[solved] Network-Manager automatically disconnects after 20 seconds

clogwog

New Member
Joined
Oct 25, 2021
Messages
5
Reaction score
0
Credits
46
I have a Quectel EG25-G setup but whenever I connect (right after a reboot) it connects for 20 seconds and then disconnects.
It happens at the
Jun 24 04:59:32 linux NetworkManager[5093]: <info> [1656046772.4569] device (ttyUSB2): state change: activated -> failed (reason 'modem-no-carrier', sys-iface-state: 'managed') Jun 24 04:59:32 linux NetworkManager[5093]: <warn> [1656046772.4677] device (ttyUSB2): Activation: failed for connection 'telstra'
point but I can't read why this is happening.

Can someone point me in the right direction please ? (Even if that means this is not the right forum ?)

[email protected]:~$ sudo cat /etc/NetworkManager/system-connections/telstra [sudo] password for nvidia: [connection] id=telstra uuid=9ae31580-093b-45ec-8b8c-3c22e7eca76f type=gsm permissions= [gsm] apn=telstra.internet number=*99# password-flags=1 [ipv4] dns-search= method=auto [ipv6] addr-gen-mode=stable-privacy dns-search= ip6-privacy=0 method=auto




[email protected]:~$ journalctl -u NetworkManager -f & [1] 7916 [email protected]:~$ ping google.com &-- Logs begin at Fri 2022-06-24 04:58:32 UTC. -- Jun 24 04:58:39 localhost.localdomain NetworkManager[5093]: <info> [1656046719.0549] device (l4tbr0): Activation: starting connection 'l4tbr0' (73df77e3-1d83-4794-afcb-e6079b37272b) Jun 24 04:58:39 localhost.localdomain NetworkManager[5093]: <info> [1656046719.0575] device (l4tbr0): state change: disconnected -> prepare (reason 'none', sys-iface-state: 'external') Jun 24 04:58:39 localhost.localdomain NetworkManager[5093]: <info> [1656046719.0602] device (l4tbr0): state change: prepare -> config (reason 'none', sys-iface-state: 'external') Jun 24 04:58:39 localhost.localdomain NetworkManager[5093]: <info> [1656046719.0609] device (l4tbr0): state change: config -> ip-config (reason 'none', sys-iface-state: 'external') Jun 24 04:58:39 localhost.localdomain NetworkManager[5093]: <info> [1656046719.0612] device (l4tbr0): state change: ip-config -> ip-check (reason 'none', sys-iface-state: 'external') Jun 24 04:58:39 localhost.localdomain NetworkManager[5093]: <info> [1656046719.0628] device (l4tbr0): state change: ip-check -> secondaries (reason 'none', sys-iface-state: 'external') Jun 24 04:58:39 localhost.localdomain NetworkManager[5093]: <info> [1656046719.0636] device (l4tbr0): state change: secondaries -> activated (reason 'none', sys-iface-state: 'external') Jun 24 04:58:39 localhost.localdomain NetworkManager[5093]: <info> [1656046719.0681] device (l4tbr0): Activation: successful, device activated. Jun 24 04:58:41 localhost.localdomain NetworkManager[5093]: <info> [1656046721.6864] manager: startup complete Jun 24 04:58:43 localhost.localdomain NetworkManager[5093]: <info> [1656046723.1537] bluez: use BlueZ version 5 [2] 7917 [email protected]:~$ ping: google.com: Name or service not known Jun 24 04:59:01 localhost.localdomain NetworkManager[5093]: <info> [1656046741.7954] modem["ttyUSB2"]: modem state changed, 'disabled' --> 'enabling' (reason: user preference) Jun 24 04:59:01 localhost.localdomain NetworkManager[5093]: <info> [1656046741.7970] manager: (ttyUSB2): new Broadband device (/org/freedesktop/NetworkManager/Devices/10) Jun 24 04:59:01 localhost.localdomain NetworkManager[5093]: <info> [1656046741.7976] device (ttyUSB2): state change: unmanaged -> unavailable (reason 'managed', sys-iface-state: 'external') Jun 24 04:59:01 localhost.localdomain NetworkManager[5093]: <info> [1656046741.7983] device (ttyUSB2): modem state 'enabling' Jun 24 04:59:01 localhost.localdomain NetworkManager[5093]: <info> [1656046741.7997] device (ttyUSB2): state change: unavailable -> disconnected (reason 'none', sys-iface-state: 'managed') Jun 24 04:59:01 localhost.localdomain NetworkManager[5093]: <info> [1656046741.8004] policy: auto-activating connection 'telstra' Jun 24 04:59:01 localhost.localdomain NetworkManager[5093]: <info> [1656046741.8025] device (ttyUSB2): Activation: starting connection 'telstra' (9ae31580-093b-45ec-8b8c-3c22e7eca76f) Jun 24 04:59:01 localhost.localdomain NetworkManager[5093]: <info> [1656046741.8030] device (ttyUSB2): state change: disconnected -> prepare (reason 'none', sys-iface-state: 'managed') Jun 24 04:59:01 localhost.localdomain NetworkManager[5093]: <info> [1656046741.8032] manager: NetworkManager state is now CONNECTING Jun 24 04:59:02 localhost.localdomain NetworkManager[5093]: <info> [1656046742.5602] modem["ttyUSB2"]: modem state changed, 'enabling' --> 'enabled' (reason: user-requested) Jun 24 04:59:02 localhost.localdomain NetworkManager[5093]: <info> [1656046742.6982] modem["ttyUSB2"]: modem state changed, 'enabled' --> 'registered' (reason: unknown) Jun 24 04:59:02 localhost.localdomain NetworkManager[5093]: <info> [1656046742.7381] modem["ttyUSB2"]: modem state changed, 'registered' --> 'connecting' (reason: user-requested) Jun 24 04:59:02 localhost.localdomain NetworkManager[5093]: <info> [1656046742.8055] modem["ttyUSB2"]: modem state changed, 'connecting' --> 'connected' (reason: user-requested) Jun 24 04:59:02 localhost.localdomain NetworkManager[5093]: <warn> [1656046742.8173] device (ttyUSB2): ip-ifname: set ifname 'ttyUSB2', unknown ifindex Jun 24 04:59:02 localhost.localdomain NetworkManager[5093]: <info> [1656046742.8177] device (ttyUSB2): state change: prepare -> config (reason 'none', sys-iface-state: 'managed') Jun 24 04:59:02 localhost.localdomain NetworkManager[5093]: <info> [1656046742.8183] device (ttyUSB2): state change: config -> ip-config (reason 'none', sys-iface-state: 'managed') Jun 24 04:59:02 localhost.localdomain NetworkManager[5093]: <warn> [1656046742.8190] device (ttyUSB2): interface ttyUSB2 not up for IP configuration Jun 24 04:59:02 localhost.localdomain NetworkManager[5093]: <info> [1656046742.8191] modem["ttyUSB2"]: using modem-specified IP timeout: 20 seconds Jun 24 04:59:02 localhost.localdomain NetworkManager[5093]: <info> [1656046742.8253] loaded PPP plugin /usr/lib/aarch64-linux-gnu/NetworkManager/libnm-ppp-plugin.so Jun 24 04:59:02 localhost.localdomain NetworkManager[5093]: <info> [1656046742.8264] ppp-manager: starting PPP connection Jun 24 04:59:02 localhost.localdomain NetworkManager[5093]: <info> [1656046742.8317] ppp-manager: pppd started with pid 7929 Jun 24 04:59:02 localhost.localdomain pppd[7929]: Plugin /usr/lib/pppd/2.4.7/nm-pppd-plugin.so loaded. Jun 24 04:59:02 localhost.localdomain NetworkManager[5093]: Plugin /usr/lib/pppd/2.4.7/nm-pppd-plugin.so loaded. Jun 24 04:59:02 localhost.localdomain pppd[7929]: nm-ppp-plugin: (plugin_init): initializing Jun 24 04:59:02 localhost.localdomain pppd[7929]: pppd 2.4.7 started by root, uid 0 Jun 24 04:59:02 localhost.localdomain pppd[7929]: nm-ppp-plugin: (nm_phasechange): status 3 / phase 'serial connection' Jun 24 04:59:02 localhost.localdomain pppd[7929]: Using interface ppp0 Jun 24 04:59:02 localhost.localdomain pppd[7929]: Connect: ppp0 <--> /dev/ttyUSB2 Jun 24 04:59:02 localhost.localdomain pppd[7929]: nm-ppp-plugin: (nm_phasechange): status 5 / phase 'establish' Jun 24 04:59:02 localhost.localdomain NetworkManager[5093]: Using interface ppp0 Jun 24 04:59:02 localhost.localdomain NetworkManager[5093]: Connect: ppp0 <--> /dev/ttyUSB2 Jun 24 04:59:02 localhost.localdomain NetworkManager[5093]: <info> [1656046742.8628] manager: (ppp0): new Ppp device (/org/freedesktop/NetworkManager/Devices/11) Jun 24 04:59:02 localhost.localdomain pppd[7929]: nm-ppp-plugin: (nm_phasechange): status 6 / phase 'authenticate' Jun 24 04:59:02 localhost.localdomain pppd[7929]: nm-ppp-plugin: (get_credentials): passwd-hook, requesting credentials... Jun 24 04:59:02 localhost.localdomain pppd[7929]: nm-ppp-plugin: (get_credentials): got credentials from NetworkManager Jun 24 04:59:02 localhost.localdomain pppd[7929]: CHAP authentication succeeded Jun 24 04:59:02 localhost.localdomain pppd[7929]: CHAP authentication succeeded Jun 24 04:59:02 localhost.localdomain pppd[7929]: nm-ppp-plugin: (nm_phasechange): status 8 / phase 'network' Jun 24 04:59:02 localhost.localdomain NetworkManager[5093]: CHAP authentication succeeded Jun 24 04:59:02 localhost.localdomain NetworkManager[5093]: <info> [1656046742.8875] devices added (path: /sys/devices/virtual/net/ppp0, iface: ppp0) Jun 24 04:59:02 localhost.localdomain NetworkManager[5093]: <info> [1656046742.8875] device added (path: /sys/devices/virtual/net/ppp0, iface: ppp0): no ifupdown configuration found. Jun 24 04:59:02 localhost.localdomain pppd[7929]: Could not determine remote IP address: defaulting to 10.64.64.64 Jun 24 04:59:02 localhost.localdomain NetworkManager[5093]: Could not determine remote IP address: defaulting to 10.64.64.64 Jun 24 04:59:02 localhost.localdomain pppd[7929]: local IP address 10.247.106.201 Jun 24 04:59:02 localhost.localdomain NetworkManager[5093]: local IP address 10.247.106.201 Jun 24 04:59:02 localhost.localdomain NetworkManager[5093]: remote IP address 10.64.64.64 Jun 24 04:59:02 localhost.localdomain NetworkManager[5093]: primary DNS address 101.168.244.101 Jun 24 04:59:02 localhost.localdomain NetworkManager[5093]: secondary DNS address 101.168.244.103 Jun 24 04:59:02 localhost.localdomain pppd[7929]: nm-ppp-plugin: (nm_phasechange): status 9 / phase 'running' Jun 24 04:59:02 localhost.localdomain pppd[7929]: remote IP address 10.64.64.64 Jun 24 04:59:02 localhost.localdomain pppd[7929]: nm-ppp-plugin: (nm_ip_up): ip-up event Jun 24 04:59:02 localhost.localdomain pppd[7929]: primary DNS address 101.168.244.101 Jun 24 04:59:02 localhost.localdomain pppd[7929]: nm-ppp-plugin: (nm_ip_up): sending IPv4 config to NetworkManager... Jun 24 04:59:02 localhost.localdomain pppd[7929]: secondary DNS address 101.168.244.103 Jun 24 04:59:02 localhost.localdomain NetworkManager[5093]: <info> [1656046742.9212] ppp-manager: (IPv4 Config Get) reply received. Jun 24 04:59:02 localhost.localdomain NetworkManager[5093]: <info> [1656046742.9268] device (ppp0): state change: unmanaged -> unavailable (reason 'connection-assumed', sys-iface-state: 'external') Jun 24 04:59:02 localhost.localdomain NetworkManager[5093]: <info> [1656046742.9297] device (ttyUSB2): state change: ip-config -> ip-check (reason 'none', sys-iface-state: 'managed') Jun 24 04:59:02 localhost.localdomain NetworkManager[5093]: <info> [1656046742.9341] device (ppp0): state change: unavailable -> disconnected (reason 'none', sys-iface-state: 'external') Jun 24 04:59:02 localhost.localdomain NetworkManager[5093]: <info> [1656046742.9350] device (ttyUSB2): state change: ip-check -> secondaries (reason 'none', sys-iface-state: 'managed') Jun 24 04:59:02 localhost.localdomain NetworkManager[5093]: <info> [1656046742.9356] device (ttyUSB2): state change: secondaries -> activated (reason 'none', sys-iface-state: 'managed') Jun 24 04:59:02 localhost.localdomain NetworkManager[5093]: <info> [1656046742.9359] manager: NetworkManager state is now CONNECTED_LOCAL Jun 24 04:59:02 localhost.localdomain NetworkManager[5093]: <info> [1656046742.9387] manager: NetworkManager state is now CONNECTED_SITE Jun 24 04:59:02 localhost.localdomain NetworkManager[5093]: <info> [1656046742.9391] policy: set 'telstra' (ppp0) as default for IPv4 routing and DNS Jun 24 04:59:02 localhost.localdomain NetworkManager[5093]: <info> [1656046742.9437] device (ttyUSB2): Activation: successful, device activated. Jun 24 04:59:03 localhost.localdomain NetworkManager[5093]: <info> [1656046743.1280] policy: set-hostname: set hostname to 'linux' (from address lookup) Jun 24 04:59:03 linux NetworkManager[5093]: <info> [1656046743.9009] manager: NetworkManager state is now CONNECTED_GLOBAL Jun 24 04:59:05 linux pppd[7929]: sif6addr: ioctl(SIOCSIFADDR): Permission denied (line 2613) Jun 24 04:59:05 linux NetworkManager[5093]: sif6addr: ioctl(SIOCSIFADDR): Permission denied (line 2613) Jun 24 04:59:05 linux NetworkManager[5093]: cif6addr: ioctl(SIOCDIFADDR): No such address Jun 24 04:59:05 linux pppd[7929]: cif6addr: ioctl(SIOCDIFADDR): No such address [2]+ Exit 2 ping google.com [email protected]:~$ [email protected]:~$ ping google.com PING google.com (172.217.24.46) 56(84) bytes of data. 64 bytes from hkg07s23-in-f14.1e100.net (172.217.24.46): icmp_seq=1 ttl=115 time=34.7 ms 64 bytes from hkg07s23-in-f14.1e100.net (172.217.24.46): icmp_seq=2 ttl=115 time=74.3 ms 64 bytes from hkg07s23-in-f14.1e100.net (172.217.24.46): icmp_seq=3 ttl=115 time=71.4 ms 64 bytes from hkg07s23-in-f14.1e100.net (172.217.24.46): icmp_seq=4 ttl=115 time=55.9 ms 64 bytes from hkg07s23-in-f14.1e100.net (172.217.24.46): icmp_seq=5 ttl=115 time=54.4 ms 64 bytes from hkg07s23-in-f14.1e100.net (172.217.24.46): icmp_seq=6 ttl=115 time=52.7 ms 64 bytes from hkg07s23-in-f14.1e100.net (172.217.24.46): icmp_seq=7 ttl=115 time=51.7 ms 64 bytes from hkg07s23-in-f14.1e100.net (172.217.24.46): icmp_seq=8 ttl=115 time=52.0 ms Jun 24 04:59:32 linux NetworkManager[5093]: <info> [1656046772.4567] modem["ttyUSB2"]: modem state changed, 'connected' --> 'registered' (reason: user-requested) Jun 24 04:59:32 linux NetworkManager[5093]: <info> [1656046772.4569] device (ttyUSB2): state change: activated -> failed (reason 'modem-no-carrier', sys-iface-state: 'managed') Jun 24 04:59:32 linux NetworkManager[5093]: <warn> [1656046772.4677] device (ttyUSB2): Activation: failed for connection 'telstra' Jun 24 04:59:32 linux NetworkManager[5093]: <info> [1656046772.4690] manager: NetworkManager state is now CONNECTED_LOCAL Jun 24 04:59:32 linux NetworkManager[5093]: <info> [1656046772.4711] device (ttyUSB2): state change: failed -> disconnected (reason 'none', sys-iface-state: 'managed') Jun 24 04:59:32 linux NetworkManager[5093]: <info> [1656046772.4955] policy: set-hostname: set hostname to 'localhost.localdomain' (no default device) Jun 24 04:59:32 linux NetworkManager[5093]: <info> [1656046772.4965] device (ppp0): state change: disconnected -> unmanaged (reason 'connection-assumed', sys-iface-state: 'external') Jun 24 04:59:32 linux NetworkManager[5093]: <info> [1656046772.4985] policy: auto-activating connection 'telstra' Jun 24 04:59:32 localhost.localdomain NetworkManager[5093]: <info> [1656046772.5016] device (ttyUSB2): Activation: starting connection 'telstra' (9ae31580-093b-45ec-8b8c-3c22e7eca76f) Jun 24 04:59:32 localhost.localdomain NetworkManager[5093]: <info> [1656046772.5035] device (ttyUSB2): state change: disconnected -> prepare (reason 'none', sys-iface-state: 'managed') Jun 24 04:59:32 localhost.localdomain NetworkManager[5093]: <info> [1656046772.5038] manager: NetworkManager state is now CONNECTING Jun 24 04:59:32 localhost.localdomain NetworkManager[5093]: <info> [1656046772.5361] modem["ttyUSB2"]: modem state changed, 'registered' --> 'connecting' (reason: user-requested) Jun 24 04:59:39 localhost.localdomain NetworkManager[5093]: <info> [1656046779.6407] modem["ttyUSB2"]: modem state changed, 'connecting' --> 'registered' (reason: user-requested) Jun 24 04:59:39 localhost.localdomain NetworkManager[5093]: <info> [1656046779.6622] modem["ttyUSB2"]: modem state changed, 'registered' --> 'connecting' (reason: user-requested) Jun 24 04:59:46 localhost.localdomain NetworkManager[5093]: <info> [1656046786.7669] modem["ttyUSB2"]: modem state changed, 'connecting' --> 'registered' (reason: user-requested) Jun 24 04:59:46 localhost.localdomain NetworkManager[5093]: <info> [1656046786.7880] modem["ttyUSB2"]: modem state changed, 'registered' --> 'connecting' (reason: user-requested) Jun 24 04:59:53 localhost.localdomain NetworkManager[5093]: <info> [1656046793.8956] modem["ttyUSB2"]: modem state changed, 'connecting' --> 'registered' (reason: user-requested) Jun 24 04:59:53 localhost.localdomain NetworkManager[5093]: <warn> [1656046793.8960] modem-broadband[ttyUSB2]: failed to connect modem: Sending command failed: 'Resource temporarily unavailable' Jun 24 04:59:53 localhost.localdomain NetworkManager[5093]: <info> [1656046793.8962] device (ttyUSB2): state change: prepare -> failed (reason 'unknown', sys-iface-state: 'managed') Jun 24 04:59:53 localhost.localdomain NetworkManager[5093]: <info> [1656046793.8971] manager: NetworkManager state is now CONNECTED_LOCAL Jun 24 04:59:53 localhost.localdomain NetworkManager[5093]: <warn> [1656046793.8988] device (ttyUSB2): Activation: failed for connection 'telstra' Jun 24 04:59:53 localhost.localdomain NetworkManager[5093]: <info> [1656046793.9007] device (ttyUSB2): state change: failed -> disconnected (reason 'none', sys-iface-state: 'managed') Jun 24 04:59:53 localhost.localdomain NetworkManager[5093]: <info> [1656046793.9028] policy: auto-activating connection 'telstra' Jun 24 04:59:53 localhost.localdomain NetworkManager[5093]: <info> [1656046793.9052] device (ttyUSB2): Activation: starting connection 'telstra' (9ae31580-093b-45ec-8b8c-3c22e7eca76f) Jun 24 04:59:53 localhost.localdomain NetworkManager[5093]: <info> [1656046793.9064] device (ttyUSB2): state change: disconnected -> prepare (reason 'none', sys-iface-state: 'managed') Jun 24 04:59:53 localhost.localdomain NetworkManager[5093]: <info> [1656046793.9072] manager: NetworkManager state is now CONNECTING Jun 24 04:59:53 localhost.localdomain NetworkManager[5093]: <info> [1656046793.9246] modem["ttyUSB2"]: modem state changed, 'registered' --> 'connecting' (reason: user-requested) Jun 24 05:00:01 localhost.localdomain NetworkManager[5093]: <info> [1656046801.0289] modem["ttyUSB2"]: modem state changed, 'connecting' --> 'registered' (reason: user-requested) Jun 24 05:00:01 localhost.localdomain NetworkManager[5093]: <info> [1656046801.0454] modem["ttyUSB2"]: modem state changed, 'registered' --> 'connecting' (reason: user-requested)
... etc...
 
Last edited:


wizardfromoz

Administrator
Staff member
Gold Supporter
Joined
Apr 30, 2017
Messages
7,326
Reaction score
6,211
Credits
25,100
Aussie Aussie Aussie Oi Oi Oi

G'day mate and a belated welcome to linux.org :)

I'm not the bloke to answer your networking questions, but we could do with some more information, including

What Linux (version and number) are you running with this baby?

It looks like an IoT device, is that so?

Also, have you checked at whirlpool.net to see if any other Aussies are having problems?

Good luck

Chris Turner
wizardfromoz
 

f33dm3bits

Gold Member
Gold Supporter
Joined
Dec 11, 2019
Messages
4,814
Reaction score
3,449
Credits
35,075
Looks like it has to with either a vpn connection or ipv6, are you using a vpn connection?
 

Tolkem

Well-Known Member
Joined
Jan 6, 2019
Messages
1,456
Reaction score
1,177
Credits
10,567
Run this in the terminal and copy/paste the output:
Code:
nmcli device show
Hide whatever sensitive/private information before posting. For more info on nmcli command run
Code:
man nmcli
 

dos2unix

Well-Known Member
Joined
May 3, 2019
Messages
1,449
Reaction score
1,055
Credits
8,957
Looks like a GSM modem. Are you trying to connect to a cell tower?
Do you have a SIM card with credentials?
 
OP
clogwog

clogwog

New Member
Joined
Oct 25, 2021
Messages
5
Reaction score
0
Credits
46
Thank you everyone.

Someone here suggested to update to the latest ModemManager like:
Code:
sudo apt-get install software-properties-common # contains add-apt-repository
sudo add-apt-repository ppa:aleksander-m/modemmanager-bionic
sudo apt-get update
sudo apt-get install modemmanager libqmi-utils libmbim-utils policykit-1
sudo reboot
and it all started working. Must have been a a ModemHandler bug in the older verision of ModemManager that the base image of NVidia comes with.
 
OP
clogwog

clogwog

New Member
Joined
Oct 25, 2021
Messages
5
Reaction score
0
Credits
46
Looks like a GSM modem. Are you trying to connect to a cell tower?
Do you have a SIM card with credentials?
it is a gsm modem, SIM is working in other devices. no credentials needed, just the apn
 
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Linux.org Hosting Donations
Consider making a donation

Members online


Top