[solved] neo2 keyboard layout won't work as expected

Dachlawine

New Member
Credits
0
Hi guys,

I'm completely new to this site but I need some urgent help, if you were so kind.
I upgraded my xubuntu distribution yesterday from 16.04 to 18.04 and now to 19.10 but the problem still persists. my keyboard worked fine under 16.04, but right after the upgrade, I would have to press the mod4-key all the time to use layer 1&2 which I didn't have to in the original installation back on 16.04. To reach layer 3, I need to hold mod4 and quickly press mod3+ designated key one after another, to get the desired result. Pressing mod3 + key simultaneously won't work. Same if the pause between pressing the keys is too long. Must be within tenths of a second.

Entry in /usr/share/X11/symbols/de (see code below) seems to look fine. Yet, it is misbehaving. :(

Held appreciated!
 
Last edited:


Dachlawine

New Member
Credits
0
Hey guys

I managed to copy the 'de' file from a live version of xubuntu 16.04 and my problem is almost solved.
Seems that "key.type[Group]" is kind of messed up. In newer versions, for alpha-numeric keys it's
EIGHT_LEVEL_LEVEL_FIVE_LOCK
but the older
EIGHT_LEVEL
works just fine! (as do the other group names!)

Now the only problem that is left is, that the CAPS_LOCK key still works as CAPS_LOCK whereas in older versions it works as mod3. If anybody knoks how to fix that, that'd be great!
 

Dachlawine

New Member
Credits
0
Problem solved.

I must have accidentally changed the "compose key" option in the keyboard settings.
Changed it back to "—" and now everything works fine!



Thanks to myself for helping me solve my problem. :D
 


Members online


Latest posts

Top