[SOLVED] I resized my EFI system partition but it didn't completely work


Well-Known Member
May 12, 2020
Reaction score
A while back, I resized the EFI system partition on my work PC (yes, I know, it seems to be the one that I mess up the most) from ~100 MB to ~300 MB using KDE Partition Manager, since it was full. However, I just realized today that it is not being detected as resized by the kernel (although KDE Partition Manager says it's 300 MB). Does anybody have any ideas why this could be happening?

It's keeping me from updating GRUB and therefore from using updated kernel versions, so it's apt to make me grouchy.

I'm on openSUSE Tumbleweed. More specs by request only. :p

Knowing you as I do, I am guessing this is a curly one or else you would have solved it yourself ;)

However to get a clearer picture
  1. Can you let us know the output of
  2. Code:
    sudo blkid | grep -i "/dev/sdxy"
    # where xy is the device and partition number for your ESP
  3. From KDE Partition Manager (you may need to right click in the Columns header and check Flags) a look at the relevant drive, and
  4. Right click the ESP and give us the Properties popup window content
  5. Output from /etc/fstab


so it's apt to make me grouchy.

... and here I thought openSUSE used zypper, not apt :)
C'mon Mr Cranky Pants, put a smile on your dial :)
I am enjoying my weekend, so no output until Monday.
Knowing you as I do, I am guessing this is a curly one or else you would have solved it yourself

Right on there. I tend to try to fix my own problems.
... and here I thought openSUSE used zypper, not apt :)
If great minds think alike, then we must have great minds!

C'mon Mr Cranky Pants, put a smile on your dial :)
Of course... It's the weekend! So, to borrow your famous farewell...

Phew, you let me off the hook for now, and totally understand weekends :)

c u (on my) tomorrow.

i'm wondering what would happend if you re-installed grub rather than just updating ?
Whoopdedoo, it's Monday. Here's the state of affairs:

@wizardfromoz: Here's what you wanted:

loren@optiplex:~$ sudo blkid | grep -i "/dev/sda"                    
/dev/sda2: UUID="54975df9-53bf-42e5-a3f2-eb4e8ecd90a5" UUID_SUB="a81fc99b-91d2-4fa3-bd8b-cf97980c5869" BLOCK_SIZE="4096" TYPE="btrfs" PARTUUID="4e239d09-4464-4d75-8c50-5c749b96d9c8"
/dev/sda1: UUID="1AF7-0AC6" BLOCK_SIZE="512" TYPE="vfat" PARTUUID="22206904-2250-4a08-85e3-ac8326d0f5d9"

Screenshot attached below.

loren@optiplex:~$ cat /etc/fstab  
UUID=54975df9-53bf-42e5-a3f2-eb4e8ecd90a5  /                       btrfs  defaults                      0  0
UUID=54975df9-53bf-42e5-a3f2-eb4e8ecd90a5 /var btrfs subvol=/@/var 0 0
UUID=54975df9-53bf-42e5-a3f2-eb4e8ecd90a5 /usr/local btrfs subvol=/@/usr/local 0 0
UUID=54975df9-53bf-42e5-a3f2-eb4e8ecd90a5 /srv btrfs subvol=/@/srv 0 0
UUID=54975df9-53bf-42e5-a3f2-eb4e8ecd90a5 /root btrfs subvol=/@/root 0 0
UUID=54975df9-53bf-42e5-a3f2-eb4e8ecd90a5 /opt btrfs subvol=/@/opt 0 0
UUID=54975df9-53bf-42e5-a3f2-eb4e8ecd90a5 /home btrfs subvol=/@/home 0 0
UUID=54975df9-53bf-42e5-a3f2-eb4e8ecd90a5 /boot/grub2/x86_64-efi btrfs subvol=/@/boot/grub2/x86_64-efi 0 0
UUID=54975df9-53bf-42e5-a3f2-eb4e8ecd90a5 /boot/grub2/i386-pc btrfs subvol=/@/boot/grub2/i386-pc 0 0
UUID=1AF7-0AC6 /boot/efi vfat utf8 0 2
UUID=54975df9-53bf-42e5-a3f2-eb4e8ecd90a5 /.snapshots btrfs subvol=/@/.snapshots 0 0

@captain-sensible: I could try, I guess, but I don't really want to trash my bootloader, just 'cuz... ya know... Anyway, I may have to back up the boot partition and reinstall if that's what it takes.


  • Screenshot_20210920_124250.png
    75.7 KB · Views: 374
actually something you can do as a fail safe get rEFInd onto a usb stick . use the attached zip , unzip it and burn to a usb . When you boot from that usb rEFInd will help boot any uefi I've tested it on both Windows10 and slackware and will boot both. That should get you out of a fix

refind-flashdrive-0.12.0.img is the bit you need so its going to be if (input file ) of (output file)

So its going to be :
dd bs=4 if=/path/to/refind-flashdrive-0.12.0.img of=/dev/sdx status=progress && sync
//where /dev/sdx is what fdisk -l reveals for your usb


  • refind-flashdrive-0.12.0.zip
    1.9 MB · Views: 407
Last edited:
Ta Loren for that info :), and I quite like Andy's contribution on rEFInd as an interim solution. :)

Loren have openSUSE ever got over their opposition to allowing for a Live CD approach, or is it still a case of you have to install it to use it?

It's one of the attractions I have for Member Sam's @GeckoLinux 's Gecko Linux, is that both the Tumbleweeds and Leap options allow for Live.

Why I ask is as a tool for you to use should something go wrong.

You will know as well as I that you can have more than one (1) ESP on the same drive, although typically unnecessary.

I am brainstorming as to whether there might be benefit from following the following:
  1. Create a new ESP - 300 MB or whatever
  2. Comment out the current line for ESP in /etc/fstab and add to it directions to the new ESP
  3. Update grub if it allows, and in any event
  4. Reboot and see how you go
If Grub cannot be updated report here on any error message/s

I don't use BTRFS so that is a weakness on my contributions.


that makes sense... Chris but i think if its a new esp is grub going to need to be installed to new esp ?

Then edit /etc/fstab with output of new uuid from blkid ; put new uuid into /etc/fstab

A new esp could for instance be put at end , if linux partition could be shrunk slightly, i've done thayt bit with gParted and got away with it
Loren have openSUSE ever got over their opposition to allowing for a Live CD approach, or is it still a case of you have to install it to use it?
I actually have a Live USB version of openSUSE available; they prefer a non-live disk, but make live versions available.

Hmm. I think that the idea of trying a second ESP is interesting, to be sure. In that case, I could in just spin up a live CD/USB to fix my fstab if the second one doesn't work. I may try that at some point. Currently, however, I have other things to do on this PC.
Of course, you could always put on a fresh install, use Guided Partitioning to set the FS default to EXT4 over BTRFS, and once installed, install Timeshift and never have another problem :)

I'll leave you to it and stop muddying the waters, but I will be interested to see how you go.


All right, a bit of an update...

I decided to follow Wiz's suggestion (although not exactly). I backed up my EFI partition from an openSUSE live USB and then deleted it. Then I created a new one in that empty space and copied the files from the backup to the new partition. After that, I ran the live USB's Upgrade option. Basically, this just did a package upgrade on my system, but it also allowed me to pick the new boot partition. I rebooted and found that everything worked except for one small problem: I hadn't updated /etc/fstab, so Linux couldn't find the boot partition and so dropped me to an emergency shell. I fixed fstab from there, rebooted, and everything has been just peachy ever since. (Except for the fact that Opera is misbehaving, but that's an entirely different story.)

Staff online

Members online