Solved!!! I am having some issues getting Linux installed.

I think you ran against a wall with the "boot" thing. There is no "boot" that is needed to install any os. Your hard-drive where you install the OS on needs a MBR Master Boot Record. It's created DURING the install. You may have remains of a failed grub installation but you don't need to repair that with grub commands. We don't know exactly "where" your PC is but it doesn't matter for installing an OS. Burn any OS Image to USB and boot it up. If you reach a Desktop write here, if not write the errors EXACTLY as they occur.
One user hinted to switch to legacy mode (for peppermint). Did that help? Does ubuntu or any other distro boot to a live Desktop?
My New disk arrived. Peppermint 11 opened with the usual "Utilities Recovery" page. It still would not install but Surprise!, Surprise! MX Linux installed perfectly best as I can tell. (I even tried this with the broken disk - I think it has a permanent error) Since Peppermint didn't work, I expected the usual crash at 97% in MX. I followed a youtube tutorial to install it using the new UEFI GPT method and it went perfectly. Last time I had MX on this computer it was the usual runaround the [so common] "acpi" bug. This time, it starts up perfectly with no runaround. It runs perfectly so far. It shuts down. As much as I love Peppermint, I am happy to trade Peppermint for a systemd free OS that works.

So, now that I finally have a working computer, I decided to try a new system on the old one. Once, again, Peppermint 11 would not install. I think it might be a hardware issue. Both computers are essentially the same. They are sold as Linux friendly but I can't see any other reason. I decided to install Zorin as that was the system I was going to try when I found out my "new" computer was broken.

It also installed perfectly and for the first time in 2 years, it also boots with no runaround. It is running perfectly and shutting down. [The check says I am missing this file -/var/log/Xorg.0.log] Otherwise, it didn't show any problems. Now that my new computer is working, I will mostly be using this one for banking. If I don't keep their cookie on my computer, they insist on sending me a code. The bank also works with only a few browsers so I have to keep Firefox on this computer which I won't have on my new one.

I'll see how it goes but so far so good. Hoping for the best.
It has been 5 weeks now.....and I think I have figured out a couple of things - "with some help". I mentioned earlier that I thought there might be a hardware compatibility problem. I think that is "one" of the problems. My "older" computer stopped working properly when I upgraded to Ubuntu 20.04. I tried to find the solution. It seemed to be a very common complaint amongst Ubuntu users that the OS would not shut down cleanly. I was having the same problem.

It was brought to my attention that my older Celeron processor might be the problem. I think they are right. I used to get frequent errors that a CPU core paused for 20 seconds or some other time. I never get that now. I think the reason is that Zorin is based on Ubuntu 18.04 and is working absolutely perfectly. It never freezes, crashes, etc. It always shuts down properly. I think the processor is not quite up to snuff for 20.04 and beyond. I don't know why it is still for sale.

The new computer with MX Linux works very well.....but not perfectly. I am guessing it would work perfectly with an older version or new CPU. I have seen the same CPU core paused error on this computer but only 2 times. I decided to fire up my "really old" 32 bit and installed Bodhi. It works pretty well but I think I am going to try to find a new Pentium CPU. I didn't buy a new computer to use software for older computers. Because I use Linux, I have always been able to use cheaper hardware but I think the new CPU might be well worth buying.
I am guessing there is something I should click to close this thread. If not, it can be closed. Anyhow, both computers are working. They boot on both machines is working. I just can't install many current distros. Yesterday, after many months of looking at Emmabuntus, I finally decided to give that a try. I have to be honest - the only reason I keep finding myself attracted to that distro is the name. It takes me back 27 years to when I needed to have a favorite Spice Girl. Mine was Emma Bunton. I thought I was not a good enough reason to try a distro. Well, let me tell you, I was wrong. It is working just as perfectly as Zorin does. It is very bloated but I read about that on distrowatch so I was prepared to remove a lot of software. It says it is XFCE but honestly, it looks more like Pantheon at the moment. I haven't fiddled with how it looks too much but very impressed.
Emmabuntis, is what it is, a distribution built to run on both 32&64 bit processor, but contains nearly all the drivers required to on anything from a P1 upwards, so the installation download is huge in comparison to others, But like any other distribution you can hack it about as much as you like, to make it your own.

If you're now happy, please go to your first post, click edit and add "SOLVED" to the title

Latest posts