(solved)Externanl DVD / BlueRay for Debian 11

vikozo

Member
Joined
Dec 30, 2021
Messages
54
Reaction score
12
Credits
442
Hello

i have two older Externanl DVD and BlueDisc Player.
They worked with my older Windows, but not working with my new Laptop and Debian 11

with BlueRay Buffalo BRXL-PT6U2V Serie
just DVD Portable Writet Samsung Model SW-208 (Sep. 2013)

Because both are obviously old, the question would be - a nice newer Hardware!
To be able to Rip my DVD and BlueRay

Thanks for your Feedbacks
have a nice day
vinc
 


A Pioneer BDR-XD07TB USB3.0 Blu-ray drive works out-of-the-box with Xubuntu so presumably will also be fine with Debian 11. For ripping, you could use MakeMKV for Blu-ray and Handbrake for DVD.
 
I am a little surprised that the external drives you have already don't just work out of the box. It may be pure luck, but I've never had one fail and I've owned/own at least a few of them because I keep misplacing them/giving them away to someone who needs one.

Have you tried plugging them in and running lscpu - and then seeing if there are drivers available (assuming the devices are reported).
 
@KGIII Hello
hope you mean lsusb there it is like this
Bus 001 Device 008: ID 0411:028e BUFFALO INC. (formerly MelCo., Inc.) BUFFALO Optical Drive

but not recognizes by dolphin
 
Last edited:
That's exactly what I'm looking for... And yeah, I meant lsusb - good catch! (It's an interesting day.)

It sees it as an optical drive. I did some looking and folks seem to have the same experiences as I - they normally just work. If you open it up and put a disk in it, does it appear in 'lsblk' (I got it right this time!)?

Or, more my question, have you tried mounting it?
 
no i did not mount it speziali.

but created a /media/dvd
sudo mount /dev/sr0 /media/dvd

starts reading and then i just hang

ls -lt
lrwxrwxrwx 1 root root 3 21. Mär 20:18 cdrom -> sr0
lrwxrwxrwx 1 root root 3 21. Mär 20:18 cdrw -> sr0
lrwxrwxrwx 1 root root 3 21. Mär 20:18 dvd -> sr0
lrwxrwxrwx 1 root root 3 21. Mär 20:18 dvdrw -> sr0
brw-rw----+ 1 root cdrom 11, 0 21. Mär 20:18 sr0
 
Huh... I hate the thought of you having to buy another drive but I suppose the brands you have may just not work with Linux. I was unable to find any specific drivers 'cause these things usually just mount and work.

That's really unfortunate.
 
yes i think the same
just the Buffalo connected and booting the laptop make a kernel error and stop.
remove pover off and on and lucky it reboots
 


Top