[SOLVED] enable trash bin on mounted NTFS partitions

Shmu26

Member
Credits
421
I have a NTFS partition that is automounted, and I want to enable trash bin. Right now, I can only permanently delete from it. The partition is
Code:
/mnt/4C74491474490266
How to configure it on Ubuntu 20.04?
My fstab looks like this:

Code:
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda6 during installation
UUID=cc0bcd2b-8de9-4f91-9f7e-e14c57eaf3a8 /               ext4    errors=remount-ro 0       1
# /boot/efi was on /dev/sda2 during installation
UUID=2641-384E  /boot/efi       vfat    umask=0077      0       1
#/swapfile                                 none            swap    sw              0       0
/dev/disk/by-uuid/4C74491474490266 /mnt/4C74491474490266 auto nosuid,nodev,nofail,x-gvfs-show 0 0
/dev/disk/by-uuid/5280463C80462737 /mnt/5280463C80462737 auto nosuid,nodev,nofail,x-gvfs-show 0 0
/dev/disk/by-uuid/22EC446AEC4439F5 /mnt/22EC446AEC4439F5 auto nosuid,nodev,nofail,x-gvfs-show 0 0
/dev/disk/by-uuid/defdd9c3-1900-4bf9-b4a5-ea05e62d0304 /mnt/defdd9c3-1900-4bf9-b4a5-ea05e62d0304 auto nosuid,nodev,nofail,x-gvfs-show 0 0
 
Last edited:


Tolkem

Well-Known Member
Credits
4,561
I have a NTFS partition that is automounted, and I want to enable trash bin. Right now, I can only permanently delete from it. The partition is
Code:
/mnt/4C74491474490266
How to configure it on Ubuntu 20.04?
My fstab looks like this:

Code:
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda6 during installation
UUID=cc0bcd2b-8de9-4f91-9f7e-e14c57eaf3a8 /               ext4    errors=remount-ro 0       1
# /boot/efi was on /dev/sda2 during installation
UUID=2641-384E  /boot/efi       vfat    umask=0077      0       1
#/swapfile                                 none            swap    sw              0       0
/dev/disk/by-uuid/4C74491474490266 /mnt/4C74491474490266 auto nosuid,nodev,nofail,x-gvfs-show 0 0
/dev/disk/by-uuid/5280463C80462737 /mnt/5280463C80462737 auto nosuid,nodev,nofail,x-gvfs-show 0 0
/dev/disk/by-uuid/22EC446AEC4439F5 /mnt/22EC446AEC4439F5 auto nosuid,nodev,nofail,x-gvfs-show 0 0
/dev/disk/by-uuid/defdd9c3-1900-4bf9-b4a5-ea05e62d0304 /mnt/defdd9c3-1900-4bf9-b4a5-ea05e62d0304 auto nosuid,nodev,nofail,x-gvfs-show 0 0
You can try editing your FSTAB file by adding this
Code:
defaults,nls=utf8,umask=0222,uid=1000,gid=1000
remember to umount the partition first, once finished editing the file, mount the partition back.
 

Shmu26

Member
Credits
421
I unmounted, edited fstab so that line now says
Code:
/dev/disk/by-uuid/4C74491474490266 /mnt/4C74491474490266 auto nosuid,nodev,nofail,x-gvfs-show 0 0 defaults,nls=utf8,umask=0222,uid=1000,gid=1000
and remounted
but still can't trash files
 

Tolkem

Well-Known Member
Credits
4,561
I unmounted, edited fstab so that line now says
Code:
/dev/disk/by-uuid/4C74491474490266 /mnt/4C74491474490266 auto nosuid,nodev,nofail,x-gvfs-show 0 0 defaults,nls=utf8,umask=0222,uid=1000,gid=1000
and remounted
but still can't trash files
You need to edit the file so it looks like this:
Code:
/dev/disk/by-uuid/4C74491474490266 /mnt/4C74491474490266 ntfs defaults,nls=utf8,umask=0222,uid=1000,gid=1000
 

Shmu26

Member
Credits
421
You need to edit the file so it looks like this:
Code:
/dev/disk/by-uuid/4C74491474490266 /mnt/4C74491474490266 ntfs defaults,nls=utf8,umask=0222,uid=1000,gid=1000
Did it, and remounted.
Now, Nautilus can't see the partition anymore.
Nautilus can see it, it just doesn't show in the list of "Other Locations", it is hidden inside /mnt.
But I still can't trash files. In fact, I can't even permanently delete them anymore.
 
Last edited:

Tolkem

Well-Known Member
Credits
4,561
So it turns out the winning incantation is
Code:
/dev/disk/by-uuid/4C74491474490266 /mnt/4C74491474490266 ntfs-3g users,uid=1000,dmask=027,fmask=137,x-gvfs-show,utf8 0 0
It seems that Ubuntu 20.04 uses a new NTFS driver, so the syntax changed.
I got it from here: https://askubuntu.com/questions/1235979/creating-trash-for-shared-ntfs-partition
Nice finding. Glad you solved it. I have a NTFS USB drive, and those options I suggested works fine for me, though I usually just delete files for good thus the trash bin is really not used that much.
 
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Staff online

Members online


Latest posts

Top