SOLVED: Cannot run Puppy Linux from a CD on a default Latitude 4320 Dell. Is this possible?

Meta Master

New Member
Credits
242
I want to run Puppy Linux on a default Latitude 4320 Dell.

I am receiving the message "Invalid partition table!" after which pressing enter takes me to GRUB where I then type reboot to exit.

Current changes to default BIOS setup settings are that I have a password set, and I have it set to Legacy Mode in order to detect the CD.

How do I run Puppy Linux from a CD on a default Latitude 4320 Dell?

Additional Note: There is no Windows Boot Manager. Default settings were enabled prior to the mentioned changes to the BIOS setup settings.
 


Meta Master

New Member
Credits
242

Meta Master

New Member
Credits
242
Additional Problem

I see the message "Invalid partition table!" when the laptop is run without any disc or USB connected. There is no OS on the computer outside the BIOS/grub basic stuff.
 

stan

Member
Credits
570
Having the same problem among so many different distros sounds like a hardware issue. A little Google hinted at this possible fix:

1. Ensure Secure Boot is off and Legacy mode is enabled. It sounds like you have done this already.

2. Boot on your Ubuntu USB (not install, just boot if it can). Use Gparted to change your hard drive from device type GPT to msdos. Create a new partition (FAT32 or ext4) and format the partition. Then also set the partition with a boot flag, even though there is no OS installed.

3. Exit Gparted, reboot into your Puppy CD and see if it is better.

4. If still a problem, check BIOS setting for "sata controller" and be sure it is AHCI, not RAID. (This one is a shot in the dark. I hope the above steps work.)
 
Last edited:

Meta Master

New Member
Credits
242
Partially Solved -Will Update Later

Below quoted post helped my figure out the solution.

I created an Ubuntu that boots off my USB through use of the Rufus USB-writing software, and that bootable also offered to turn my OS-less computer into an Ubuntu system via installation, which I agreed to. In turn, this act of installation fixed the partition table. This made gparting unnecessary.

Have not yet loaded the Puppy Linux disc after having fixed this matter. Will be trying that next.

Having the same problem among so many different distros sounds like a hardware issue. A little Google hinted at this possible fix:

1. Ensure Secure Boot is off and Legacy mode is enabled. It sounds like you have done this already.

2. Boot on your Ubuntu USB (not install, just boot if it can). Use Gparted to change your hard drive from device type GPT to msdos. Create a new partition (FAT32 or ext4) and format the partition. Then also set the partition with a boot flag, even though there is no OS installed.

3. Exit Gparted, reboot into your Puppy CD and see if it is better.

4. If still a problem, check BIOS setting for "sata controller" and be sure it is AHCI, not RAID. (This one is a shot in the dark. I hope the above steps work.)
 

Meta Master

New Member
Credits
242
Having the same problem among so many different distros sounds like a hardware issue. A little Google hinted at this possible fix:

1. Ensure Secure Boot is off and Legacy mode is enabled. It sounds like you have done this already.

2. Boot on your Ubuntu USB (not install, just boot if it can). Use Gparted to change your hard drive from device type GPT to msdos. Create a new partition (FAT32 or ext4) and format the partition. Then also set the partition with a boot flag, even though there is no OS installed.

3. Exit Gparted, reboot into your Puppy CD and see if it is better.

4. If still a problem, check BIOS setting for "sata controller" and be sure it is AHCI, not RAID. (This one is a shot in the dark. I hope the above steps work.)
Problem Persists

Even when entering the boot menu and manually selecting the CD, I receive the message:

"Selected boot device failed. Press any key to reboot the system."
 

stan

Member
Credits
570
I created an Ubuntu that boots off my USB through use of the Rufus USB-writing software, and that bootable also offered to turn my OS-less computer into an Ubuntu system via installation, which I agreed to. In turn, this act of installation fixed the partition table. This made gparting unnecessary.
Okay, good. You indicated earlier (post #2) that Ubuntu would not install due to the "invalid partition table" error. And you don't say exactly, but I guess that Rufus was a different method to make your Ubuntu USB than what you had used before when it failed.

About your Puppy CD:
Even when entering the boot menu and manually selecting the CD, I receive the message:
"Selected boot device failed. Press any key to reboot the system."
That error sounds like it just does not recognize the CD. Can this be a similar problem in that you may need to use a different program to create your CD? I find Brasero to be very simple and effective for burning .iso files to CD/DVD media.

You might also try to burn Puppy to a USB instead. Rufus may work well for this too, but keep in mind that some Linux distros have problems with some different burning programs. So while Rufus works sometimes, it may not work all the time. Be prepared to try other methods if you keep having trouble. BalenaEtcher is another very good program and is available for both Windows and Linux.
 
Last edited:

Meta Master

New Member
Credits
242
Okay, good. You indicated earlier (post #2) that Ubuntu would not install due to the "invalid partition table" error. And you don't say exactly, but I guess that Rufus was a different method to make your Ubuntu USB than what you had used before when it failed.

About your Puppy CD:

That error sounds like it just does not recognize the CD. Can this be a similar problem in that you may need to use a different program to create your CD? I find Brasero to be very simple and effective for burning .iso files to CD/DVD media.

You might also try to burn Puppy to a USB instead. Rufus may work well for this too, but keep in mind that some Linux distros have problems with some different burning programs. So while Rufus works sometimes, it may not work all the time. Be prepared to try other methods if you keep having trouble. BalenaEtcher is another very good program and is available for both Windows and Linux.
I used the build-in mac disk utility to burn the CD. I used Windows to burn the AOMEI Partition Assistant by using its wizard to burn it to a CD which I did successfully boot off the CD without an OS. This is because it forces the computer to run a UEFI for the CD even when set to legacy, and then runs off of a lite version of Windows.

Puppy Linux meanwhile does not force a UEFI environment.

The point of Puppy Linux is it's small, so I want to run it off a CD as it's one of the few Linux distros left that runs off as small a storage capacity as a CD. There's a novel appeal to it for me so running off a USB while probably more sensible would defeat the purpose.

It is possible Mac somehow botched the burning process though I don't know why it would.
 

stan

Member
Credits
570
It is possible Mac somehow botched the burning process though I don't know why it would.
Test your Puppy CD on other computers. If it works, then the Dell is still likely your trouble, whether it is UEFI or something else. Puppy is a different kind of Linux, and I have very little experience with it.

I have botched MANY CD/DVD disks, so I have no reason to think that Mac is superior.
 

stan

Member
Credits
570
PXE is your Network Boot. Disable that.

But it should have booted on CD before it ever got that far, so it is obviously not reading your CD. Try the CD in a different computer to confirm it will boot (not that you can read the contents).

Or make a new Puppy CD using different software. It is very important when burning a CD that you use "burn image" settings with the CD burning software. Some programs will not do this. If you simply copy the .iso file to the CD, it will not boot. That may be the problem.

Oops, you deleted the post I am replying to! :oops::D
 

Meta Master

New Member
Credits
242
PXE is your Network Boot. Disable that.

But it should have booted on CD before it ever got that far, so it is obviously not reading your CD. Try the CD in a different computer to confirm it will boot (not that you can read the contents).

Or make a new Puppy CD using different software. It is very important when burning a CD that you use "burn image" settings with the CD burning software. Some programs will not do this. If you simply copy the .iso file to the CD, it will not boot. That may be the problem.

Oops, you deleted the post I am replying to! :oops::D
Yes, since I realized the PXE response was the same regardless if the disc was inside or not, I deleted.

I will be trying imgburn next and see if that gives me better luck. Currently the CD shows up in Ubuntu containing the correct ISO.
 

stan

Member
Credits
570
I will be trying imgburn next and see if that gives me better luck. Currently the CD shows up in Ubuntu containing the correct ISO.
I don't think that it should show the ISO. As I mentioned above, it has to be properly burned to disk, not copied. It will not boot if it is simply copied to the CD. Hopefully imgburn will do this correctly for you.

EDIT: Confirmed, I just looked at some Linux DVD's that I have. You should NOT see the ISO file on your CD. An ISO is kind of package format, and when it is burned properly, the package is expanded into the correct files and folders it needs. The burning process also makes the CD bootable, which is required. I'm pretty sure now that this is your problem with Puppy.
 
Last edited:

Meta Master

New Member
Credits
242
Solved 100%: Puppy Linux had been burned incorrectly.

The first time I burned Puppy Linux onto the CD using Mac's tools and somehow must have botched that operation. This time I used ImgBurn.exe via the direct download link on the Puppy Linux home website (which gives a bunch of BS warnings you can ignore).

After burning, the burn ejecting the CD before verification, putting the CD back in, and the burn then completing verification, the CD was burned.

Linux Puppy then booted normally onto the laptop without issue from the CD.

Thank you for your insightful help @stan ! :cool:

I don't think that it should show the ISO. As I mentioned above, it has to be properly burned to disk, not copied. It will not boot if it is simply copied to the CD. Hopefully imgburn will do this correctly for you.

EDIT: Confirmed, I just looked at some Linux DVD's that I have. You should NOT see the ISO file on your CD. An ISO is kind of package format, and when it is burned properly, the package is expanded into the correct files and folders it needs. The burning process also makes the CD bootable, which is required. I'm pretty sure now that this is your problem with Puppy.
 


Members online

No members online now.

Latest posts

Top