Solved: Bluetooth Adapter Is Not Detected

bytestream

New Member
Credits
60
Hello,

I bought a bluetooth usb adapter (Miilink BT501) i tested it in windows so i know it works. When i boot in Linux Mint it is not detected. I go to the default bluetooth app, it looks like it turns on the bluetooth but it does not detect my adapter.

I run Linux Mint 20.1 x86_64, Kernel 5.4.0-72-generic, Blueman-manager version 2.1.2, Bluez* 5.53-0ubuntu3

When i run blueman-manager in command line i get this output:

blueman-manager version 2.1.2 starting
Failed to enable bluetooth
blueman-manager 21.24.36 ERROR Manager:118 on_dbus_name_appeared: Default adapter not found, trying first available.
blueman-manager 21.24.36 ERROR Manager:122 on_dbus_name_appeared: No adapter(s) found, exiting

I don't really understand how to configure bluetooth. Do i have to "connect" blueman to bluez?

Thanks for your time.
 


bytestream

New Member
Credits
60
The output of uname -a:
Linux ernest 5.4.0-72-generic #80-Ubuntu SMP Mon Apr 12 17:35:00 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux

I run kernel 5.4 so this is why it does not work? If so is there a safe way to run 5.8 or should i just wait? In the link you send there are some people in the comments saying that you can make it work with an older kernel should i try one of these methods?

This one looks like it might work:
 

KGIII

Super Moderator
Staff member
Gold Supporter
Credits
16,022
You could use the firmware and follow some of the links in the comments. They're having success and the link gives directions for use.

You could also try using a newer kernel. (This includes using an OS with a newer kernel.)

Those are your two realistic options. For example, try booting into a live USB with Ubuntu 20.10 to see if it works out of the box. (That should have a 5.8 or higher kernel.)

Of course, you could buy different hardware, but your existing hardware can be made to work.
 

bytestream

New Member
Credits
60
Update:
I followed the guide in the link i sent above. It still does not work. I read a bit more and i thought maybe secure boot has something to do with this, however my computer probably does not support secure boot (msi 970a-g43 plus). I will read more from linuxreviews and i will post if i make any progress.

Thank you.
 
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Members online


Top