[Solved] AMD Radepon pro Vega 20 (Aka vega12)

f33dm3bits

Gold Member
Gold Supporter
Credits
16,567
I'm running out of ideas because I can't find anything useful of any of the messages from your dmesg. Can you try booting Manjaro with the opensource boot option but before you boot edit the boot options and then remove the following options from the line that size linux and then press ctrl+x to boot.
Code:
driver=free nouvea.modset=1 i915.modeset=1 radeon.modeset=1
The only thing errors I find in your dmesg are these but I can't find anything about them.
[ 57.844648] [drm:amdgpu_dm_atomic_commit_tail [amdgpu]] *ERROR* Waiting for fences timed out!
[ 63.374471] [drm:amdgpu_job_timedout [amdgpu]] *ERROR* ring gfx timeout, signaled seq=362, emitted seq=364
[ 63.374521] [drm:amdgpu_job_timedout [amdgpu]] *ERROR* Process information: process gnome-shell pid 1788 thread gnome-shel:cs0 pid 1818
[ 68.965972] amdgpu: [powerplay] Failed message: 0x28, input parameter: 0x500a8, error code: 0x0
[ 72.148359] amdgpu: [powerplay] Failed message: 0x26, input parameter: 0x4012c, error code: 0x0
[ 75.323564] amdgpu: [powerplay] Failed message: 0x28, input parameter: 0x60000, error code: 0x0
[ 78.508722] amdgpu: [powerplay] Failed message: 0x27, input parameter: 0x503, error code: 0x0
[ 81.683051] amdgpu: [powerplay] Failed message: 0x27, input parameter: 0x502e4, error code: 0x0
[ 84.859487] amdgpu: [powerplay] Failed message: 0x27, input parameter: 0x40320, error code: 0x0
[ 98.084632] [drm:amdgpu_dm_atomic_commit_tail [amdgpu]] *ERROR* Waiting for fences timed out!
[ 103.694467] [drm:amdgpu_job_timedout [amdgpu]] *ERROR* ring gfx timeout, signaled seq=602, emitted seq=603
[ 103.694520] [drm:amdgpu_job_timedout [amdgpu]] *ERROR* Process information: process gnome-shell pid 2679 thread gnome-shel:cs0 pid 2708
 


rluglio

New Member
Credits
128
I'm running out of ideas because I can't find anything useful of any of the messages from your dmesg. Can you try booting Manjaro with the opensource boot option but before you boot edit the boot options and then remove the following options from the line that size linux and then press ctrl+x to boot.
Code:
driver=free nouvea.modset=1 i915.modeset=1 radeon.modeset=1
Sure!
 

f33dm3bits

Gold Member
Gold Supporter
Credits
16,567
If that doesn't work, can you try downloading Manjaro Xfce and then booting from there and then try installing to see what happens?
 

f33dm3bits

Gold Member
Gold Supporter
Credits
16,567
I just had to work a bit in the evening, the last I idea have is to try to adding these to your boot parameters while booting from Manjaro Installation media.
Code:
1. amdgpu.dpm=0 amdgpu.aspm=0 amdgpu.runpm=0 amdgpu.bapm=0
2. amdgpu.dpm=0 amdgpu.aspm=0 amdgpu.runpm=0 amdgpu.bapm=0 amdgpu.dc=0
3. amdgpu.dc=0 or amdgpu.dc=1
First try 1, if that doesn't work try 2, if that doesn't work try 3 and if that doesn't work it my be worth a try experimenting with trying different on and off options for 2.
 
Last edited:

rluglio

New Member
Credits
128
I just had to work a bit in the evening, the last I idea have is to try to adding these to your boot parameters while booting from Manjaro Installation media.
Code:
1. amdgpu.dpm=0 amdgpu.aspm=0 amdgpu.runpm=0 amdgpu.bapm=0
2. amdgpu.dpm=0 amdgpu.aspm=0 amdgpu.runpm=0 amdgpu.bapm=0 amdgpu.dc=0
3. amdgpu.dc=0 or amdgpu.dc=0
First try 1, if that doesn't work try 2, if that doesn't work try 3 and if that doesn't work it my be worth a try experimenting with trying different on and off options for 2.
I'll try this now, and let you know. Once again thanks!
 

rluglio

New Member
Credits
128
I just had to work a bit in the evening, the last I idea have is to try to adding these to your boot parameters while booting from Manjaro Installation media.
Code:
1. amdgpu.dpm=0 amdgpu.aspm=0 amdgpu.runpm=0 amdgpu.bapm=0
2. amdgpu.dpm=0 amdgpu.aspm=0 amdgpu.runpm=0 amdgpu.bapm=0 amdgpu.dc=0
3. amdgpu.dc=0 or amdgpu.dc=0
First try 1, if that doesn't work try 2, if that doesn't work try 3 and if that doesn't work it my be worth a try experimenting with trying different on and off options for 2.
I can’t believe! The first option worked!
I don’t know how to thank you!!! I’ve been trying for more than a year to make this work!!!!!!
 

f33dm3bits

Gold Member
Gold Supporter
Credits
16,567
I can’t believe! The first option worked!
I don’t know how to thank you!!! I’ve been trying for more than a year to make this work!!!!!!
So booting with these?
Code:
amdgpu.dpm=0 amdgpu.aspm=0 amdgpu.runpm=0 amdgpu.bapm=0
So the glitching and freezing in Manjaro live boot didn't happen anymore and you were able to go through the install process now?
 

rluglio

New Member
Credits
128
So booting with these?
Code:
amdgpu.dpm=0 amdgpu.aspm=0 amdgpu.runpm=0 amdgpu.bapm=0
So the glitching and freezing in Manjaro live boot didn't happen anymore and you were able to go through the install process now?
The amdgpu.dpm=0 is the one that does their trick!
I’m talking to people at freedesktop.org to see if they can upstream a fix.
With this parameter I’m able to boot into any distro and install. Thank you very much, you have no ideia what a happy person you made me....I’ve been trying everything for more than a year!!!
 

f33dm3bits

Gold Member
Gold Supporter
Credits
16,567
Glad that solved it, it was my last idea. Just for your understanding since you asked before, those settings have to do with how the driver handles certain power management features for the graphics card. I read somewhere that some graphics cards tend to give trouble with those settings and tweaking around with those settings should do the trick.

Just one question, after you installed Manjaro and then updated the system were you able to boot the system without having that kernel boot parameter enabled?
 
Last edited:
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Members online


Latest posts

Top