Slow/unresponsive X

ImpYour

New Member
Joined
Feb 1, 2021
Messages
2
Reaction score
3
Credits
26
Hey guys, need some help.

I have to run 2 video cards in my PC, radeon HD 7700 and Radeon RX 5500 XT.
I have to have the 7700 as my bios/motherboard(x58m) won't boot with only
the RX 5500.

Trying to live boot ubuntu and mint, the desktop is VERY SLOW and unresponsive.
takes 15 seconds to highlight something after i mouse over it.. I'm assuming this is due
to the 2 video cards as i have ran live boot many times on my laptop and it ran fine.

I would like to only have the 5500 but alas, after weeks of trying to figure that out
i gave up.

Anyway, i need to figure out how to disable the HD7700 in linux without removing the
drivers and disabling my 5500.

any help would be appreciated.
Thanks.

PS. i'm not on linux as it is way to slow and i was about to give up and just keep using
windows but i would really like to get back into linux again.
 


f33dm3bits

Gold Member
Gold Supporter
Joined
Dec 11, 2019
Messages
3,893
Reaction score
2,633
Credits
28,122
Hey guys, need some help.

I have to run 2 video cards in my PC, radeon HD 7700 and Radeon RX 5500 XT.
I have to have the 7700 as my bios/motherboard(x58m) won't boot with only
the RX 5500.
That's odd. Wouldn't it be better to try and figure out why your system refuses to boot without the Radeon HD7700 in it? When you boot from the live installation media you could try the following, press e, then add radeon.modeset=0 to the kernel boot parameters and then finally press ctrl+x to boot. Then when you are in the live environment check if the response is normal, then install and reboot the system after the installation is finished. When you reboot you can just boot the system normally without adding that kernel boot parameter and see if your desktop responds normally, if not try updating your system.
Code:
sudo apt update
sudo apt upgrade
Reboot again with without adding boot parameters and then see if after a kernel upgrade your desktop reponds normally. If it helped adding the boot parameter which I mentioned earlier it's possible to make it permanent but I would first try that. So in short.
1. Start your system with the live cd.
2. Before it starts booting edit your kernel boot parameters and add: radeon.modeset=0
3. Continue booting.
4. Check if that fixes your lag issue.
5. If so install your system.
6. Reboot normally after installed
7. Is the lag issue gone, if not update your system: sudo apt update && sudo apt upgrade
8. Reboot and see if your desktop reacts normally after a kernel upgrade.
9. If not reboot again and add the same kernel boot parameters.
10. Once booted into your system again I can tell you how to make the boot parameter permanent.
 
Last edited:
OP
I

ImpYour

New Member
Joined
Feb 1, 2021
Messages
2
Reaction score
3
Credits
26
thank you for your reply, i went into the bios and changed primary boot display to PCI from
PCI-e and rebooted and lag was gone, and it also put my icons on my main display!

as for the issue of not booting without the hd7700, i would love to figure that one out.
i've tried putting the card in different slots and we've tried different PCs. After enough, i
just gave up. I'm upgrading to an ASRock Extreme4 B550 with a ryzen 5 3600 and moving
the 5500 over to the new system.

Again F33dM3Bits, i really appreciate your reply! cheers.
 
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Members online


Top