Series 7 CHRONOS Laptop Brightness Problem

DevynKo

New Member
So my laptop will only be in full brightness when I turn on and boot up while its plugged in to the power. If I turn it on while it not plugged in, the screen is stuck not so bright. This was fixed previously when I had windows 10 installed by changing something in the registry. I forget what it was but it worked. Now I need a fix for linux. I would appreciate any help.


Specs

Samsung Series 7 Chronos Laptop
OS: Ubuntu 18.04.1 LTS
Processor: Intel® Core™ i7-3635QM CPU @ 2.40GHz × 8
Graphics: Intel® Ivybridge Mobile
Gnome: 3.28.2
OS type: 64-bit
 


wizardfromoz

Super Moderator
Staff member
Gold Supporter
G'day @DevynKo and welcome to linux.org :)

Is your Ubuntu Desktop aka GNOME or MATE or other desktop?

If you are not sure, then go to Terminal (Ctrl-Alt-t) and enter

Code:
echo $DESKTOP_SESSION
and tell us the output.

Cheers

Chris Turner
wizardfromoz
 

Bayou Bengal

Active Member
If it did this in Win 10 as well it might be a Bios setting that needs to be changed.
 

DevynKo

New Member
G'day @DevynKo and welcome to linux.org :)

Is your Ubuntu Desktop aka GNOME or MATE or other desktop?

If you are not sure, then go to Terminal (Ctrl-Alt-t) and enter

Code:
echo $DESKTOP_SESSION
and tell us the output.

Cheers

Chris Turner
wizardfromoz
When I put in that command it just says ubuntu.
 

wizardfromoz

Super Moderator
Staff member
Gold Supporter
When I put in that command it just says ubuntu.
OK, so it's GNOME DE (desktop environment) - you have a launcher panel at left of screen, the word Activities at top left, we'll call that a Dash after its predecessor, you can type in searches, and a 9 dots shaped like a square at bottom left for Show Applications, yes?

Wiz
 
Last edited:

wizardfromoz

Super Moderator
Staff member
Gold Supporter
Assuming the above, go to either of Activities or The Dash and type in Settings, it will open, and there will appear an icon in your Launch bar at left with a red-handled wrench on a cogged wheel. Right-click on that and add to favorites, that will lock it to your launch bar.

In Settings go down to Power and click, check all brightness options are optimal.

Go down a couple further to Devices, choose Display, make sure night light is off.

See how you go, and if no joy we'll look further.

Cheers

Wizard
 

DevynKo

New Member
Assuming the above, go to either of Activities or The Dash and type in Settings, it will open, and there will appear an icon in your Launch bar at left with a red-handled wrench on a cogged wheel. Right-click on that and add to favorites, that will lock it to your launch bar.

In Settings go down to Power and click, check all brightness options are optimal.

Go down a couple further to Devices, choose Display, make sure night light is off.

See how you go, and if no joy we'll look further.

Cheers

Wizard
Did all of this still no progress.
 

wizardfromoz

Super Moderator
Staff member
Gold Supporter
Then as Bayou Bengal suggested, it may be a BIOS problem, have you been in there to look?

Wizard
 

wizardfromoz

Super Moderator
Staff member
Gold Supporter
1. Can you provide me with the output from Terminal for the following

Code:
inxi -G
2. Does your keyboard have any dedicated function keys for light settings, eg F10, F11, F12?

Thanks

Wizard
 

DevynKo

New Member
1. Can you provide me with the output from Terminal for the following

Code:
inxi -G
2. Does your keyboard have any dedicated function keys for light settings, eg F10, F11, F12?

Thanks

Wizard
Yes F2 and F3. And these buttons dont do anything either. The UI shows that Im changing the brightness, but the screen stays the same wether its plugged in or not.
 

wizardfromoz

Super Moderator
Staff member
Gold Supporter
wizardfromoz said:
1. Can you provide me with the output from Terminal for the following

Code:
inxi -G
Wiz
 

DevynKo

New Member
Sorry, must have looked over that part. This is the output.


Graphics:
Card-1: Intel 3rd Gen Core processor Graphics Controller
Card-2: Advanced Micro Devices [AMD/ATI] Mars [Radeon HD 8670A/8670M/8750M]
Display Server: x11 (X.Org 1.19.6 ) driver: i915
Resolution: [email protected]
OpenGL: renderer: Mesa DRI Intel Ivybridge Mobile
version: 4.2 Mesa 18.0.5
 

wizardfromoz

Super Moderator
Staff member
Gold Supporter
Thanks for that @DevynKo :)

I'll be perfectly honest with you, namely that graphics is not my forte, rather multi-multi-booting and to an extent general troubleshooting (good at Googling :p).

Someone else may have a better answer (hope so)

If you'll bear with me, we can see if a couple of things work on a temporary basis, and so eliminate possibilities?

For the benefit of The Viewers and Helpers, "xbacklight" works with Intel, but not AMD Radeon.

Can you give me the output for

Code:
xrandr -q | grep " connected"
?

Now that will have a description at left for the display, mine is eDP-1, others might include LVDS1 and numerous others.

So in case we are online and offline at different times, you could try the following - substitute your description for mine:

Code:
xrandr --output eDP-1 --brightness 0.5

#and

xrandr --output eDP-1 --brightness 1.0
The lowest is 0.0 which is black, 1.0 is full brightness, and increments are by 0.1, ie 0.5, 0.6, 0.7 etc.

Let us know if there are any changes, but be aware this will only last for your session, won't survive a reboot unless we tweak it.

Cheers

Wizard
 

DevynKo

New Member
Thanks for that @DevynKo :)

I'll be perfectly honest with you, namely that graphics is not my forte, rather multi-multi-booting and to an extent general troubleshooting (good at Googling :p).

Someone else may have a better answer (hope so)

If you'll bear with me, we can see if a couple of things work on a temporary basis, and so eliminate possibilities?

For the benefit of The Viewers and Helpers, "xbacklight" works with Intel, but not AMD Radeon.

Can you give me the output for

Code:
xrandr -q | grep " connected"
?

Now that will have a description at left for the display, mine is eDP-1, others might include LVDS1 and numerous others.

So in case we are online and offline at different times, you could try the following - substitute your description for mine:

Code:
xrandr --output eDP-1 --brightness 0.5

#and

xrandr --output eDP-1 --brightness 1.0
The lowest is 0.0 which is black, 1.0 is full brightness, and increments are by 0.1, ie 0.5, 0.6, 0.7 etc.

Let us know if there are any changes, but be aware this will only last for your session, won't survive a reboot unless we tweak it.

Cheers

Wizard
These do change the brightness, but the 1.0 full brightness, is capped at the brightness its booted into. Almost like the max brightness is set different depending on if I boot plugged in or not.

Sorry for the late reply.
 
Last edited:

DevynKo

New Member
Thanks for that @DevynKo :)

I'll be perfectly honest with you, namely that graphics is not my forte, rather multi-multi-booting and to an extent general troubleshooting (good at Googling :p).

Someone else may have a better answer (hope so)

If you'll bear with me, we can see if a couple of things work on a temporary basis, and so eliminate possibilities?

For the benefit of The Viewers and Helpers, "xbacklight" works with Intel, but not AMD Radeon.

Can you give me the output for

Code:
xrandr -q | grep " connected"
?

Now that will have a description at left for the display, mine is eDP-1, others might include LVDS1 and numerous others.

So in case we are online and offline at different times, you could try the following - substitute your description for mine:

Code:
xrandr --output eDP-1 --brightness 0.5

#and

xrandr --output eDP-1 --brightness 1.0
The lowest is 0.0 which is black, 1.0 is full brightness, and increments are by 0.1, ie 0.5, 0.6, 0.7 etc.

Let us know if there are any changes, but be aware this will only last for your session, won't survive a reboot unless we tweak it.

Cheers

Wizard
Got any more ideas?
 

wizardfromoz

Super Moderator
Staff member
Gold Supporter
Phew! Had a one-day day trip and am just about caught up :)

These do change the brightness, but...
If that level of brightness is acceptable as a workaround, we could incorporate that into a script or function that would run at boot. That might take me a day or so.

Another possibility is to download and burn a different type of Linux, and add to the stick "Persistence". Then boot from the stick, disable screensaving and powersaving options and run for a couple of hours on and off battery, to establish the likely culprit. You can read about Persistence by Googling

persistence pendrivelinux

Just be aware that despite the fact that we jagged linux.org as a domain name, that we are not an official organ of Linux. Every helper here is a volunteer with work lives, family lives, and commitments, but we give freely of our time where we can just because we love Linux and like to help. OK? ;)

Wiz
 

Members online

No members online now.

Latest posts

Top