Seeking Help with Elgato 4k60 Pro Mk.2 Live Streaming on Linux


Active Member
Jan 2, 2022
Reaction score
Greetings fellow furries and hardcore gamers!

I come to you today with a problem that has been vexing me for some time now. You see, I have three different capture cards, and I've only tried two of them. All I want is a way to live stream my console, but alas, it seems fate is not on my side.

Currently, I'm using POP_OS, which is the operating system I'm most comfortable with. I'm on version 22.04, and one of the reasons why I don't want to switch to another operating system is that my capture cards don't have support for Linux, or at least one of them doesn't. My Elgato 4k60 Pro Mk.2 is the one that's causing me trouble. I fall over two Github drivers sc0710 and elgato-gchd, but the first one I got Linux to find once, but OBS couldn't see it, and after a restart, it couldn't find it anymore.

I tried everything, even changing some code in two of the files as I got recommended on Reddit. So, it should work with the new version of Linux, but it doesn't. It compiles correctly, but I can't seem to get it to load because of the error message
"insmod: ERROR: could not insert module sc0710.ko: Unknown symbol in module."
When I run
sudo dmesg | tail
I get the following error message:

[ 733.437303] sc0710: Unknown symbol videobuf_vmalloc_free (err -2)
[ 733.437342] sc0710: Unknown symbol videobuf_querybuf (err -2)
[ 733.437366] sc0710: Unknown symbol videobuf_qbuf (err -2)
[ 733.437379] sc0710: Unknown symbol videobuf_read_one (err -2)
[ 733.437407] sc0710: Unknown symbol videobuf_iolock (err -2)
[ 733.437426] sc0710: Unknown symbol videobuf_streamon (err -2)
[ 733.437434] sc0710: Unknown symbol videobuf_queue_cancel (err -2)
[ 733.437447] sc0710: Unknown symbol videobuf_queue_vmalloc_init (err -2)
[ 733.437475] sc0710: Unknown symbol videobuf_mmap_mapper (err -2)
[ 733.437495] sc0710: Unknown symbol videobuf_mmap_free (err -2)

My understanding is that it uses an older version of videobuf, and that's why I'm getting this error.

I'm not sure what to do about it. I've tried to install,
sudo apt install v4l-utils libv4l-dev
but that didn't help. So, I'm at a loss here. The second driver, elgato-gchd, compiled with no problem, but when I run it, it says,
"Unable to find a supported device."
So, I guess it doesn't support Elgato 4k60 Pro Mk.2.

Now, I'm not sure what to do. I did mention that I have one that works on Linux, my Asus TUF Gaming CU4K30. But as soon as I live stream, it starts to lag. Maybe this issue has been fixed since I made a clean install of POP_OS 22.04. I will check it out, but I would still rather have my Elgato 4k60 Pro Mk.2 if there's a way around it.

So, my fellow furries and hardcore gamers, I ask you, do any of you have any experience with this issue? Any advice or solutions would be greatly appreciated.

Members online