security issues

david spriggs

New Member
i just got started in lnux i want to get away from windows,thats why im doing this, i have 2 machines, i am using the other one right now as i cant get past google because of the error messages block me from going anywhere,even linux mint, there is no exception to use ,so i need advise on how to get rid of the security messages, certificates you can call them, any help?? ca/nt use help nothing,i think it is my problem because its at every website i try to go even linux mint, i can see its using version 16 of firefox when they are at number 60 i think, so maybe thats causing this ,i dont know, i can download a current version of firefox its 66 i think its there in the box,i can extract the files but cant get firefox to start, so the old version is still there. and that may have nothing to do with the error certificates???
 


TechnoJunky

Silver Member
Silver Supporter
wow. Um can you explain what's going on a little better? What do you mean you can't get past Google? Are you saying that you have Linux Mint installed and when you try to use Firefox it opens to Google and won't go anywhere? You say that you can download Firefox 66. How are you going about that if you can't get past Google? Are you sure you are connected to your network? Would you be connected using a network cable or Wifi? In your system tray is a network icon, does it say that you're connected?
 

david spriggs

New Member
i will /try to be more clear. i have linux installed with mint, i am using firefox
and google,i have it set to open at google,. thats good,i can gmail easily from there/.
but if try to go beyond there, like mint, community forum,other sites,i get certificate errors.
with no exception so i cant get past them to connect to other sites
 

atanere

Well-Known Member
i will try to be more clear.
Hi David, and welcome! You might start with details about your system... which version of Mint? Which desktop (Mate, Cinnamon, XFCE)? Firefox is now at version 66, and it's extremely unlikely you're using version 16. Maybe Mint version 16, but that's pretty old now too. Have you been using Mint a long time, or just recently?

While you're gathering up this info that might help us to help you, please try to start Firefox in "safe mode" and see if that helps:

1. Click the Options icon near the upper right corner (looks like 3 horizontal lines)
2. Look near the bottom of the Options menu and click Help
3. In the Help menu, click "Restart Firefox with Add-ons disabled"
4. It will ask if you're sure, so then click the Restart button
5. On the next small window, click "Restart in Safe Mode"

It may go to your Google home page, but probably not. Type in some addresses in the URL bar manually to see if it will surf around without the certificate errors. If this works, you probably have an add-on that has gone wonky for some reason.... and just need to find and uninstall the culprit. And if that's not it, then we will certainly need more info to go on to help you troubleshoot this.
 

david spriggs

New Member
thank you i will try the safe mode, you might be right
i have win 10 on old compaq computer, linux came with mint installed, i dont know he version as i cant get to it, cinnamon is the desktop sas for firefox i have used it for many years and i help in the support forums, i can see version 16 /info. and i did download v66 thru firefox itself,it is in the box where downloads go,i can extract the files,but i cant get firefox to run, i tried the firefox command from the command line. no help there/ must be a seperate way with linux to start a program?? i will try the safe mode a litttle later and get back to you,probably tomorrow thanks for the help. im not on that machine right now but i dont think the3 lines you mention are there. i will try and find away to get to safe mode,if not there, usually i tap f8 at startup and i can get to it from there
 

david spriggs

New Member
ok i going to sign off now and get on the linux machine and try safe mode. im hoping that will work david

[Email address removed by @atanere.]
 
Last edited by a moderator:

atanere

Well-Known Member
i will try and find away to get to safe mode,if not there, usually i tap f8 at startup and i can get to it from there
Not Windows Safe Mode... that's not it. I was talking about Firefox Safe Mode. Your statements are not clear, as @TechnoJunky pointed out. It sounds like you are having problems with a Windows computer, and this isn't a Windows help site.

"Linux came with mint installed" also does not make sense. I'm not sure if we will be able to help you or not. But if you can provide some meaningful information then maybe I, or someone else here, will be able to guide you better.

Cheers
 

atanere

Well-Known Member
[Email address removed by @atanere.]
This is a community forum, and if you are to find help here then it needs to be publicly in the forum. Posting your email address puts you at risk of scammers, spammers, and such.... and then you might blame us. Please continue here in this thread that you have created. There are many people who may read it and offer you advice. But we are all volunteers, and we have families, and jobs, and lives outside the forum (in different time zones all around the world)... so do not be too anxious for a quick reply. We respond as we are able.
 

david spriggs

New Member
my god man what are you?no i dont think this is a windows forum, if you think that your in the wrong place not me.. what part cant you understand, the certificate error messages block linux from going anywhere. if you see a windows in that your out of line.. are such a god that you can look down on the rest of us.. you have to make your smart ass accusatory remarks for what purpose??i came here for help with linux but i have seen enough to know this is not the place for me. carry .on
 

Condobloke

Well-Known Member
G'day David.

I think there may have occurred a 'crossing of the wires' here.

You are experiencing certificate errors/security messages

What are those errors?

Either take a screenshot, or a mobile phone pic, or reproduce them here word for word....so we will know exactly what you are faced with. Then, and only then can we offer a solution.

(that sort of tone towards a respected moderator is not cool...at all. )
 
Last edited:

david spriggs

New Member
i am not concerned with what is cool, im a human so is here, neither of us is any better than the other he may know things i dont in his category, and i may know things in my category. enough said
 

Condobloke

Well-Known Member
You indicated that you were going tp tap f8 to enter safe mode....that is a Windows thing....not Linux

Entering your email address into a topic is a huge attraction for spammers ...something we go to all sorts of lengths to discourage....because once the spammers.scammers get hold of a verified email address, they are in heaven....and you will be in hell because they are relentless, and their first stop will be identify theft and any othert personal details that they can hoover up. You can thank atanere for removing your email details as promptly as he did.. atanere rightly or wrongly interpreted it as you looking for one on one assistance....which does not happen here...ever. He may also have interpreted it you attempting to "jump the queue"....which also does not happen.

So....if we may move on....details of the certificate/security errors/messages, please.
 

wizardfromoz

Super Moderator
Staff member
Gold Supporter
usually i tap f8 at startup and i can get to it from there
Under what environment, David? Where does this take you?

G'day and welcome to linux.org :)

Go to your Start Menu at bottom left and click.

Start to type in

welcome

Something will show as Welcome screen, click it.

It will tell you eg

Linux Mint 18.3 Cinnamon

Tell us exactly what it says. These differences matter as much as the differences between Windows 7, 8 and 10.

If we know what we are dealing with, we may be able to help ... you came here.

All of the participants here are older than you, a little give and take would help.

Chris Turner
wizardfromoz
 

TechnoJunky

Silver Member
Silver Supporter
David, I apologize in advance if this statement is offensive, I don't mean to be, but your statements aren't clear and are quite confusing. For one thing I don't understand this certificates blocking you thing.

I think what would help us to help you is if you just bullet point what steps you take to get to the issue and what the outcome is. Leave out feelings and thoughts, just the facts man :). Here's an example of what I'm talking about:
1) Log into Mint
2) click menu, internet, Firefox
3) type in www.Linux.org
4) error message says "you are screwed man"

Also add in the info that Wiz and CondoBloke asked for above.

One thing that you can try, in order to fix Firefox is to rename your .mozilla directory to .mozilla_old. This is a hidden directory in your home folder, so you may need to enable hidden files to see it, or just use those names if typing in the terminal. Then when you open Firefox you'll get a brand new, empty profile with either no certificates or just the default ones. Unfortunately, unless you use Firefox Sync, you will lose your favorites and usernames/passwords for sites. But it's a good step to try in order to figure out what's going on. You can always delete the new folder and then rename .mozilla_old back to .mozilla.
 
Last edited:

Vrai

Active Member
After reading this whole thread I would mention that it is still not clear exactly what the error message(s) is/are, nor the precise version of Firefox nor Mint.

That being said, if the error is indeed a 'certificate' issue it is easily fixed by deleting or renaming the 'certificate store' used by Firefox and restarting the browser. Firefox will rebuild the list of certificates automatically. :cool:

https://support.mozilla.org/en-US/questions/878694

https://www.trishtech.com/2016/04/fix-invalid-certificates-error-in-mozilla-firefox/
 

Condobloke

Well-Known Member
G'day again David.

I am here....where are you ?
 

Condobloke

Well-Known Member
start a new topic, David.
 

Members online

No members online now.

Top