Screen goes black after logo..SOLVED IT(I don't know how to delete it..hehe)


New Member
Dec 6, 2021
Reaction score
My pc: intel core i7 3,5GHz-w/igpu, 16GB DDR3, Asus gtx 970 turbo and 10 different ssd+hdd

I'm fairly new to Linux but started when knoppix came out but have forgotten most since then by now, really want to use mint as 'i've jumped through many distro's the last week with Ubuntu, Centos but didn't get in due to same problem and Garuda dragonized gamer but had some issues as well but not the same ones and on their forum(just lets say they were less then ok, in fact worst I've noticed ever)but then got in to Mint by pressing C on my vontoy disk booter and typing: vtdebug on and all was fine except my sound. SO please help me..?
More info here:
My creen goes black after seeing the logo. I have nvidia gtx 970 and Intel igpu and both responds the same way and what I wrote in grub.cmd: grub_gfxmode=1920x1080x32. And that's t got in, but I have no sound since I use my gtx for picture&sound so when booting my keyboard also stops working which is on an usb(wireless) so it looks like hdmi-port and the usb-ports cut out for some reason..? I'm going to stay here on safe-boot until I know why or just get it fixed and the same happened on other Linux distro's when trying to boot, like Ubuntu, centos and mint of' course!!

System: Kernel: 5.4.0-74-generic x86_64 bits: 64 compiler: gcc v: 9.3.0 Desktop: Cinnamon 5.0.7
wm: muffin dm: LightDM Distro: Linux Mint 20.2 Uma base: Ubuntu 20.04 focal
Machine: Type: Desktop Mobo: ASUSTeK model: P8Z77-V LX v: Rev X.0x serial: <filter>
BIOS: American Megatrends v: 2501 date: 07/21/2014
CPU: Topology: Quad Core model: Intel Core i7-3770K bits: 64 type: MT MCP arch: Ivy Bridge
rev: 9 L2 cache: 8192 KiB
flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 56165
Speed: 3710 MHz min/max: 1600/3900 MHz Core speeds (MHz): 1: 3707 2: 3694 3: 3678
4: 3697 5: 3656 6: 3701 7: 3708 8: 3703
Graphics: Device-1: NVIDIA GM204 [GeForce GTX 970] vendor: ASUSTeK driver: N/A bus ID: 01:00.0
chip ID: 10de:13c2
Display: x11 server: X.Org 1.20.9 driver: nouveau,vesa unloaded: fbdev,modesetting
resolution: 1024x768~N/A
OpenGL: renderer: llvmpipe (LLVM 12.0.0 256 bits) v: 4.5 Mesa 21.0.3 compat-v: 3.1
direct render: Yes
Audio: Device-1: Intel 7 Series/C216 Family High Definition Audio vendor: ASUSTeK P8Z77-V LX
driver: snd_hda_intel v: kernel bus ID: 00:1b.0 chip ID: 8086:1e20
Device-2: NVIDIA GM204 High Definition Audio vendor: ASUSTeK driver: snd_hda_intel
v: kernel bus ID: 01:00.1 chip ID: 10de:0fbb
Sound Server: ALSA v: k5.4.0-74-generic
Network: Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: ASUSTeK P8 series driver: r8169 v: kernel port: d000 bus ID: 03:00.0
chip ID: 10ec:8168
IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives: Local Storage: total: 12.49 TiB used: 20.47 GiB (0.2%)
ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 980 500GB size: 465.76 GiB
speed: 31.6 Gb/s lanes: 4 serial: <filter>
ID-2: /dev/sda vendor: SanDisk model: SDSSDXPS240G size: 223.57 GiB speed: 6.0 Gb/s
serial: <filter>
ID-3: /dev/sdb vendor: Samsung model: HD103SJ size: 931.51 GiB speed: 3.0 Gb/s
serial: <filter>
ID-4: /dev/sdc vendor: Hitachi model: HTS723216A7A364 size: 149.05 GiB speed: 3.0 Gb/s
serial: <filter>
ID-5: /dev/sdd vendor: Samsung model: HD753LJ size: 698.64 GiB speed: 3.0 Gb/s
serial: <filter>
ID-6: /dev/sde type: USB model: USB DISK 2.0 size: 968.0 MiB serial: <filter>
ID-7: /dev/sdf type: USB model: USB DISK 3.1 size: 57.81 GiB serial: <filter>
ID-8: /dev/sdg type: USB vendor: SanDisk model: Cruzer size: 14.91 GiB serial: <filter>
ID-9: /dev/sdh type: USB vendor: Samsung model: HD103SJ size: 931.51 GiB
serial: <filter>
ID-10: /dev/sdi type: USB vendor: Western Digital model: WD40EZRZ-00WN9B0
size: 3.64 TiB serial: <filter>
ID-11: /dev/sdj type: USB vendor: Western Digital model: WD My Book 25ED size: 5.46 TiB
serial: <filter>
Partition: ID-1: / size: 915.40 GiB used: 20.38 GiB (2.2%) fs: ext4 dev: /dev/sdb5
Sensors: System Temperatures: cpu: 47.0 C mobo: N/A
Fan Speeds (RPM): N/A
Repos: No active apt repos in: /etc/apt/sources.list
Active apt repos in: /etc/apt/sources.list.d/official-package-repositories.list
1: deb http: // uma main upstream import backport #id:linuxmint_main
2: deb http: // focal main restricted universe multiverse
3: deb http: // focal-updates main restricted universe multiverse
4: deb http: // focal-backports main restricted universe multiverse
5: deb http: // focal-security main restricted universe multiverse
6: deb http: // focal partner
Info: Processes: 285 Uptime: 6h 25m Memory: 15.58 GiB used: 3.89 GiB (24.9%) Init: systemd
v: 245 runlevel: 5 Compilers: gcc: 9.3.0 alt: 9 Client: Unknown python3.8 client
inxi: 3.0.38

Hope you can please help me!!
Last edited:


Staff member
Gold Supporter
Apr 30, 2017
Reaction score
@x3mghost - we don't usually worry about deleting Threads, we keep them around in case someone else can benefit.

So don't keep us in suspense (you wouldn't like the colour blue I turn holding my breath) - tell us how you solved it.


$100 Digital Ocean Credit
Get a free VM to test out Linux! Hosting Donations
Consider making a donation

Members online