• We had to restore from a backup today after a failed software update. Backup was from 0000 EDT and restored it at 0800 EDT so we lost about 8hrs. Today is 07/20/2024. More info here.

Reviews which are opinions

Heh... I used Mandrake back in the day.

DISTRO: elementary OS
VERSION: 7 (Jan-2023)
I read your review and downloaded this .iso to have a look in a VMware Fusion (Mac) virtual machine. The installer displayed a warning about trying to run Elementary OS in virtual machines.

Since I am looking at many different distros as potential future desktop candidates, I gave up on Elementary OS without installing it.

Thank you for sharing your reviews. They have been helpful to me as I try out different Linux desktops.

The ISO was launched a few weeks ago. This is an OS that many people aren't going to be comfortable with, and installing it might not make it better. I have decided to remain using the ISO although it's clunky.

The first option of GRUB boot menu for this live distro is to load the OS into RAM. This is not recommended for people who have 2GB RAM or less! It creates a 256MB ramdisk like Bluestar live mode. There is one major problem with using this ramdisk that I will get to in a moment.

After it finishes booting the user is given the choice to "startx" or not. This is in case he/she wants to treat this OS as if he/she just finished successfully installing Arch. :)

There is no desktop environment. The GUI is a variation of "i3" window manager. The "wallpaper" is dominated by a big snail and instructions for which keystroke combinations do what. Universally press Meta (Windows key) with a digit key to switch to that numbered workspace. Include SHIFT with one of those key combinations to move an application window to the wanted workspace such as Meta+SHIFT+4 to move it to workspace #4. However, other key combinations are different from expected in other window managers such as to open the file manager and terminal. The system has CPU indicator which is updated every five seconds. The user will have to program for fancier visuals on that top panel after he/she installs this distro. The system has "pango" monospaced serif font with 16 point size, which looks kewl but might be too big. Sadly setting 14 point size makes it harder to read and the "s" looks too weird. The 16 point size has another problem: on my computer, which is a laptop having 768 pixels up and down, the whole bottom line remains blank because Bash, Nano and other programs don't know what to do with it.

The "cat" terminal command is aliased to "bat" which is annoying unless one likes the pretty-print. There is neither "inxi" nor "neofetch" or something else to get some information about the system quickly. However it comes with Mousepad, Nano and Vim to edit text files, the latest Lua interpreter v5.4.6, Python v3.11.3 and recent GNU Compiler Collection. I don't know how far a developer could go with the latter two.

OK, here's the flaw that might put off an user of Linux which isn't experienced enough. Snal Linux comes with PCManFM which is incomplete with recognizing external media plugged in for the regular user at "/home/snal". In fact it shows nothing of it. The user must get "root" privileges, go to the terminal and use "mount" command to access a disk formatted for "fat32" in the least to save a text file such as this one. I don't like this file manager but there must be another way to get it to cooperate without seeking elevation. Especially when one is saving to the 256MB ramdisk and is anxious to commit it to more-lasting media, this is not something he/she wants to come across suddenly. Another thing is that for each workspace the terminal is opened into, it asks "run screen?" for a GNU Screen configuration that doesn't exist, which is irritating. Then the user is left with dollar-sign prompt worthless for any file creation.

I clarify: when an ordinary USB disk is plugged in, there is no sign of it such as "/run/media/snal/MYDISK". There is not even a "media" directory under "/run". I believe there is a way for "root" to mount a disk for the sake of the regular user, but this is a hassle which indicates this live distro is not for beginners and not for people who "just want to use it". It would have to be done everytime Snal is started, unless it's formally installed.

Using Mousepad and giving the command to save a file for the first time, the OS draws a save file requester on my computer where the text field is cut off from the top, to be able to see typing in a filename. This is a flaw with XFCE that I have been disgusted with a few months before their "huge" v4.18 release.

Snal comes with "ranger" Python program for file management but it was impossible to navigate with it on my computer. It seems to prefer for Snal ISO to have been written on its own to an USB disk instead of being launched by Ventoy. In "ranger", to look at a text file it launches Vim on the same workspace.

I haven't gone online with this live distro; I don't have a need. Eventually Firefox is going to need an update. The easiest way out is to get the AppImage from "srevinsaju" Github page. Somebody else will have to review this distro to check out its extensive tools for networking troubleshooting.
One thing that causes resentment with Arch Linux is some things not called like they should be. Now I'm having trouble getting the same exact font that is used in Snal Linux for the terminal, but away from that Linux OS. It claims internally the font is called "FreeMono", but I found a version from the GNU "Free Fonts" collection with the same name of OTF-suffix file which looks very much like "Courier Bold" on Windows. The lowercase "s" looks significantly better on the "Freemono" of the copy I downloaded just now. To make matters worse, in "i3" configuration of Snal, the font is called "Pango". There is a message on the TTY written with "startx" messages and other stuff which has that "Pango" label which should be for something else. Why are they unable to call stuff correctly?

TL;DR liked the serif monospaced font used in Snal but if I want it away from Snal I would have to copy it away from that ISO to where I want. Also set it to display with 16 point size LOL.
Sounds like Snal is for experienced Linux users, there's nothing wrong with having a distro that doesn't hold the users hand.... ;)

It's easy enough to mount a disk for yourself, & ranger works OK, though I have always liked mc myself. :)

(Using screen & i3 suggests it is for the experienced minimalist.)
What a shame. Back up Slackware 32-bit for a moment to be able to install OpenSUSE "Leap" v15.5 into the internal HDD and got a kernel panic upon booting it for the first time. I'm really done with this distro and anything else RPM-based unless Gecko Linux comes through. I will not install and update any active branch from almost year-old ISO and this is final.
I found that I liked the way apt worked a long time ago, & that is why I stuck with Debian based distros, until systemd, at that point, I transferred allegiance to Devuan, been with it ever since, as my main distro, but I still look around occasionally. ;)
These are some random thoughts about my experience with Debian v12 "Bookworm":

If you don't like the "standard" set with Cinnamon or GNOME, then I recommend grabbing the Spiral Linux ISO and upgrading to "Bookworm". MATE might be the same way but I have never tried Spiral with MATE nor XFCE. If you do choose Spiral and don't want Firefox or Libreoffice, it is recommended to remove them before doing the "distro" upgrade. It's because on Debian, removing Libreoffice in particular is harder; on GNOME it could cause the desktop to stop functioning properly. This actually happened to me. Debian also installs an insane amount of language packs for both those programs. Last December when I checked out "Testing" with MATE it also put on "fctix" input method stuff that I didn't need, and they made the volume control on system tray more complicated than it should have been. There is other stuff like Clementine and Thunderbird installed on Spiral the user might be interested in purging as well before going ahead with the "distro" upgrade.

Install Spiral Linux as I have already suggested. Install it with "btrfs" main file system integrated with Snapper if you have to, I don't know about that. After done successfully remove the unwanted programs, if this is applicable. Then to do the upgrade from "Bullseye" to "Bookworm" base, must get "root" permissions temporarily to edit the "/etc/apt/sources.list" like this:

deb http://deb.debian.org/debian/ bookworm main contrib non-free non-free-firmware
#deb-src http://deb.debian.org/debian/ bookworm main contrib non-free
deb http://security.debian.org/ bookworm-security main contrib non-free non-free-firmware
#deb-src http://security.debian.org/ bookworm-security main contrib non-free
deb http://deb.debian.org/debian/ bookworm-updates main contrib non-free non-free-firmware
#deb-src http://deb.debian.org/debian/ bookworm-updates main contrib non-free
deb http://deb.debian.org/debian/ bullseye-backports main contrib non-free #Debian bookworm Backports

In addition, you have to add the "non-free-firmware" tag at the end of the first three lines, because "apt" would complain about it saying it couldn't find some packages while in the process of refreshing repositories. There's no need to modify the last line with the "backports".

Another server could be used instead of the main Debian one, which is closest to where you live.

After the "sources.list" is modified, then go ahead and do:

sudo apt update

"apt" could say over 1500 packages need to be upgraded. So if your Internet connection isn't very fast just go get a cup of coffee, read a chapter of a good book or something else and be patient. "apt" could point out the distro label change according to Debian versions but this warning is harmless. Afterward, to upgrade, the command is:

sudo apt full-upgrade

Note it's "full-upgrade" and not just "upgrade". There are a couple of messages from "apt" that could be worried such as, "Installing this will break some dependencies but will install it as you requested", but this will have to do with some parts of the desktop such as "mutter" for GNOME. After the "full-upgrade" operation is finished completely, the user should reboot the computer.

Doing "upgrade" instead of "full-upgrade" on Spiral GNOME will give you something that looks like GNOME v38 which used to be installed but with some v43 components. This is very important to understand if you do care about getting the latest GNOME D.E. possible. This is less successful with Cinnamon at least with appearances, but many things under the hood are fixed. Just don't expect a theme to be installed making it look like Ubuntu Cinnamon.

On GNOME as a bonus, many extensions could still be handled locally, although a few of them will be broken because they weren't maintained into v43. Not like v44 which requires going online, installing a plug-in which requires a Chromium-based browser. It eventually tried my patience with EndeavourOS and rolling-release distros, and although I really don't like GNOME that well I thought v43 was good enough and therefore settled for Debian (or what Spiral Linux plus "full-upgrade" could give me).

This is what I did to get something comparable to Debian "Bookworm", with Cinnamon and GNOME D.E.'s, without many annoyances presented by the feature set installed by the Debian ISO's.
Feeling adventurous, I've decided to upgrade the installation that I had which was Spiral Linux GNOME but with "Bullseye" base. I changed the "sources.list" like I have already described. However I did this command:

$ sudo apt upgrade

to upgrade instead of "full-upgrade". The process took about 45 minutes on my computer and rather slow Internet connection. (At least it didn't mess around too much, sometimes it could go to 100KiB/second and less.)

Indeed, I got the GNOME v3.38 desktop with some v43 components. But alas, "Settings" refuses to start. I could open "Tweaks", though, and the "Extensions" page there is still very much like in the older desktop version. When the repository information is updated at this point, it reveals packages needing to be upgraded which, I imagine would bring the whole GNOME desktop to v43 where it should be.

I'd keep what I have except for two caveats. I think I need to access "Settings". Also the old Wine v5 was upgraded to v8, making things less certain about 32-bit Windows compatibility.

I know I could use "dconf Editor" to change most of the stuff inside "Settings" but using it is clunky and some fields expect precise values. Through there I was able to change Nemo file size display for base-2 rather than base-10. (I installed Nemo because I just don't have faith in GNOME Files anymore, but it is slow, ignores my attempt to disable its animations, doesn't allow one "bookmark" hidden on the left-hand sidebar and could put on a horizontal scrollbar at the bottom for a long filename that I couldn't help.)

I was going to ask around here if there were a way to kill the "Settings" daemon and restart it but it probably wouldn't have been enough. So you all have been forewarned. "full-upgrade" instead of "upgrade", and say goodby to the older GNOME desktop. :)
One more thing I forgot to add. The mouse accuracy with pointing and clicking still sucks. Especially on the panel top-right menu have to hold the mouse button about 1/2-second or longer to see a blue marker over the choice. Sometimes I even had to open that menu with the mouse then navigate to "Power off" with the keyboard to shut down the computer.

I had to add that I created a "dot-desktop" file and included it into the "autostart" to set some "synclient" commands so the touchpad behaves itself better. Otherwise the system continues trying to find the "middle" mouse button from a touchpad with two physical buttons. Be forewarned that GNOME v44 doesn't seem to offer a way to disable scrolling with touchpad, and neither does KDE Plasma v5.27 which is a hard pass for both of them for me.

Another thing I have to clarify is that the desktop and "activities" overview will not look like the screenshot for Debian's page on Distrowatch. If there are two or more workspaces enabled and the extension is enabled to show them on the overview, the "thumbnails" of the workspaces are shown on the right-hand side, while the user has to go up or down with the mouse to change icon screens. I think how GNOME v43 has things looks cooler. But I also wanted the rounded top edge of desktop below the top panel...

This caveat about mouse response would certainly decide some people that the later GNOME desktop version is better.
Checked out Q4OS v5.2. It doesn't do better than SpaceFun "IceFun" which actually looks nicer; I don't like later KDE Plasma than v5.21 because it's annoying. Both OS's cannot activate the "Sandisk UEFI" option for me for an external USB disk soon after turning on my computer.(*) Spiral Linux could do it. Sparky Linux could do it. Ubuntu overdoes it sometimes LOL. Eckersley even siduction could do it I bet although I think it's horrible. Distro-named special entry doesn't count which appears only once. Therefore I will not keep those first two mentioned, in this case they are not better than what I have had already based on "Bullseye". Q4OS did create the expected folders in "Home" directory.

(*) I clarify: my computer is Hewlett-Packard which is 11 years old, originally came with Windows8 and has a dual-core Intel CPU. It was supposed to be lent over but so far I have been allowed to keep it. But something was done to it so a few seconds after the power button is pressed to turn it on, and I don't intervene, it doesn't shoot straight into Windows10. It shows at the bottom of the screen: "Press [F9] to see boot options" which is what I have to do if I want to get into anything other than Windows. Then this "Sandisk UEFI" option should appear in the menu that appears when the screen changes. This is not GRUB, this is before that. This menu is what I usually call the "blue HP booting menu". I also have Spiral Linux KDE "Bullseye", Manjaro MATE and Slackware KDE 32-bit on the hard disk as well as Windows. I cannot boot Slackware directly, need to use GRUB of either of the other two Linux OS on the hard disk to get into that one. When I plug an external USB disk which has a Linux OS installed, some of them (which are 64-bit) don't do the "magic" with UEFI which means from that menu I have to select "Boot from EFI file" and then go looking for the EFI file on the external disk's ESP. This is what I had to do with SpaceFun then with Q4OS v5.2 so far which shouldn't have happened. But as I've already said I have successfully installed Spiral Linux at least six times in which the EFI "magic" was done correctly.

When Q4OS is fired up the first time right after installation and right after user log-in, very irritatingly it requests connection to Internet. No other distro especially with KDE does this. Then it keeps holding back startup to desktop by telling the user to select one of the "Desktop Profiles". This although in Calamares I purposely chose "Basic" installation so I could install what I want without the "features" of this OS getting in my way. I wonder if this distro is this annoying if the "bare bones" OS setup were chosen. The Linux kernel is Debian's v6.1.0-10, but there was a bit of discussion about this one over at Debian User Forums where a few people had trouble creating the "initramfs". The web browser is Chromium -- not my cup of tea. That's about it from the apps not written by KDE -- I repeat, this is for "Basic" installation, the screen in Calamares before the partition setup.

I could get the same thing from EndeavourOS fellas, so forgive me if I sounded cruel here. I have one thing with KDE Plasma v5.27 for a while and that's Manjaro. I deeply wish the touchpad configuration were like I found on Redcore, which (le gasp!) also comes with KDE Plasma v5.27! Although being left back because the ISO for that one is nearly five months old.

I also have a copy of Q4OS v4.11 "Gemini" based on Debian "Bullseye", really fast and with not much installed on it, and it's "less nice" than Manjaro KDE but I'm going to keep it instead. I have Debian XFCE (finally found out it came from the 2-January-2023 "Testing" ISO), the one I showed off in the desktop screenshots thread, and also two of Spiral Linux with Cinnamon and GNOME raised to "Bookworm". I don't think installing one with "Bookworm" base in the first place would be better for me.
Last edited:
I think a while for toying with Q4OS.
Thanks for saving me the hassle.
Well here is my opinion review I tried Ubuntu 22.04 for awhile - it was ok but kept getting Unexpected error messages eg. when using Totem which could not play mp4s - I always install Vlc. Bluetooth was easy to set up. But then I tried Mint (21.1) and so far a much more solid experience, without the unexpected error messages. As a side note I still don't like Bookworm - should have Bluetooth out of the box in live mode - very disappointing.
I forgot one thing about my experiment with Q4OS v5.2, with the "Basic" installation.

There was no Gwenview nor anything else to view an image (if so please correct me here) in v4.11 "Gemini". The other day I had to go install it. I was hoping the distro-makers would fix this issue, but it still persists in the latest version/release of their distro.

Some beginners might not care, so long as Chromium could load an image for them!

But I do care about this. I don't want to fire up a greedy web browser for anything except to actually get into Internet. No wonder there is that push to install that "Desktop Bundle".

My outdated copy of Q4OS came with KWrite, not Kate but I had installed Geany (not KDE application) to be different there for once. The v5.2 comes with KWrite and Kate which is irritating, as well as Spectacle. Could create screenshots but not look at them later without a web browser! Not even Feh nor Nitrogen guys?

It doesn't look like there's a music nor video player neither. Must opt for "Full" installation, I guess.
Wendy if want a small install why not have some appimages that you run on the fly between the distros that you run. Have them on a flash drive - I am sure an image viewer is available to run portable.
Yep Xnview one of the good ones.

It opens all the image formats. Well, hundreds of them. It even works with the most obscure image formats out there.
This is the first time I check out PeppermintOS. Was tempted to try the Devuan base but would have liked it to be for "Daedalus" which is the later version. Anyway I had bad experiences with Devuan on internal HDD (before I replaced it with Spiral Linux KDE which was much-better behaved) and I didn't like how Gnuinos was upgraded to XFCE v4.18. I was a jerk last year unwilling to use the Ethernet cable for the sake of either. Gnuinos needs a little bit more IMHO and otherwise if it supported persistence it would have made a very good live distro.

PeppermintOS did the UEFI magic. I forgot to mention that, if that's done then I lose the "debian" entry for Spiral Linux KDE on the internal HDD. The important thing is that I get the "Sandisk USB" option when I hook up with the OS I want to boot from there, and not have to go looking for the EFI file which is clumsy.

What a shame it comes only with XFCE. The theme looks nice, a twist on the "Numix" on Spiral Linux. Not eager to change it although I really want out of "Cantarell", don't know why XFCE go along with GNOME with this so much. OTOH "Ubuntu" is becoming an eye-sore to me on other Debian-based Linux OS's. Appreciated that the compositor is turned off by default. Thunar is much too wide for my taste; I don't want to use the split view nor tabs with this. I don't like compact filename view but this file manager sometimes brings me out by enabling the horizontal scrollbar. I don't need to see file dates as much but would be nice to see the sizes of regular files. Cannot have that on Thunar, Nemo nor PCManFM without them peaking me off. Somehow Caja is better about this but is slow.

Appreciate that the "standard" installation does not come with Libreoffice but also without a lot of other things like a media player and image viewer. This is from over 260 thousand files being copied to the main partition. Less is more, eh? Sorry but Spiral Linux has it beat because that comes with Libreoffice, Clementine, and even the Snapper borrowed from OpenSUSE it looks like. Not a lot to remove -- Plank, that's about it.

One thing that could be super-annoying is the auto-focus of windows with mouse pointer. To disable it, go to Settings menu, then Window Manager (not Tweaks), the third tab "Focus" and then make sure "Click to focus" is picked over the other option at the top of the dialog. This is the first distro with XFCE where I had to make this setting. I accidentally took it off "Click to focus" somewhere else and it was driving me crazy and unwilling to proceed any further until I found the way to restore the good setting.

This distro comes with Debian's v6.1.0-9 Linux kernel because the ISO was released a few days before the "revision 10".

I'm not eager to use distro-maker-specific applications; for this one it's Peppermint Hub. "System Info" disappointingly doesn't show any Linux mark at the left-hand side and otherwise executes "neofetch" and leaves the terminal open. There's this thing called "x-Daily" which seems to be an updater. On my computer it launches the terminal asking for the regular user's password but doesn't focus on the terminal for it. Maybe that's why that focus setting in "Window Manager" was what it was. The "Software Tools" category on the right-hand side isn't for me. It allows installing AppImages, Flatpaks and Snaps.

Sadly, the system update failed, maybe because I intended to do it like I did anything else based on Debian. This was the last of it:

Setting up linux-image-6.1.0-10-amd64 (6.1.37-1) ...
I: /vmlinuz.old is now a symlink to boot/vmlinuz-6.1.0-9-amd64
I: /initrd.img.old is now a symlink to boot/initrd.img-6.1.0-9-amd64
I: /vmlinuz is now a symlink to boot/vmlinuz-6.1.0-10-amd64
I: /initrd.img is now a symlink to boot/initrd.img-6.1.0-10-amd64
dkms: running auto installation service for kernel 6.1.0-10-amd64.
dkms: autoinstall for kernel: 6.1.0-10-amd64.
update-initramfs: Generating /boot/initrd.img-6.1.0-10-amd64
I: The initramfs will attempt to resume from /dev/sdb3
I: (UUID=4ea97739-b908-4046-b6fb-0598d93be8c3)
I: Set the RESUME variable to override this.
raspi-firmware: missing /boot/firmware, did you forget to mount it?
run-parts: /etc/initramfs/post-update.d//z50-raspi-firmware exited with return code 1
run-parts: /etc/kernel/postinst.d/initramfs-tools exited with return code 1
dpkg: error processing package linux-image-6.1.0-10-amd64 (--configure):
installed linux-image-6.1.0-10-amd64 package post-installation script subprocess returned error exi
t status 1
Setting up linux-compiler-gcc-12-x86 (6.1.37-1) ...
Setting up libgstreamer-gl1.0-0:amd64 (1.22.3-dmo1+deb12u2) ...
Setting up libjavascriptcoregtk-4.1-0:amd64 (2.40.3-2~deb12u1) ...
Setting up gstreamer1.0-plugins-base:amd64 (1.22.3-dmo1+deb12u2) ...
Setting up linux-headers-6.1.0-10-common (6.1.37-1) ...
Setting up linux-kbuild-6.1 (6.1.37-1) ...
Setting up gstreamer1.0-gl:amd64 (1.22.3-dmo1+deb12u2) ...
Setting up libgs10-common (10.0.0~dfsg-11+deb12u1) ...
Setting up gstreamer1.0-x:amd64 (1.22.3-dmo1+deb12u2) ...
Setting up linux-headers-6.1.0-10-amd64 (6.1.37-1) ...
dkms: running auto installation service for kernel 6.1.0-10-amd64.
dkms: autoinstall for kernel: 6.1.0-10-amd64.
Setting up linux-headers-amd64 (6.1.37-1) ...
Setting up gstreamer1.0-plugins-good:amd64 (1.22.3-dmo1+deb12u1) ...
Setting up gir1.2-gst-plugins-base-1.0:amd64 (1.22.3-dmo1+deb12u2) ...
dpkg: dependency problems prevent configuration of linux-image-amd64:
linux-image-amd64 depends on linux-image-6.1.0-10-amd64 (= 6.1.37-1); however:
Package linux-image-6.1.0-10-amd64 is not configured yet.

dpkg: error processing package linux-image-amd64 (--configure):
dependency problems - leaving unconfigured
Setting up libgstreamer-plugins-bad1.0-0:amd64 (1:1.22.3-dmo1+deb12u1) ...
Setting up gstreamer1.0-plugins-bad:amd64 (1:1.22.3-dmo1+deb12u1) ...
Setting up libwebkit2gtk-4.0-37:amd64 (2.40.3-2~deb12u1) ...
Setting up libgs10:amd64 (10.0.0~dfsg-11+deb12u1) ...
Setting up libwebkit2gtk-4.1-0:amd64 (2.40.3-2~deb12u1) ...
Setting up gir1.2-webkit2-4.0:amd64 (2.40.3-2~deb12u1) ...
Setting up ghostscript (10.0.0~dfsg-11+deb12u1) ...
Processing triggers for libc-bin (2.36-9) ...
Processing triggers for man-db (2.11.2-2) ...
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

Let's see if it could be fixed.

Many thanks to the guys from Debian User Forums for providing a solution to the "initramfs" upgrade problem. It was true what was said in that thread about upgrading from "Bullseye". Just for kicks a few days earlier I installed "Bullseye" with LXDE, then purposely upgraded it to "Bookworm" and it gave me the Linux kernel v6.1.0-10 without protest. In fact, the whole upgrade went faster than ever LOL since it was doing it to a quasi-desktop and not to a beast like KDE.

Back to PeppermintOS. Supere preset to open Nemo while it's not installed, should open Thunar instead. This is before I discover that the "Keyboard/Application Shortcuts" tab is as buggy as PCLinuxOS, doesn't let me delete nor change an entry. Sorry but the journey ends right here. I opened the keyboard shortcuts XML to adjust the settings, generally less keypresses because I don't need 12 workspaces. But it resists, sets what it wants like that other operating system which gave me trouble. That's a good reason why I don't like Linux distros that offer only XFCE. It's another pretty face, like Linux Lite, like Kumander, like Gnuinos, like my Debian XFCE which is not that retarded and I'm happy I found that one first.

Members online