Reviews which are opinions


Active Member
May 3, 2023
Reaction score
NOTICE: The Linux distribution reviews to be posted in this topic are not to be the only thing used to make a final decision! You should not make a decision based only on opinions of other people, and stories of experience should serve only as warning. Please use the Internet search services and read reviews, and pay less attention to videos championing this distro over another. For one review about a certain distro, you should look for a second opinion. Please do not persist with members of this community recommending a particular distro for you, because there are a few hundreds, at least 50 good ones, and everyone has different goals and tastes. You are deeply encouraged to investigate which Linux distribution is for you.

One thing about videos is that the visuals could be manipulated for what the creator of the video wants the viewer to see. Most of the videos are honest and home made, but they should not be the only thing to base a final decision on which Linux distribution that you will use. Because one distro is getting based "all the time" and/or harder than others, you shouldn't select it. Because one distro gets a lot of praise, and installing it is like belonging to a tribe, you shouldn't select it. There are many, many Linux OS's in between that should get a fair analysis. I'm not saying this to overwhelm anybody but the source of anger is a choice that is made hastily because "this was cool" or "it just works" or "updates don't break" or "I wanted this high-tech feature", and he/she could have done even better.

It's all right to create a list of things to expect from a Linux distribution. For example, one of the things I expect is full "multilib" support for Wine. In other words, 32-bit as well as 64-bit Windows libraries emulated in Linux for a few apps that I enjoy using and have a great problem giving up. This might be right up your alley. Also you could require an OS which doesn't carry "systemd", because this is always a controversial topic. You might want a system that looks like MacOS or Windows as much as possible, not necessarily because you want to keep using that other OS but is like me refusing to forget about some good times of the past. Instead of that, you might require a window manager without "desktop bloat" so that things run more quickly. You might be considering one of the "static" distributions, with support for AppImages and/or Flatpaks in order to get software which is more recent than what could be found in repositories. You might require a system that could do snapshots in case of an upgrade failure. You might want a system that is optimized for gaming, toward a desktop computer you built especially for it. You might be looking for a solution only for server, for a portable phone or for some gadget there somewhere that needs an operating system to do something. Saying that in case "desktop user" is not the only thing to be covered.

This is a topic of opinion. I will not be held responsible for choices made based on it, if it's a bomb or a heaven, and neither will be any of the members of this forum, especially the ones most visible posting.

DISTRO: Slackel
BASED ON: Slackware "current"

This distro was created by "djemos", its author to be portable, but it could be used as a regular Slackware-compatible installation. It is meant to be really installed into pluggable media, on a disk at least 32GB. It's recommended to set up the disk before running the "SLI" program. The live ISO comes with GParted to do it: at least 512MiB ESP "fat32", at least 4GiB "swap" and in between the "root" partition.

The Salix/Slackel Live Installer (SLI) has to be obeyed with all the options from the middle to the bottom of the dialog. At the top pay attention only to the right-hand side. It's strongly recommended to choose GRUB and not ELILO unless you know what you're doing with the latter bootloader. Only choose the partition where "root" will go and don't alter any other setting there. Choose "full" installation because I don't know what the other two options would bring. It's not recommended to anybody lesser than a deep Linux expert to pick up the 32-bit edition of this distro because it installs no bootloader.

When I installed it onto a 32GB USB disk (c. 30GiB total), it occupied nearly 40% of space on the "root" partition. The good trade-off is that it consumes less RAM than many other Linux OS setups, at least in my experience. The Openbox default configuration is a bit ugly, in particular that clock at the bottom. I can't figure out how to change the font at least. Also it comes with "conky" which is not a "transparent window" like on eg. Bunsen Labs Beryllium. I wasn't comfortable with a window manager and therefore it took me a long time to make adjustments for behavior that I liked. Keystroke shortcuts and some of the panel buttons have to be changed through a dot-file. The "autostart" file has to be used, for example to run "synclient" program to enable the touchpad and change its reactions. The Openbox Settings Manager could be used to change the appearance of the windows, but not of the panel nor PCManFM. A separate program is required to change the wallpaper, I think the "LXPanel". I almost forgot to add that the "NetworkManager" required no fuss, unlike my previous brushes with Slackware-based except Salix.

Slackel comes with the GSlapt GUI program which is the front end to the "slapt-get" package manager, which is not "standard" Slackware and isn't very good at detecting package orphans. Sometimes, for example the user bids it to install an application which requires 10 packages. Then sometime later when he/she bids GSlapt to remove that app, only the app's package might be removed. This is although the other nine packages aren't needed by anything else in the system. This case doesn't happen all the time and otherwise, most users prefer it very much over the old "pkgtools" which don't provide any dependency resolution. The distro also borrows the Sourcery program written by "gapan", the head developer of Salix. From there I acquired Wine v8 although in 64-bit only. The program lists another repository but for Slackbuilds and other source code. When the user asks for installation of an app the source code group is downloaded. When the download is finished the various modules in the group are compiled and eventually an "SBo" module is created. GSlapt marks especially the apps installed via Sourcery. It marks as "taboo" a few things such as Linux kernel updates.

It's because a separate program is provided to upgrade the Linux kernel. Note there is a separate program to upgrade it for a system installed to an internal HDD/SDD and another program to do the same thing only for an external pluggable disk. The ISO came with v6.1.20; I have used this program so far to change the kernel to v6.1.24. It could have been neater about it because it changes how the GRUB menu appears and the messages displayed before the hardware clock is consulted. Freshly installed, it didn't put the two penguins at the top of the screen after the pause of several seconds which is the start of booting.

Slackel follows Slackware "current" and therefore it's a rolling-release model. Do not put off updating longer than two weeks. It might be wise to back up the whole disk holding an installation if it's small enough, before doing an update with many packages, in case something goes terribly wrong during or after the update process. Take it from me: I have installed this distro five or six times. "SLI" was less reliable last year and could still fail a few times. One time while it was in "release candidacy" I succeeded, although I had to manually start "NetworkManager" to get Wifi Internet. Then I made the full system update which changed at least a hundred packages. Then I discovered it refused to start into the "desktop" unless I logged in "manually" in "init 3" mode and then "startx". I was advised by "djemos" to install an additional library to rectify the problem. After that I couldn't shut down from the GUI, had to open a terminal and do the "sudo shutdown -h now". Finally I did something else to wreck it. It was about a week before the v7.6 Openbox release.

The distro boots somewhat slowly on my computer, although I have it on a fast disk. It comes with some useful programs like Geany, GIMP and Libreoffice. It has built-in Flatpak support. Leafpad which is pensive to use sometimes but useful to quickly write down something. Firefox "regular" as the web browser. Also Viewnior to look at images. It also has a video player, bit-torrent manager and other stuff that I'm less likely to use. PCManFM from LXDE/LXQt is the file manager, somewhat less annoying than on EndeavourOS or Zephix. Watch out with this one: there is a check box that affects your keypress of SHIFT+DEL, especially on a file located in a pluggable USB disk, and it will be gone immediately!

Slackware and anything based on it has extensive "devel" libraries that have to be installed on other distros. It's bloat to people who don't program even for leisure, or who are content to program for "bash". But it's an advantage to someone like me who uses a "foreign" programming system such as QB64 Phoenix Edition. However, there is other stuff occupying megabytes such as "texlive". I haven't figured out what this does. If nothing, then I would like to remove it because it's regularly being updated but it takes a really long time.
DISTRO NAME: Gecko Linux
VERSION: ROLLING ("Tumbleweed")

If it weren't for GeckoLinux I would have never touched OpenSUSE and I would have never understood the high praise this keeps getting. In all honesty, this is a good system which has a serious weakpoint: the YaST Software Manager. Other people think instead it's a strong point, and "zypper" is what is wrong.

In the last out of four times I have installed this successfully, I desired out of YaST completely, intending to do all the system updating and app adding and subtracting with "zypper". I lost heart after a few hours and uninstalled it. It was slow but faster than "dnf" on ROSA. This was after almost three hours "zypper" had to make up for a nine-month-old ISO. A rolling-release distribution with a "current" ISO older than three months is unacceptable and so is trying to make up for it with "nightly" and "weekly" builds. Calculate I'm looking at you. Also RebornOS which sucked in a different way although I decided to install it offline.

That last time was with KDE Plasma since a bunch of RPM-based distros away from Fedora/RHEL orbit seem to pick that one. It was beautiful, it even changed the desktop icons to match the accent color that could be chosen in System Settings/Appearance and dialogs page. People exist who deeply wish GeckoLinux could find time to create a new ISO for "Tumbleweed". Not everybody could do a "net-install". One day the full-system update will fail and it wouldn't be possible to do it successfully unless the ISP is paid a few hundred dollars a month.

The fact that the system update was successful twice in my experience, however, beats hands down Debian and whatever based on it. For example I had enough of siduction after more than three hours, too many questions with text-mode "dialog" that I have never gotten before asking me about low-level system gobbledygook, five rebuilds of the "initramfs" and failing the whole update totally while "apt" progress was over 95%. It could also beat any Arch-based distro but cannot risk it even two months. Cannot pick up an ISO for EndeavourOS or Manjaro in particular which is older than three months. Cannot do that right now with Redcore as well as Calculate if somebody really wanted Gentoo but not the "you are the installer" bit.

I have installed it three times in "Tumbleweed" mode which in Gecko Linux is called "ROLLING", and once in "STATIC" mode, based on "Leap" v15.4. Doing the "STATIC" was a big mistake. It had nothing to do with GNOME; in fact I rather liked it. However it was a mother trying to get QB64 Phoenix Edition v3.4 working on it. I had to seek out the additional libraries for it, and it worked well until the next time I asked it to update about two weeks later, which YaST Software kept asking me if I wanted to break dependencies if I expected to keep using that programming system. "Leap" later was raised another notch.

After that I installed with XFCE but v4.18 of that D.E. was very irritating on this distro. To me it looked like a racoon. I appreciated GeckoLinux's visual consistency, with Spiral Linux as well but this XFCE was fugly. I desperately sought relief out of YaST with "zypper" but got angry and had enough a short time later. At first I had to download over 1.5GiB of updates. Then resolved to update once a week, and couldn't even get to the third time. The OpenSUSE developers really need to sit down and redesign the GUI of that awful package manager. Sometimes when it shows only the progress bar of downloading packages it's very easy to press the "cancel" button that is below. Then when it suddenly pops out a dialog box warning about a dependency problem or something else. Why can't that be displayed in the dialog that exists while there is plenty of space for it? The distro makers decided to draw a dialog which takes up at least half my computer's screen, only to put a half-filled red bar and a button below it.

I don't remember anything about my first try except that it was "ROLLING" edition. Wine was no problem to install. Note that on OpenSUSE, "sudo" requires the user giving the "root" password; the user account's password is asked for only for logging in. One big reason why I chose Gecko Linux is because it comes with Calamares installer; I must install it to an external USB disk which is faster than the internal HDD (not SSD) of my laptop. Original OpenSUSE's installer doesn't allow it. If it does please correct me here, someone who is deeper into the base distro than I could ever be.

Indeed, like many other people have said, this is a great distro but I'm the biggest problem. The rolling release "Tumbleweed" (Gecko Linux "ROLLING") is superior to any other thing that uses a package manager for RPM format.
I've been using Gecko Linux since some time prior to 2016, I think.

I currently run the Cinnamon, KDE and XFCE flavours, very good distro, IMO.

You may or may not be aware that @GeckoLinux , the developer of Gecko and Spiral is one of our Members.


BASED ON: independent (RPM-based)

Note this is not to be confused with ALT Linux; these are two separate Russian companies providing distros forked from the RPM ancestors other than the original Red Hat. I had to download the ISO from the link provided by Distrowatch under the columns for the latest distro releases, on the left-hand side of the main page. Going to the distro developers' site and Wiki was far less productive.

Let me see if I remember everything, because this was a month ago, in the first week of April. The installer is Anaconda; could choose "ext4" for main partition. It's recommended for the user to design the target disk before running the installer because Anaconda is slow no matter which distro sports it. This distro could be had with GNOME or KDE. I chose the latter. It's one of the weirdest I have experienced.

Firstly it comes with GNOME session manager, not SDDM. Using the KDE system settings was OK but I should have written down what was about composition and touchpad, two critical areas that were just right on Spiral Linux KDE.

The weirdness with the desktop on ROSA is carried over to the bottom panel. The "Enter Edit Mode" of this distro/D.E. combination is very irritating. If a widget only has "Configure" and "Remove" options it makes it impossible to select either option with the mouse. I had this happening to me in OpenMandriva "ROME" also, I don't know why. I desired to remove the sleeping icon on the far right, and place the "Show desktop" rectangle-icon widget there instead. Cannot do it without trashing the whole panel and re-creating that panel. It's because pressing that sleeping icon immediately displays briefly a black screen with large letters on it saying that the screensaver daemon or something else about the hibernation wasn't ready yet at release, then the screen goes off and the computer subsequently refuses to respond to any gestures to make it come back to the desktop. This was something that ultimately turned me off about this distro.

Otherwise the "dnf" package manager was very slow. This is not for slow Internet connections nor for budget computers with 4GB RAM or less, because the user like me will have to accept the waiting for servers from the other side of Earth. Much like OpenMandriva, a GUI program is provided which is inferior to using "dnf" at the command line. The one for this distro was fairly unresponsive. At the time I installed this distro successfully it updated exactly one package: "info". After that I desired to see if it was different through the GUI program. That program hung up trying to download repository information.

I was able to install Wine but, because the OS runs a lot of services in the background, it was very CPU intensive trying to do anything with OpenMPT.

IMHO this was superior to Fedora 38 this year, and better than a bunch of other RPM-based distros. Rocky Linux even with GNOME would have been better if I were able to install Wine on it and treat it like I did with Fedora 35 last year. This ROSA would be a good one only if it weren't so slow and if it were more user-friendly with the looks. Perhaps their GNOME version is better.
VERSION: 0304 "winter"

OK it's been 1-1/2 months since I last had this and I had forgotten some things. But what I know is this is one of the best distros I've tried all around. This is true regardless of having a desktop environment or a window manager, how many files the installer copies to the hard disk and its performance related to the other two points. It's better if somebody has working experience about Arch or something else based on it, and has at least one other thing ready to go to prove it. This Archbang is a winner all the way through.

It is dressed only with "i3" window manager. It takes a bit of getting accustomed to. This distro spoiled me so much about it I thought I could handle the same W.M. on EndeavourOS then on Manjaro and miserably failed. In particular the "i3" version is the weakest flavor of EndeavourOS. It wanted to impress better with visuals, like Garuda, and assumed too much the user reserved one workspace for a specific app such as file manager or web browser. Please let me run whatever I want in whatever window I want, thank you. On Archbang I really didn't care about the keystroke commands other than splitting a workspace into two windows especially when I needed to copy a file from one directory to another. The mouse automatically focuses the window that is hovering over, but I don't know if that could be turned off.

Its installer is a "bash" script which makes it easy even for a noob like me. The instructions have to be followed in the order indicated by the menu! The user is recommended to set up the target disk before running the installer: at least 512MB ESP, a "swap" which is at least the size of the RAM on his/her system and an "ext4" partition in between. The installer first asks where to put the root directory, then where the ESP should be located. After that it copies many files into the main partition. Then it asks for other stuff which requires it to make modifications to the fresh-installed root partition, such as the clock settings, "root" password, creation of regular user and related password.

There is one step which is very important! That of the bootloader. Note that in the first step of the installer, it asks where the ESP should be, but not anything else about the bootloader. Later in the installation, the "bash" script that installs this distro has to be given specific instructions because I have screwed this up once. The user could choose between "GRUB" and "systemd-boot". The target path it expects is different for both -- for GRUB it's "/boot/efi" but for "systemd-boot" it's just "/boot"! The installer is going to ask the user and if it's not done right, and he/she is not a profound Linux expert who knows how to "chroot" and stuff like that, he/she will have to start over, erasing the target disk and re-creating the partitions before running the installer.

Otherwise many people must have wondered why Arch Linux is not so easy to install like that. Oh well, give more glory to something else...

Archbang comes with Thunar as file manager and L3afpad as text editor. Not sure now what was the web browser. Freshly installed it has a bit over 90 thousand files. Which is really darned good these days for a 64-bit system. This is as close to Arch Linux as I could get.

Of course after installing any rolling-release distribution, the first thing to do is the full system upgrade. This went down without a lot of problems. The somewhat terse help documentation, shown when L3afpad is opened for the first time, advises that after connecting to Internet, the user should give a few commands such as initializing the keyring, before "pacman" could be employed. Moreover, there is no "reflector" nor "pacman-mirrors" nor any other program available that rates mirrors. There is a "bash" script to do something about it that's half-broken; I advise not to use it. I wound up stealing the "mirrorlist" from one of my installations of EndeavourOS, for servers on countries nearest where I live.

LOL I took the idea from Manjaro "i3" for the "Terminess" font to use for this distro installation, because it looked kewl. Installed Wine which added a few thousand more files to the installation. Using my favorite program OpenMPT, the distro produced weak audio. It must have had Pulse Audio already installed but it needed settings that I was unable to look up in another Arch-based thing like EndeavourOS. Using the equalizer inside that program came up in the rendered MP3 and WAV files and otherwise was good enough for production or as a temporary solution. Sadly I got rid of this installation because I didn't know what else to do with it.

News flash: I went to check out the Sourceforge page to discover a "1305 spring" version made available a couple of days ago!

Surprising this distro has been around a long time but doesn't get a lot of social-networking airplay.
News flash: I went to check out the Sourceforge page to discover a "1305 spring" version made available a couple of days ago!
This hasn't been reported yet on Distrowatch, while babbling about "rolling" Ubuntu goes on and on, which really is a shame.
DISTRO: Mageia
VERSION: v9 Beta 2 "Cauldron"
BASED ON: Independent?

Kudos to the Mageia developers this time around for creating an installer which feels cohesive, although with the same windows as the "Alpha 1" installer that offended me months before. Poorly-drawn windows inside poorly-drawn windows but at least within one program that I would choose anytime over Anaconda. Slowly but surely they're getting there. The installer first offers the user three choices for desktop environment: GNOME, KDE or "other desktop environments". That's weird, I think it should ask user credentials and hardware configurations first. Then the program asks which disk the operating system should be installed to, but before that, it does like Ubiquity running the internal hard drive, which is unnecessary to an user who cannot pick that as destination. I had a 32GB disk that I cleaned out and therefore chose it as destination and "entire disk" mode. Then it creates the partitions it thinks it needs and begins copying files to the "root" partition. Note that this is an offline process; this is before any Internet connection could be accessed. It could take a long time, about an hour on older equipment that used to run Windows8.

When the copy process is complete the installer asks for "root" and regular user passwords, the regular user's name and handle. Then it asks the user more questions such as setting up the monitor and Internet. It offers to enable a firewall. Afterward it installs the bootloader. Finally the installer asks the user if he/she would like to connect to Internet to update the system. This is not recommended for slow connections because that could take twice as long as the offline install especially if the ISO is more than a month old, and it's not recommended at all to use the ISO if at least that much time passed and the distro creators really should offer a final release or candidate.

I chose "other desktop environments" and from the list (which also had GNOME and KDE) I picked MATE. It was the first time I would see this OS in a flavor other than XFCE. (It has one of the most beautiful XFCE default desktop looks around, at least it did last year.) It produces an appearance more or less like ALT Linux "Sisyphus" or Debian MATE.

The OS installed successfully on the 32GB "dongle." After the user logs in he/she is greeted with "Mageia Welcome" screen. I chose to bypass that for a moment to activate my Wifi. After I did that successfully, however, the icon on the right of the top panel kept showing an earth ball with "do not" small icon on it, although the network manager said I was connected via Wifi. Belatedly I noticed the clock was configured wrong. The Wifi icon did show up after I did the system update and rebooted.

Potentially everything could be done from the "Welcome" program. However I asked it to update but it claimed the OS didn't have additional candidates to refresh. Maybe because I have to add "tainted" repository as well as having "core" and "non-free". Started becoming impatient and therefore dropped to terminal, tried to do "sudo dnf check-update" to then be told my user wasn't in "sudoers" file. This is just like Debian, I can't believe it, only because I had to give a "root" password during installation! I had to enter as "root" and edit "/etc/sudoers" file which is not recommended to newbies. In fact using Nano it gives a warning at the bottom in white with red background that the file was meant to be read-only. I should know after enough times having to edit that file on Debian to be allowed to know what I'm doing. Then I regressed to my regular user and tried the "dnf" command again. Struggled instead with the flimsy Internet connection that I must pay for. Frustratingly later I discovered making a search for a package on the repos does the repo updates again. This folly, and the incompetence of any GUI installer/updater/remover is the reason why I tend to flee from RPM-based operating systems. Like many other things about this distro, the output has to be cleaned up a bit. It overwrites a progress bar with "determining the fastest mirror", so it will never be considered as elegant and "finished" as RHEL. I had a bit better luck with this, if Mageia servers are in Europe, than I did with ROSA which servers are even farther away from where I live.

Otherwise the retrieval of packages was fairly fast for my connection. I noticed Firefox ESR was installed on a rolling-release distro edition. This OS also comes with GIMP, Pidgin, Rhythmbox, the GNOME Video player and the MATE suite which includes Caja, Engrampa and Pluma (but not System Monitor and therefore no way to tell which version of MATE, kernel etc.). The plug-ins related to Caja does not include the "Open Terminal" one which I think is essential in Linux. Image modification is much less important to me out of a file manager.

"Configure Media" (the second tab of "Mageia Welcome") was fairly uncooperative; I needed to enable 32-bit repositories temporarily so I could install Wine. It seems to try to get information from one server in mid-eastern Europe, sticking up for several minutes. Cancelled and tried again, but was unsuccessful. It means the end of the line for this distro definitively. Sorry no glory without Wine and I don't want to be with a bird which is useless to me.

This inability will be unacceptable to somebody else who insists terminally in the proprietary audio and video codecs, which requires "tainted" group to be enabled. Such a big deal is made on that second tab -- what a shame it's so pretty. I found a way through "dnf" to enable "i586" mode but when I tried to refresh the repository information it insolently removed the repositories I added by hand. Very reluctantly installed things according to "wine64" tag but it didn't give me "wine" command, ie. to invoke 32-bit Windows programs, although it installed "gecko" and a fair deal that is "pseudo-multilib". This distro was always very lame about Wine anyway; last year when I tried to install it for the first time it still had a release older than anything else even Debian "stable" and Ubuntu LTS. Didn't dare go near that, just ripped it off.

More bad news. This is the first MATE install which insists on the tiny mouse cursor like "stock" XFCE. It ignores the "small... large" slider for mouse pointer size, while customizing the current theme. I don't want to change it to "dark mode" like I have Manjaro MATE.

I would have had to run it for a few days to see if it's anything like the epic fail of NixOS MATE version, where Engrampa didn't work because no archived file support, not even ZIP was installed and I couldn't figure out how to solve the problem.
Last edited:
CONTINUED: Mageia v9 "Cauldron" Beta

I'm sorry if I misled anybody in the previous post about my inability to install 32-bit Wine, but I have figured it out, reading the Mageia Wiki more closely. It's too bad they don't give the specific commands to do it, because they want the user to use "RPMDrake" which I'm still having problems with and, until it's successful downloading its junk from Europe, I cannot enable "tainted" or any other repository.

Before going ahead with installing 32-bit Wine must run the following commands:

[~]$ sudo dnf config-manager --enable cauldron-i586
[~]$ sudo dnf config-manager --enable cauldron-updates-i586
[~]$ sudo dnf config-manager --enable updates-i586
[~]$ sudo dnf config-manager --enable mageia-i586

So the repository list looks something like this:

[~]$ sudo dnf repolist
repo id                                      repo name
cauldron-i586                                Mageia Cauldron - i586
cauldron-updates-i586                        Mageia Cauldron - i586 - Updates
cauldron-updates-x86_64                      Mageia Cauldron - x86_64 - Updates
cauldron-x86_64                              Mageia Cauldron - x86_64
mageia-i586                                  Mageia 9 - i586
mageia-x86_64                                Mageia 9 - x86_64
updates-i586                                 Mageia 9 - i586 - Updates
updates-x86_64                               Mageia 9 - x86_64 - Updates

And after, do this and smile:

sudo dnf install wine32
Last edited:
CONTINUED: Mageia v9 "Cauldron" Beta

Once again I had to resort to the command line after looking things up again in the Mageia Wiki. It's really rude for a GUI program to stay displaying a progress dialog box, and nothing else, without any other information while it's waiting to retrieve data. It's even worse when it hangs doing that and for a time, it ignores the user trying to get its attention due to the first problem.

I had to use "urpmi.addmedia" and other things that should never be considered by somebody green about Linux. When there was any progress displayed, it was downloading at the epic speed of 50 kilobits per second or less. It took several minutes, and it included a "synthesis" of "non-free" repository from last year. (shake head) This was just for "core" and "non-free" components, before I could move on to "tainted".

EDIT: I have had Wifi falling a couple of times, with no other distro I've this problem. Must install "chrony" before trying to force synchronization of system date and time with Internet servers.

Then I used "urpmi.update" to add the "tainted release" and "update" but this stupid operating system didn't really enable them, had to go back to "edit media sources" to continue peaking me off wasting my time. GSlapt, which looks similar to RPMDrake, makes it easy to add a server or something else and to update the package information, and that's not even official part of Slackware. It seems there's no interest from the Mageia "community", whatever that may be, to make things more friendly to newcomers to Linux after almost nine major releases. Definitely Mageia isn't aimed at the family like they claim on the slideshow of the installer. It's all right for experienced users; I had to depend on what little I learned for 1-1/2 years. It might be good enough but Gecko Linux was less trying for me to use with different problems.
Last edited:
i've only been using linux for about 2 or 3 years. I held onto windows 7 for my business for as long as possible but was forced into Wind10 eventually. But when that POS bill gates started trying to inject me and at the same time my computer was annoying me every day to install windows 11 i looked in the mirror and said, " I don't deserve this." Leaving for linux was like being reborn.

I started with Mint and it has been wonderful. moving into the command line for email with mutt has been a game changer. same with editing documents with nano. learning bash and writing my own scripts that i can run in the terminal is addictive. And cmus is the reason i started listening to new music again.

i don't really understand the differences between the distros. sure they look different and have some different commands, but for me i'd probably use them for the same purposes. is it that some distros have packages not available on others? what is it that one distro can do that others can't?

it's nice to have a 'main stream', well supported distro like Mint for noobs that just works. Scanning a document has been the biggest challenge, but as of the latest Mint (21 i think), everything just started working automatically. no drivers, no settings. it just miraculously scanned like it is supposed to. everything works out of the box, like bluetooth.

But the fun of Linux is that you can get into the guts and figure out WHY it works. i'm happy with Mint for an everyday desktop, but i've been playing with retro computing and have since started digging into TinyCore. really fun. i do it as a hobby setting up cheap computers to run simple databases and eventually and hopefully control some valves with arduino. i'd like to contribute somehow and want to learn how to compile, because some of the extensions either don't work or are friggin impossible to set up (MariaDB-10.6 for example) and there is scant info online compared to more popular distros.

so that's my input: Mint or TinyCore (the only 2 i've ever used lol). but i'm really interested in why people choose one over another.
Last edited:
i don't really understand the differences between the distros.
To my mind, there are only 3 basic differences, all distributions start life as an idea of an individual or a group of like-minded people, being Linux users they have developed their own ideas as to what a distribution should be.
There are thousands of possible Linux applications, that can be conglomerated in a myriad of ways, some developers want to make the fastest lightest distribution they can, some want the coolest looking, and some want a distribution aimed at a specific task. Every developer has the same warehouse full of parts available, but will pick the parts either they prefer or work best for their project and assemble them.
all distributions start life as an idea of an individual or a group of like-minded people its a personal disposition rather than strictly technical. interesting. i didn't expect that as an answer.
I'm in the 'fastest and lightest' camp myself, but there are certain real-world priorities that necessitate some heft. I like the ideas of independence and frugality. So far TinyCore doesn't give me all that I need but will be a fun project to make it so.
So far TinyCore doesn't give me all that
It's many years since I played with Tiny Core or DSM [damn small Linux], they were quite fun to play with in the early days, but now I am old, I tend to stick to full OTB builds,
It's many years since I played with Tiny Core or DSM [damn small Linux],
These distros are too sadistic for me. I stopped at Puppies to keep me from getting bald.:(
I worked in IT alright, but never in Unix based environment.
I take Linux as a hobby and am like a street fighter who doesn't know martial arts.
These distros are too sadistic for me.

LOL i know, i know. i've stopped and asked myself why tf am i doing this? i've accepted the hard truth that i'm just a masochist.
but linux is cool because you can actually make meaningful contributions. I also do it as a hobby and like the idea of creating something that may be appreciated by others in the 'group of like-minded individuals' that Brickwizard mentioned.
DISTRO: elementary OS
VERSION: 7 (Jan-2023)

Many people would balk at the main website after a short time. It's rude to ask for 20 USD in particular, expecting the user to press the blue button where credit card details and other personal information is sought. "Well I could download something else for free!" would be the typical reaction. That's why this distro gets such bad parting shots from people who check it out for a rather short time. It should suggest ZERO DOLLARS and then either a download button not revealing a link to the ISO, or some "promotion" with a "no thanks please give me the download" option.

I read somewhere the story between the original lead developers of the distro. What a shame the guy became greedy. I salute the lady for staying firm about it. Sadly it adds to male chauvinists I guess not taking this distro seriously, because they are also affected by resentment toward "systemd", toward Ubuntu's track record and much more.

It's recommended to prepare a disk with GParted, before booting the ISO, if you don't want to risk your internal hard disk. It has an option, "ERASE DISK AND INSTALL" which I didn't dare go near. I selected the other option, "EDIT PARTITIONS" or now I don't remember exactly what it is called. After a really long time it takes to move the internal HDD on my computer, everything is straightforward. It's because I met the qualifications: ESP of at least 512MB; in GParted format that as "fat32" with "esp" and "boot" flags enabled, "swap" of at least 2GiB, and the "ext4" main partition in between. Because I was affected enough by bootloader failures in the past with Debian- and Ubuntu- based distros ("get a newer version of ''fsck''!") I observed how it was done by "automatic" partition setups. Therefore I also made sure there was a 2MiB space in the very front of the target disk, before the ESP. It doesn't always work with some distros which is irritating. Anything with Calamares installer seems to want to be allowed to do what it wants. BTW the installer for elementary OS is a derrivative of Ubiquity.

Another thing some people would like, while others (like me) don't: right after the installer finishes, it gives a message for about a minute about that fact. Then right away it tries to go reboot the computer. I think it should wait for a keypress from the user.

When the OS is fired up the first time, it asks for the system language and main keyboard locale, then asks for the regular user's name, password and local host name. It suggests to the user to connect to the Internet at this stage. Because other users reported problems with Wifi with this distro, I elected to use the old yellow cable, able to do so on an 11-year-old portable computer.

The Linux kernel is v5.15 coming from Ubuntu LTS "Jammy Jellyfish". The system could be updated to v5.19 but by this time even this heavily-patched kernel is being considered an increasing security risk. Paranoid people need not apply.

The Pantheon D.E. is a main feature, it was derrived from GNOME it appears with some hints taken obviously from MacOS such as the bottom panel of app launchers. What always gets me about this distro is the "X" to close a window on the left-hand side of the titlebar. The desktop looks attractive, which is the idea to involve total beginners out of MacOS and Windows. I like the wallpapers it comes with, LOL saves me impulsive visits to "w___p____c___-dot-com" and other places filled with bad taste.

The "Application/Permissions" tab of system settings has some weird values: "Music", "Video" and "Web" categories don't get permission for the Home folder. The quite-common combinations of shift-key and spacebar are the options available to change input method which is something I didn't expect and would like to have control over. The mouse pointer could be made much larger, which is much appreciated. Shame on you GNOME, for not making it this easy. There is the option to find the mouse pointer easily by pressing CTRL but on my computer this works only for the left-hand's shift key. The "Notifications" section could be quite a bore adjusting things for each and every app installed through the App Center. Not my kind of thing.

EDIT: clarify that ALT+SPACE does not open the menu to move, resize or minimize a window on this operating system. Somebody could correct me on this.

The system theme has a flaw I think. Maybe the reason why a "dyslexic" option is offered is because the font the devs of this distro chose could be too small for users 50 years and older. A few might actually prefer Cantarell font which is GNOME default. Some apps will have cramped dialog boxes such as the program preferences of Geany.

elementary OS wins with one thing that I am so sick and tired of other Linux OS's about. This seems to allow the date and time changed without giving any password. In the very least, it allows the time zone changed and allows disabling of network-influenced clock setting, without entering a password. That's the way it should be. Please hold your excuses and the distro maker's justifications about it, Windows never got in anybody's way especially when the time is set flatly wrong about four or five hours behind in some cases and there's no other way to change it, especially since few distros outside Slackware pay attention to "/etc/adjtime" file. I have always maintained the "local" time of my computer to UTC, preferring to have the desktop show it as local time according to the time zone.

Went to update in terminal, refuse to do it the GUI way because of really bad experiences with Pamac, GNOME Software and KDE Discover, and I don't want to deal with one less popular than that which also asks for money. I had to get rid of 400MB of language packs. Sorry English only and it's a doubt somebody else besides me will use the ageing computer. I noticed for once a request was made to run grub-mkconfig, the system did it twice. So I cannot hope to preserve my fading internal HDD with this OS.

The App Center insolently puts itself back on the dock after the user bids it to chill out. This is not the way to make friends among the people who have some experience with Linux OS. Also not very nice is opening the App Store to accept updating, but then updating fails because a component has to be changed as if this were the "distro upgrade" mode of Fedora or the infamous "Do not turn off your computer" gag not from Linux. Trying to do something about the "Runtime Updates" causes failure while the system is running. In my second attempt I tried to start the whole update procedure over but the OS locked up my system tight. I was forced to break into "tty" mode and give the command to shut down the computer, but not before "systemd" held up for about two minutes. Rebooting afterward, trying to open the App Center and the updates section crashed back to desktop.

What I think is the App Center should request "sudo" permissions temporarily. Otherwise "repair" seems to do nothing. I have yet to find a GUI program that could do its job gracefully installing, removing and updating applications. Synaptics was always a confusing mess, and YaST Software seems to be patterned from it. The App Center is the vulnerable part of the entire elementary OS.

Somehow, however, I got it to work correctly, but not before it held up for a really long time for what it claimed was only 4.7MiB. Likely it was downloading at 20KiB/second or less, that's why it wasted even more time.

I wound up installing Nemo because the File Manager based on GNOME is really tiresome. The latter has few program options, and therefore it's always opening at the last location it was closed with. It seems to dislike /home/(user)/bin so I had to select a different last name for PPA's installed manually. Pulled in Wine but running "winecfg" the first time hung up. Tried again after reboot with no change. Otherwise no problems. I got sound in OpenMPT but I should have gone farther testing it, with plug-ins. After "winecfg" run the Linux OS installation has less than 120 thousand files, however it consumes more than half of 25GiB from an external 32GB USB disk.

To Danielle and assistants: keep up the good job on the distro! Yes it is slow sometimes, have to like the look and accept the silly scrolling animations, updating the "elementary apps" could be a trying experience and a few other things might not be to the expectations of Linux die-hards, but this distro is better than a bunch of others I have gone through. I dare say this is better than Solus because I prefer periodic updates of an LTS instead of rolling-release model that tends to break stuff and affect confidence.
Last edited:
Mageia was created in 2010 as a fork of Mandriva Linux

... and then, Mandriva itself was a merge between Mandrake and Connectiva - it's like peeling the layers in an onion. ;)


Members online