Raspberry pi loses hdmi0 output when audio cable is plugged in

VP9KS

Well-Known Member
Credits
319
I finally received all the video adaptors I needed to do the first bootup on my Pi 4. Everything went well until I decided to get the audio up and running. My research showed that I needed the 4 conductor plug, because composit video was on this connector also. So I broke out what I perceived to be the proper cable, and plugged it in. Immediately, I lost the HDMI 0 output, and there was no audio output. rats! I unplugged it, but the video would not come back. I had to shut down the Pi and bring it back up to get video back. I tried pairing it with my bluetooth headset. The headset reported being paired but, again, no audio. I tried plugging in a regular stereo cable. I had audio, but again lost the video output to HDMI 0. What am I doing wrong?
 


HuMJohn

Member
Credits
0
There is a configuration file, somewhere, in the /boot directory that you may need to change a setting or two, in order to keep your HDMI function and have the audio go out the 3.5mm port.
By default, the audio is bundled to be on HDMI, when you are using an HDMI video monitor.
Once you have the audio separated from the HDMI, going out the 3.5mm socket, then you can use an ordinary 3-conductor audio cable.
Right now, I am not near my Pi's, and I can not recall the name of the configuration file. And you may need to google how to configure Raspberry Pi settings in that file.
 

xXNORDXx

Member
Credits
0
I have the Pi 4 4gb and I am having difficulty with the Hdmi out as well. I think my junk Tv my be the issue though i'm going to try a different tv i think.
 

xXNORDXx

Member
Credits
0
update after i downloaded some drivers you have to set up in hdmi in audio controls still having issues with blue tooth and netflix.
 

Peer

Well-Known Member
Credits
349
Bluetooth Audio is a big problem on all pis, to solve this just Google for raspberrypi Bluetooth headset and follow those instructions. My hdmi out works fine, at the beginning I had time to some random and weard full screen flickering but after some new kernels this doesn't happen anymore.
 

VP9KS

Well-Known Member
Credits
319
There is a configuration file, somewhere, in the /boot directory that you may need to change a setting or two, in order to keep your HDMI function and have the audio go out the 3.5mm port.
By default, the audio is bundled to be on HDMI, when you are using an HDMI video monitor.
Once you have the audio separated from the HDMI, going out the 3.5mm socket, then you can use an ordinary 3-conductor audio cable.
Right now, I am not near my Pi's, and I can not recall the name of the configuration file. And you may need to google how to configure Raspberry Pi settings in that file.
I see what you are saying here. The problem is that I am not using a HDMI display. I am using a HDMI to VGA adapter connected, through my 4 port KVMA switch, to my 21 inch Dell analog monitor. I have tried changing some of the values in the config.txt, but no luck as yet:rolleyes:.

Happy Trails,
Paul
 

VP9KS

Well-Known Member
Credits
319
Thanks, mate.:) I'll check it out. In the mean time, I have been doing a little testing. I found that the Pi will display the aviation sectional chart TIF files better than my trusty dual core in the lab computer. It updates the display much faster when I zoom in or out:p I am on it right now, and here is my Pi4 desktop.
2019-12-22-104920_1680x1050_scrot.png


Once I get the sound problem taken care of, I will explore the Slackware install.

Happy Trails,
Paul
 

VP9KS

Well-Known Member
Credits
319
My current config.txt file has the following lines not remarkrd out:

dtparam=audio=on
dtoverlay=vc4-fkms-v3d
max_framebuffers=2
hdmi_force_hotplug=1
 

HuMJohn

Member
Credits
0
OKay, try this:

Open a terminal on the Pi and enter:
sudo raspi-config

Select Advance Options then Audio. At this point, you can force the audio to either the HDMI out or the 3.5mm output. Or you can set it to automatic.
 

VP9KS

Well-Known Member
Credits
319
Thanks again mate, I will try that when I get home. I am on my tablet right now. Merry Christmas to all!

Happy Trails
Paul
 

VP9KS

Well-Known Member
Credits
319
OKay, try this:

Open a terminal on the Pi and enter:
sudo raspi-config

Select Advance Options then Audio. At this point, you can force the audio to either the HDMI out or the 3.5mm output. Or you can set it to automatic.
I tried the information that you gave me. It did not work (rats!):oops: I have been scratching my head over this one for a while. Here is my conclusion. I apparently purchased the wrong HDMI to VGA adapter. The correct one should have a 3.5 mm stereo socket built into it, for the audio output to the pc speakers. The two that I purchased do not have this audio output. They work fine if all I need is the display, for a projector presentation for example, but not for my needs. HMMMM. Back to the drawing board. I will need to return these, and order the correct ones. (Film at 11:rolleyes:) A lesson learned. Hopefully my trials and tribulations will help to keep someone else from making the same mistake.
The "sudo raspi-config" command that you told me about works just fine, and will come in handy in my exploration of this little gem. Thanks for the info mate:).

Happy Trails,
Paul

P.S. Please let me know what you think of my conclusion.
 

HuMJohn

Member
Credits
0
in /boot/config.txt file, find the line that has
hdmi_drive=2
and comment it out. Next, look for
dtparam=audio=2
make sure it is enabled.
There are other settings that can effect both, video and audio, outputs. Google 'raspian config.txt file settings' to get the full list of possible settings for the Pi.
 

VP9KS

Well-Known Member
Credits
319
in /boot/config.txt file, find the line that has
hdmi_drive=2
and comment it out. Next, look for
dtparam=audio=2
make sure it is enabled.
There are other settings that can effect both, video and audio, outputs. Google 'raspian config.txt file settings' to get the full list of possible settings for the Pi.
Are you using a HDMI to VGA converter on your Pi 4? How are you getting audio output?
 
Last edited:

HuMJohn

Member
Credits
0
I have an DVI monitor without speakers. I am using an HDMI to DVI cable to drive the monitor.
At this time, I do not have the speakers attached to any of my Pi's. I used to have, but then I decided to clean up my cluttered work table and the speakers were tossed into the parts bin.
Of my three Pi's:
Pi 3b - Headless (No monitor, keyboard or mouse)
Pi 3b+ - HDMI to DVI cable to monitor. USB keyboard & mouse
Pi 4b - Headless, (This is my NSA server, with an USB external drive)
 

VP9KS

Well-Known Member
Credits
319
I sent the adapters back, and ordered 1 with the audio out on the side. It will not arrive until the end of this month, so I an on hold once again:(.
 


Members online


Latest posts

Top