Quake doesn't launch in Debian 11

Terminal Velocity

Active Member
Joined
Oct 13, 2021
Messages
251
Reaction score
156
Credits
1,818
I found Quake in the Debian repositories and I installed it, when I click launch this message appears
Screenshot from 2022-03-04 16-01-32.png


What to do
 


Lord Boltar

Well-Known Member
Joined
Nov 24, 2020
Messages
2,036
Reaction score
1,437
Credits
15,091
Various games are divided into two logical parts: engine and data. Often the engine and data are licensed in different ways, such that the engine can be distributed in Debian but the data cannot.
game-data-packager is a tool which builds .deb files for game data which cannot be distributed in Debian/Ubuntu
It is telling you what to do "Install game data for Quake" and that is what game-data-packager does - it builds the game data to a .deb file so you can install it

You have to build the game data

 
OP
Terminal Velocity

Terminal Velocity

Active Member
Joined
Oct 13, 2021
Messages
251
Reaction score
156
Credits
1,818
Someone in the comments of the software manager said that I have to run the following:
Code:
sudo apt-get install innoextract lhasa
game-data-packager -i quake
I did and it worked but the game is too old, I didn't remember it so bad
 

kibasnowpaw

Active Member
Joined
Jan 2, 2022
Messages
223
Reaction score
109
Credits
1,844
why not just get it on steam?

 
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Linux.org Hosting Donations
Consider making a donation

Members online


Latest posts

Top