Qnap Nas share timeouts

Amonter93

New Member
Joined
Jan 27, 2024
Messages
6
Reaction score
4
Credits
78
I switch over to Ubuntu 23.10 January of 2024. I have a QNAP 2 bay NAS that I use for all the devices in my network. When I first set up Ubuntu it was able to see the NAS and connect to it without issues.


Today, after a reboot I can no longer connect to the NAS. Ubuntu shows the name of the NAS but when I tried to connect to it, it takes a long time and then gives me a timeout error.


I have two two other windows computers and a Linux laptop (Pop OS) and they are all able to access NAS. I can access the NAS via the web interface and there have been no recently changes to either Ubuntu or NAS from me manually. I am looking for a way to troubleshoot the issue and any information would be helpful.
 

Attachments

  • Screenshot from 2024-04-29 17-07-17.png
    Screenshot from 2024-04-29 17-07-17.png
    36 KB · Views: 63
  • Screenshot from 2024-04-29 17-06-20.png
    Screenshot from 2024-04-29 17-06-20.png
    10.4 KB · Views: 61


Dumb question time: Have you tried just rebooting your router?
 
Not a dumb question.

Here are all my troubleshooting steps for today.

  • Rebooted Router
  • Rebooted NAS
  • Checked for any firewalls. The firewall is inactive on Ubuntu. On the router it allows all needed ports.
  • Used time-shift to go back three days.
  • Tried nautilus -q to close the file system
Restoring from time-shift fixed the issue for little bit. I downloaded all the updates for Ubuntu and then rebooted the computer two times. The issue did not re-appear after the reboots. A new issue appeared in where Ubuntu would locked itself and give the "something went wrong message". Used the link below to fix that error. Decided to go back to the troublesome snapshot and use the same command to clean everything up to see if that fixed the issue. It did not fix the issue. Afterwards reverted back to the snapshot that was working before. However, the issue now persist with the snapshots that did not have the issue.

Oh no something went wrong issue

I learned the following

  • The issue is not cause by an update
  • The issue persist even with Prior snapshots and is random until is encounter. Afterwards, the issue will persist constantly
  • There are no issues with internet connectivity
  • The OS can see the NAS but timeouts in connecting.
  • I can only assume that there is something wrong with the protocol SMB connection or nautilus itself.
 
I went ahead and set up the fstab file with permission needed for the share last night. That works and it does what I need it do thanks.

Funny enough, I just woke up and nautilus now works out of the blue too. Nautilus was not working last night even after the fstab file set up and multiple reboots. I think this and issue with Nautulis itself as every once it a while it would disconnect the drive for a few seconds. I will stick to using the fstab file as seems is more reliable. Thank you all for your help.
 
If you are exposing your NAS to the Internet and based on the fact that you said your router ports are open.

You are making a mistake by doing that. If you need access to your NAS from outside your home network, use a VPN or use RealVNC or something similar.

Everytime I hear someone crying about their NAS being compromised. That is exactly what they were doing.

EDIT: btw, the first thing you should do is clone your "admin" user with all permissions / groups with a non-standard name. Then disable the admin account. Most attacks on Internet facing NAS devices brute force the admin account. If the admin account is disable, they will never succeed in that brute force operation!
 
Last edited:
Thank you for the advice. I will look into using VPN for outside connections. I did clone the admin to another non-standard name disabled the admin account when I first set up the NAS. I usually never use the default admin account if I am not forced.
 

Staff online


Top