problems with installing manjaro off of a usb drive

OP
M

Me!

New Member
Joined
Oct 4, 2021
Messages
24
Reaction score
8
Credits
179
and bwiz, when I try to reinstall from the beginning I am faced with the same options i described earlier, no extra ones.
 


brickwizard

Well-Known Member
Joined
Apr 28, 2021
Messages
1,202
Reaction score
920
Credits
8,990
Ok just an idea that sometimes happens
 

captain-sensible

Well-Known Member
Joined
Jun 14, 2019
Messages
2,531
Reaction score
1,672
Credits
15,089
Re: POST #40

i think that would be trying to install to MBR with the command you quoted .


For Arch its along the lines of : grub-install --target=x86_64-efi --bootloader-id=GRUB --efi-directory=/boot/efi

At least that was my command on Vanilla. Manjaro is based on Arch but don't run that command i posted yet until some manjaro users have checked it over, manjaro has some quirks.
 
OP
M

Me!

New Member
Joined
Oct 4, 2021
Messages
24
Reaction score
8
Credits
179
Ok, I finally figured out what the problem was (it was something stupid as usual, and I am truly sorry for wasting your guys' time because this was something so simple that I just overlooked it). So someone over on the manjaro forums told me to remember to take out the usb drive after installing before restarting, so I did that, and it didn't seem to have any effect. But I was just curious, so I went into my BIOS and started looking around. I went into the boot menu, and saw that for some reason the NVME that I had installed manjaro to wasn't in the list of boot priority, rather it was in the part where it has other drives that aren't in it. And sure enough, when I put it into the boot order, and booted the computer, I found myself in the complete version of Manjaro KDE and am now messaging you from there. You guys have been a great help, and I as I said before (when I thought that I was finally done and would have linux installed by the next day haha), without you I would still be desperately searching the internet.

Thank You!
 

wizardfromoz

Administrator
Staff member
Gold Supporter
Joined
Apr 30, 2017
Messages
6,603
Reaction score
5,360
Credits
19,447
Wonderful news.

Enjoy your Linux. :)

Wizard
 
OP
M

Me!

New Member
Joined
Oct 4, 2021
Messages
24
Reaction score
8
Credits
179
btw its great so far, and honestly, contrary to what I've been told, its actually quite similar to what I was expecting!
 

Fanboi

Well-Known Member
Joined
Apr 16, 2021
Messages
358
Reaction score
270
Credits
4,288
Glad it's sorted. Wouldn't entirely blame myself if I were you. Hell, I couldn't find the virtualization settings to enable KVM on my board, but luckily MSI decided to include a search function. I also struggled with boot order coz it shows multiple devices for the same device :shrug: so you're not 100% alone there.
 
$100 Digital Ocean Credit
Get a free VM to test out Linux!


Top