Problems with Display Port 1.4 and DSC on Intel Iris XE

Prelator

New Member
Joined
Jul 23, 2022
Messages
5
Reaction score
0
Credits
38
Hello there,

i have a problem with my new laptop (Lenovo X1 Carbon G10) and my LG Ultragear 4k 144Hz Displays:

if i use the display with 144hz i get many problems and black outs / flickering on it.
i have always testet this:

https://wiki.archlinux.org/title/intel_ … flickering

when i use the display with 95hz i dont have any issue. I think this is maybe a Problem with non enabled Display Stream Compression (DSC).

have anyone an idea?

PS:

On Windows 11 i dont have any issues with this configuration @144hz.

best regards

//arch linux 072022
 


f33dm3bits

Gold Member
Gold Supporter
Joined
Dec 11, 2019
Messages
4,900
Reaction score
3,527
Credits
35,667
Are you using Xorg or Wayland, if you are using Xorg try and using Wayland instead to see if the problem persists or not.
 

f33dm3bits

Gold Member
Gold Supporter
Joined
Dec 11, 2019
Messages
4,900
Reaction score
3,527
Credits
35,667
And does your laptop only have an Intel graphics chip or does it also have an Nvidia graphics card. If it has both you may want to look at Nvidia Optimus.
 
OP
P

Prelator

New Member
Joined
Jul 23, 2022
Messages
5
Reaction score
0
Credits
38
Are you using Xorg or Wayland, if you are using Xorg try and using Wayland instead to see if the problem persists or not.
iam using xorg. i have tried it now with wayland. some problem here...
And does your laptop only have an Intel graphics chip or does it also have an Nvidia graphics card. If it has both you may want to look at Nvidia Optimus.
the laptop has only the intel gpu.
 

f33dm3bits

Gold Member
Gold Supporter
Joined
Dec 11, 2019
Messages
4,900
Reaction score
3,527
Credits
35,667
What DE are you using, I've seen posts where changing around certain settings in the DE effected flickering.
 
OP
P

Prelator

New Member
Joined
Jul 23, 2022
Messages
5
Reaction score
0
Credits
38
what do you mean with DE? Desktop Environment?

Its KDE / Plasma @ Arch Linux 072022
 
OP
P

Prelator

New Member
Joined
Jul 23, 2022
Messages
5
Reaction score
0
Credits
38
Disabling the compositing does not have an Effekt.

With 144hz i get flickering and this artifacts.
 

Attachments

  • 20220724_171927.jpg
    20220724_171927.jpg
    2.1 MB · Views: 35

f33dm3bits

Gold Member
Gold Supporter
Joined
Dec 11, 2019
Messages
4,900
Reaction score
3,527
Credits
35,667
If you don't already have it installed try installing xf86-video-intel and I came across a post somewhere where someone had flickering and they installed the lts kernel and it solved them for them.

Is your LG Ultragear 4k an external monitor so when you have it connected to your laptop together with your laptop screen you are using two screens? If so what is the supported refresh right on your laptop screen?
 
OP
P

Prelator

New Member
Joined
Jul 23, 2022
Messages
5
Reaction score
0
Credits
38
If you don't already have it installed try installing xf86-video-intel and I came across a post somewhere where someone had flickering and they installed the lts kernel and it solved them for them.

Is your LG Ultragear 4k an external monitor so when you have it connected to your laptop together with your laptop screen you are using two screens? If so what is the supported refresh right on your laptop screen?
i have two LG Ultragear 4k 144hz Monitors. Both runs atm with 95hz super smooth. native refresh rate is 144hz.

laptop screen is disabled.
 
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Linux.org Hosting Donations
Consider making a donation

Members online


Latest posts

Top