Purchase Linux CDs / DVDs / Flash Drives at OSDisc.com

Welcome to Our Community

While Linux.org has been around for a while, we recently changed management and had to purge most of the content (including users). If you signed up before April 23rd, 2017 please sign up again. Thanks!

Problem with video files from recordings

Discussion in 'Mint' started by Caloxeno, Dec 26, 2016.

  1. Caloxeno

    Caloxeno Guest

    A few days ago, I barely knew what Linux was. But when I installed Linux Mint, Most of the stuff was wonderful; It was not the case of screen recording.



    I first wanted to record with OBS, using pretty good quality and with MP4 as output format. I recorded what I wanted to record, but when I saw the recording, there were black flashings in different parts of the screen, and the interface also dissappeared and re-appeared like in flashings.



    "Strange" I said. So, I used much lower quality and MKV as output format. I had the same result.



    "Then the software is wrong" I thought. So I installed Simple Screen Recorder. Tried with all the different settings, but, even if it was much less glitchy, I was still getting the same glitches.



    So I tried with Kazam. No different results.





    "It must be the media player" I said. So, I tried with VLC, and even with YouTube, but there was no difference.



    I uploaded an example glitched recording to YouTube, you can see it by going here:




    I will also leave the message that the terminal sent me after writing the command Inxi-Fxzd. Here is the pastebin link: EDIT: I am not allowed to post links, and if I paste the terminal content here, it says there is a "sneaky url".


    I will provide as many info as requested to fix this issue.

    Thanks.

    -Caloxeno

    PS: If you see this thread in other forums, I probably was too lazy to write a thread for each forum
     
  2. JasKinasis

    JasKinasis Guest

    Hmmm, interesting.
    I'm running Debian Testing and I'm seeing exactly the same thing using simple screen recorder.
    I haven't tried to take any video of my desktop since back in the summer and it was definitely working properly back then. But after reading your thread, I had a go at recording a bit of my desktop session.... It looks like it's some kind of bug in the graphics pipeline somewhere, or perhaps something in the configuration/settings that has gone a bit screwy since some update somewhere. As for exactly where it is occurring and when it went wrong, I have absolutely no idea.... I'm not sure where to start with debugging this!

    I haven't noticed any problems when playing videos, playing games, or doing anything else graphically intensive. Editing/exporting videos using Blender and Kdenlive/Openshot etc. All works without problem. Likewise with recording audio. The only problem seems to be capturing video output from the desktop.

    I have a dual graphics card setup on my primary laptop and I've tried capturing video using both graphics cards and the results are exactly the same. I've also tried using different desktops too - I have dwm, Enlightenment and KDE installed.

    In all cases - the videos were extremely flashy/glitchy, just as you have reported. So perhaps it is a graphics driver related issue, or perhaps it is a bug with X itself. Or perhaps it is some kind of syncronization issue - perhaps simple screen recorder is capturing frames at different stages in the drawing cycle - sometimes capturing complete frames, other times blank or partially drawn frames..... But audio in the video was always smooth. So the audio is being captured OK.

    Might be worth checking out the forums for Simple Screen Recorder and see if there are any other reports of this behaviour.
    Otherwise, perhaps the developers might have some ideas what could be causing this kind of behaviour.

    I don't have a lot of time to chase this up ATM, but I will take another look at it at some point. If you do track down any potential fixes for this in the meantime - please share them here!
     
    1 person likes this.
  3. JasKinasis

    JasKinasis Guest

    OK, a quick look at the Simple Screen Recorders bug-tracking system on github yielded this:
    https://github.com/MaartenBaert/ssr/issues/492

    So it looks like we aren't the only people experiencing this issue. And as I suspected, it looks like it may be some update to the X-server which introduced this problem. I have managed to reproduce the bug with several different WM's/desktops, so the common link between all of these is X11. So that would seem to indicate that an update to one of the X libraries that occurred at some point in August/September was probably the cause of the issue!

    Saying that, I've just used recordmydesktop and that works pretty much flawlessly.... :/
     
    2 people like this.
  4. Caloxeno

    Caloxeno Guest

    @JasKinasis Thanks for the replies!
    Yes, we definitely have the same problem.
    But my PC is at the technician right now because some kind of malware ruined my windows (Oops) and I am not having it back until at least 48 hours.
    But after I get it back, the first thing I'm gonna do is to clean my disk, and reinstall Windows. After that, instead of installing linux mint, I will give a try to a different distro called Apricity. If I can record normally with that distro, this case will be solved :D

    If I can't, I will start to think it is my PC :/

    But anyways, thanks again for the replies!
     
  5. Yesyesloud

    Yesyesloud Guest

    Apricity seems nice, I'll also try it out. Great find
     
  6. JasKinasis

    JasKinasis Guest

    I don't think it's your distro that is causing the desktop recording problem, it's the software itself!
    As far as I can tell, something has changed in one of the X libraries and it is causing the bug to manifest in simplescreenrecorder and some other screen recording software.
    But, as mentioned in my previous post - recordmydesktop works for me.
    So I think it has something to do with whatever method simplescreenrecorder is using to capture frames from the X server.
    Recordmydesktop must use a slightly different method, which is unaffected by the changes to X.

    So perhaps try recordmydesktop instead of simplescreenrecorder?!
     
  7. JasKinasis

    JasKinasis Guest

    Thanks to your first post - I've just tried obs-studio on Debian Testing (I'd never heard of that one before) and it works flawlessly for me. So thanks for that! Looks like it will come in handy for recording desktop sessions on Linux!
     
  8. JasKinasis

    JasKinasis Guest

    OK, this is interesting. I've taken a look at some of my .MKV videos, which I captured in simplescreenrecorder yesterday in Dragon (The KDE video player) and all of the videos look completely OK. Previously I was watching the recordings back on VLC and seeing all of the flashing/frame related issues.
    So on VLC, the MKV videos do not play back correctly. Whereas on Dragon - they do play correctly.

    So it appears that there is NOT a problem with simplescreenrecorder or X. It actually looks like a bug in one of the libraries used by VLC for playing back the MKV format. The libraries affected by this playback bug might be in use by several other media players. Whatever Dragon uses for MKV playback works.... At least that is the case with my Debian Testing system.

    So it turns out that there isn't actually a problem with recording at all, it's a playback related issue!
    Recordings made in simplescreenrecorder in .mkv format currently only play correctly in Dragon-player, but recordings made in all other container types that I tested (.OGG, mp4, .webm and .flv) play perfectly in Dragon and VLC. .

    To test further, I have also tried recording some mkv's from obs-studio and again - the mkv's do not play-back correctly on vlc, but they play correctly on Dragon. But all other container formats (webm, ogg, flv etc) work well on Dragon and VLC.

    So, if anything - perhaps try a different container format for your desktop videos until the mkv playback bugs are fixed in VLC (or whatever backend/library VLC uses for mkv)?!

    When I tested obs-studio earlier on (see previous post), I was using its default .flv container. But later, when I switched to mkv - I noticed the flashing/frame problem when playing the videos back in VLC. But when I played the captured mkv's in Dragon-player - the video played perfectly.

    So I now think that this is a bug in the backend library/libraries that VLC uses for mkv playback.
    I have noticed that mp4 playback can be a bit glitchy in VLC sometimes too. Most notably the recent episode of Dr Who I downloaded from the IPlayer the other day - which again only plays back correctly in Dragon-player!
     
  9. Caloxeno

    Caloxeno Guest

    Hello, there.
    I switched to Apricity, and now the glitch is even worse.

    It is not the recorder's fault: I have tried with at least 5 different recorders, and all of them give me the same result.

    It is not the output format's fault; I have tried with 4 different formats and the problem is the same.

    It is not the video player: I have tried with four different players (Including YOUTUBE itself) and all of them seem to reproduce the same glitch.

    Now, in Linux Mint and Apricity I have the glitch; But seems like in Ubuntu, the glitch does not happen.

    In Windows, I can record perfectly.

    Now I am confussed.

    Anyways, thanks for your help :)

    -Caloxeno
     

Share This Page