Purchase Linux CDs / DVDs / Flash Drives at OSDisc.com

Welcome to Our Community

While Linux.org has been around for a while, we recently changed management and had to purge most of the content (including users). If you signed up before April 23rd please sign up again. Thanks!

Printer (Brother DCP-167C) on Linux

Discussion in 'Linux Hardware' started by itscience, May 27, 2015.

  1. itscience

    itscience Guest

    I am having issues finding drivers for this printer. Ubuntu wants to use another printer for it and Arch is missing it from their database. You CAN get the driver from their website but it doesn't work .deb package and Ubuntu doesn't like it, either. Says it's a bad package.

    I'm only new so I cannot post a link but they give .rpm and .deb downloads

    What are the chances of getting this printer to print from my computer?
  2. arochester

    arochester Guest

    How do you try to install the .deb ? Try with gdebi. If you have not got it: sudo apt-get install gdebi. Then RIGHT click the .deb and choose Open with gdebi.
  3. rstanley

    rstanley Guest

    You should not need yet another package just to install a .deb file. You should have dpkg already installed.
    sudo dpkg -i DEB_PACKAGE
    This should install the package, providing you don't have any missing dependencies. If so, you will need to install those dependencies first, then retry the .deb package
  4. itscience

    itscience Guest

    Thanks for that. I tried it and got this message:
    mkdir: cannot create directory ā€˜/var/spool/lpd/dcp167cā€™: No such file or directory
    Managed to create the directory manually with a bit of faffing but extracted in the end..

    I did it both ways but unfortunately it's not detecting my printer :-/ Only 'generic printer' is showing... Have I missed something?

    Do I need ghostscript, CUPS or something like that?
  5. rstanley

    rstanley Guest

    Now I am confused. I don't know what you did to cause this to occur.

    What .deb file did you download, and what commands did you use to install it?
  6. itscience

    itscience Guest

    I downloaded a .deb file from the offical website (I still can't link it) It lets me either download a deb or rpm file..

    In the terminal I cd to the file location and use the sudo dpkg -i package command.
    It couldn't make the needed directory for some reason due to either file or directory missing so I used mkdir to make it before installing and it worked, kinda. I tried to print something, no printer so I restarted and still no printer so I used gdebi to install and still same result.

    I'm not sure what it's doing, originally when I tried installing it I just double clicked and let the app manager do it for me and it didn't like it but I installed anyway. Maybe the file is no good, anymore?
  7. rstanley

    rstanley Guest

    What is the ACTUAL name of the .deb file? I need this to look at what it is.

    And, what is the ACTUAL command that you used to attempt to install the file?
    does not tell me anything.
  8. itscience

    itscience Guest

    the file is called dcp167clpr-1.1.2-2.i386 and to install I did:
    sudo dpkg -i dcp167clpr-1.1.2-2.i386 like you said
    Sorry about this, I tried another way. I'm guessing it's a bash script but I downloaded it and followed the instructions:
    sudo su
    bash linux-brprinter-installer-2.0.0-1 DCP-167C
    Now my printer works. Just wanna say thanks for being patient with me, and sorry about that.
  9. rstanley

    rstanley Guest

    This file is not a .deb file.

    As long as you have the printer working, that's what's important. In the future it is important to document EXACTLY what you did so we can determine what the problem is/was, and reverse it is needed.
  10. jonnyc

    jonnyc Guest

    Hi itscience!
    I think you might have made my day.
    I'm having the exact same problem with a Brother printer model MFC-L2700DW. I downloaded the driver from their
    site and tried to install it and got stuff like "this is not a deb file,or is corrupt,or you do not have permission" etc.
    ( I suspect the latter). For the avoidance of doubt does the code go like this:

    sudo su (enter)
    bash linux-brprinter-installer-2.0.0-1 MFC-L2700DW (enter)?
    I'm still pretty dumb at the sudo bash stuff.

    Update:- Tried that........."no such file or directory".....Christ!!!!!!
    I suspect I'm failing (because of grammatical errors) to tell it where the file is.
    What I typed was, first as above.............no go.
    Then (after sudo password)

    bash /home/downloads/linux-brprinter-installer-2.0.0-1 MFC-L2700DW (enter).
    Can anyone tell me what I'm doing wrong?

    #10 jonnyc, Oct 25, 2015
    Last edited: Oct 25, 2015
  11. atanere

    atanere Guest

    The description above is not very clear, but linux-brprinter-installer is a script file that you need from Brother (if this method is going to work at all). You can dowload the script from here: http://support.brother.com/g/b/agreement.aspx?dlid=dlf006893_000&c=us_ot&lang=en

    Brother's support website says how to unzip and use this tool at (scroll down to find it): http://support.brother.com/g/s/id/linux/en/faq_prn.html?c=us_ot&lang=en&comple=on&redirect=on

    I hope it works, but there is no guarantee. There may be other ways to make it work, such as getting the latest version of CUPS, but that isn't certain either. By the way, the best printer support in Linux is for HP printers.

  12. jonnyc

    jonnyc Guest

    Hi again.
    I suspect you missed my update! That's where I got the original driver from. Ive downloaded it and extracted the script file. All OK so far. But then..............see my update.

  13. atanere

    atanere Guest

    The script is not the driver. The driver is the .deb or .rpm file, and I'm not sure that you need to download that... if the script works properly.

    The script is a .gz file... that means it is "gzipped". You need to unzip it as described on the Brother website.

    The command you are trying to execute with bash is the script. If you have not downloaded it, you can't be executing it yet. Or maybe you are calling the script the driver... I don't know. You aren't telling us what errors you are getting.

    If you will Google this problem, you will find other forums (Ubuntu, for one) that have discussed setting up Brother printers. I have only glanced through them, so perhaps I am not covering the techniques properly.
  14. jonnyc

    jonnyc Guest

    OK, what I downloaded was "linux-printer-installer-2.0.0-1.gz". I extracted the contents and now have "linux-printer-installer-2.0.0-1" in the same directory ( Downloads).
    When I try to install it via the bash thingy it can't find the file, which tells me that there is some dot,comma,stroke,hyphen in the wrong place, but I don't know which. All this is just an attempt to avoid having to go back and trawl through the manuals again, which I know I'll have to do sometime; but at the moment I'm up to my ass in alligators with other things, so I'm just trying to "dodge the column" a bit! Trouble is, until I get the driver installed I can't set it up as a network printer so the damn thing is sitting on a chair beside the Windows box!
    Life is hard in the Limousin!

  15. atanere

    atanere Guest

    Unfortunately, I don't have a Brother printer, so all I can do is parrot what I can find (or what you could find yourself) using Google. It is extremely important to follow command line stuff exactly or you don't stand a chance of success. From what I can find on the Brother website, the script should install your driver. Be sure your printer is turned on! It might help if it is connected to your computer with a USB cable or if it is already connected to your home router.

    We have some difficulty expressing to each other what is being done, or trying to be done. For instance, you don't "install a bash thingy"... you run or execute a BASH command or script. And "no go" is not the error that Linux uses to report a failure.

    I understand at this point that you have downloaded the script and unzipped it into your Downloads folder.

    Open a terminal and let's try to step through it. What I'm telling you below may look a little different if you aren't using Linux Mint, which is what I'm using, but hopefully you will follow along.

    Your terminal prompt will be something like, [email protected] ~ ?

    Type "sudo su" (without quotation marks) and hit ENTER. You will be prompted to enter your root password, and hit ENTER again when you have typed it in. The ? symbol should change to a # symbol, and change to something like: computername username #

    If you see the # prompt I just described, then type: cd /home/your-username/Downloads and hit ENTER. Your prompt should look like: comptername Downloads #

    On Linux Mint, it will look like as I just described. Downloads must have a capital letter "D". Other versions of Linux may be different. Maybe that is the trouble you had.

    If you 're in the proper Downloads folder, where your script is, then your ready to execute it now as root. So type: bash linux-brprinter-installer-2.0.0-1 MFC-L2700DW (ENTER) -- and if that doesn't work, try: bash ./linux-brprinter-installer-2.0.0-1 MFC-L2700DW (ENTER)

    (TIP: Click and drag your mouse to highlight the command you want to use, hit CNTL-C to copy it, and then in the Terminal window, use the middle-click to paste it. Sometimes a scroll wheel on the mouse works as middle-click if you push down on it.)

    With any luck, it will now run and fetch your driver (yes, be connected to the Internet at this point too). The script is not the driver itself, but I'm expecting it to download it and install it for you. This may all take a little while to complete.

    If it doesn't work, then please describe the errors you get. And please be as EXACT as you possibly can. I have found another page that describes installing the drivers for your printer manually, but I think that will be even harder than using the script.

    #15 atanere, Oct 26, 2015
    Last edited: Oct 26, 2015
    1 person likes this.
  16. jonnyc

    jonnyc Guest

    Thanks for the (very comprehensive) help!
    I had been trying to specify the file location within the command (and failing) instead of going to the directory and then typing the command.
    I followed your instructions and it ran the script, downloaded and installed the driver all without a hitch. I've even printed a test page!!
    Importantly, it has shown me how to navigate in Terminal. In my prrevious attempts I had been missing out the space after "cd". So simple, and yet it screwed up everything. I also think the capital on "Downloads" was also a factor; I guess I'd just got used to typing everything in lower case. But I don't want the printer sitting on the chair for evermore, so I'll now have to learn how to configure it as a network printer so I can print from my other computers. More learning curves!!
    Anyway you have my sincerest thanks for having taken the trouble to help me through this.

    1 person likes this.
  17. atanere

    atanere Guest

    Great! I'm happy to hear that you've got it working successfully now, and I hope that it goes more smoothly getting on to your home network next.

    That darn command line can be a pain, but it's worth learning the basics. Sometimes it is the absolute best tool to do things. But you'll get there too... stay with it!


Share This Page