pop-os doesn't detect my wifi adapter after i updated to latest version.

begad

Member
Joined
Jul 31, 2021
Messages
79
Reaction score
4
Credits
621
hello, I am a new guy to Linux and have been using pop-os for like a week now and when I updated to the newest version I find that it doesn't detect my wifi adapter putting in mind that in the older update it was detecting it and running smoothly I tried updating drivers and reading other forums nothing helped my wifi adapter Broadcom and ya that's it please if you have a way to fix it tell me <3
 


f33dm3bits

Gold Member
Gold Supporter
Joined
Dec 11, 2019
Messages
4,800
Reaction score
3,444
Credits
34,979
Have you tried installing broadcom-sta-dkms? Open a terminal and run the following.
Code:
sudo apt install broadcom-sta-dkms
Then reboot your system en see if your wireless is working, if it isn't open a terminal again and then
share the output of the following.
Code:
ip a
lspci -nn | grep -i net
 
OP
B

begad

Member
Joined
Jul 31, 2021
Messages
79
Reaction score
4
Credits
621
k now when i try to boot the device after i log in i get a black screen note: i didnt do anything yet it just dont even let me in
 

f33dm3bits

Gold Member
Gold Supporter
Joined
Dec 11, 2019
Messages
4,800
Reaction score
3,444
Credits
34,979
Is that after you installed broadcom-sta-dkms or you have done that either as in you have change anything yet?
 

f33dm3bits

Gold Member
Gold Supporter
Joined
Dec 11, 2019
Messages
4,800
Reaction score
3,444
Credits
34,979
Press ctrl+alt+f6, that should switch you to virtual console where you should be able to login. Can you try that?
 

f33dm3bits

Gold Member
Gold Supporter
Joined
Dec 11, 2019
Messages
4,800
Reaction score
3,444
Credits
34,979
Can run the following and share a picture of what you see, use your mobile.
Code:
systemctl list-unit-files | grep gdm
 

f33dm3bits

Gold Member
Gold Supporter
Joined
Dec 11, 2019
Messages
4,800
Reaction score
3,444
Credits
34,979
Try running the following and then tell me what happens?
Code:
sudo systemctl restart gdm
 
OP
B

begad

Member
Joined
Jul 31, 2021
Messages
79
Reaction score
4
Credits
621
k finnaly it worked k i will try the wifi connections command and tell u what happened :)
 

f33dm3bits

Gold Member
Gold Supporter
Joined
Dec 11, 2019
Messages
4,800
Reaction score
3,444
Credits
34,979
I am assuming that means you got the graphical login screen again as before?
 
OP
B

begad

Member
Joined
Jul 31, 2021
Messages
79
Reaction score
4
Credits
621
yes now i am in running command i am getting an error i will send in a sec i am opening the browser on linux
 
OP
B

begad

Member
Joined
Jul 31, 2021
Messages
79
Reaction score
4
Credits
621
when i open the browser on linux it now crashed and doesnt open ????
 
OP
B

begad

Member
Joined
Jul 31, 2021
Messages
79
Reaction score
4
Credits
621
1627723073345.png
that what i am getting when trying to run the first command to fix the wifi
 

f33dm3bits

Gold Member
Gold Supporter
Joined
Dec 11, 2019
Messages
4,800
Reaction score
3,444
Credits
34,979

f33dm3bits

Gold Member
Gold Supporter
Joined
Dec 11, 2019
Messages
4,800
Reaction score
3,444
Credits
34,979
edge browser
I think your browser profile may be corrupted, you can try to rename or delete whatever directory has your browser profile stored and then open the browser again.
 
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Linux.org Hosting Donations
Consider making a donation


Latest posts

Top