pop!-OS display unknown and can't display max resolution


New Member
Jan 29, 2021
Reaction score
I have just installed popOS alongside windows 10 on my machine, and for the life of me, I can't figure out how to get my ASUS ROG PG278Q monitor to display its full 2560x1440 resolution at 144Hz refresh rate. I've tried using xrandr in the following way and I get "out of range":

xrandr --newmode "myMode" 312.25 2560 2752 3024 3488 1440 1443 1448 1493 -hsync +vsync

xrandr --addmode DisplayPort-0 myMode

xrandr --output DisplayPort-0 --mode myMode

I even tried setting the resolution to 1920x1080 and this STILL showed up as "out of range". I have a dual monitor setup (both are 2560x1440) and my alternate monitor works just fine. It displays the correct resolution and is running at the correct refresh rate. I just can't get the PG278Q monitor (my primary one) to work.

I am currently using the open source "amdgpu" driver on my AMD Radeon RX 5600XT. Not sure if this would be the issue or not. Does anybody have any suggestions on how I can get my monitor to display its full resolution?

In windows 10, both monitors work fine and run at their marketed resolutions and refresh rates, so I know it isn't a monitor issue.

Thank you in advance!

The monitor telling you "(input) out of range" means that your graphics adapter's output is out of the range your monitor can handle. Since that is apparently already the case in the grub environment, you should change grub's graphic configuration not xandr to a value that both your graphics adapter and monitor can handle.
Manually edit the grub:
sudo gedit /etc/default/grub
note "gedit" maybe different on your OS use the text editor installed on Pop OS and replace gedit with the text editor you have
find this line:
remove the # and change 640×480 for the preferred mode you want.
save, then type
sudo update-grub
Hope this helps

Members online

Latest posts