Please Help - Printer not working

Heacs

New Member
Credits
0
Hello... Please Help-me!
I am a beginner at linux. I installed linuxmint about 6 months and i am learning how to work.
I installed everything step by step following installation guide.
Everything was working fine, until 3 days ago.
My printer was gone from Printers, i cant print nothing.
I go to the net for help, and when i tried to install hplip but the same error appears:
error: A required dependency 'cups (CUPS - Common Unix Printing System)' is still missing.
error: Installation cannot continue without this dependency.
error: Please manually install this dependency and re-run this installer


Please help. This is my online pc for work.

Thank you
 


captain-sensible

Well-Known Member
Credits
2,278
im not sure what you are saying but..


i don't use Mint but CUPS in simple terms is a print server/print system that can be accessed via url http://localhost:631

Now if you had cups before its a bit of an odd one how you lost it. Unless somehow its there but you disabled it . IN slackware cups is at : /etc/rc.d/rc.cups

what make and model is your printer, is it on wifi connection ? Have you tried usb cable .my experience with Linux, is that you can't go far wrong with a HP printer.

Hopefully some Mint users will help
 

Condobloke

Well-Known Member
Credits
1,450
G'day Heacs, and Welcome to linux.org

Have you rebooted the PC ?

How is the printer connected to the pc ?
 

Alexzee

Well-Known Member
Credits
1,660
Go to the Software Center and type cups in the search.
The Software Center should show if it is installed or not.
IF the Software Center isn't showing if CUPS is installed or not open the terminal and run this:
dpkg -L cups

What does it return?

Until you satisfy that dependency your printer will most likely not work:-

Without knowing what printer and version of Mint your running it's a little hard to advise you what to try.


What is the output of:

cat /etc/os-release
 


Members online


Top