Purchase Linux CDs / DVDs / Flash Drives at OSDisc.com

Welcome to Our Community

While Linux.org has been around for a while, we recently changed management and had to purge most of the content (including users). If you signed up before April 23rd, 2017 please sign up again. Thanks!

  1. Follow us on twitter - we shoot all of our new original content out as well as random messages. https://twitter.com/linuxdotorg
    Dismiss Notice

Physical and Logical Disk Commands show Different Readings

Discussion in 'Getting Started' started by Weng, Mar 13, 2019.

  1. Weng

    Weng New Member

    Joined:
    Mar 13, 2019
    Messages:
    1
    Likes Received:
    0
    I have RHEL 7.3 installed on a VM and it consists of a single disk with 3 partitions. The first partition is a filesystem partition (XFS at /dev/sda1 with 1.1GB). The second is a LVM2 volume (/dev/sda2 with 42GB) and the third is also a LVM2 volume (/dev/sda3 with 161GB).

    When I ran the "pvs --units g", it showed that both that the lvm2 partitions have 0 under the PFree column. The same happened when I ran the "pvscan" command. It showed that these 2 partitions have "0 free"


    (Log in to hide this advertisement)


    However when I ran the df command, it showed that the filesystem which was mounted on the lvm is only 13% in use. The filesystem is "dev/mapper/rhel" and is mounted on /

    I am not sure what does the difference in readings mean? This is a new VM and contains only the OS and docker so there should be plenty of free space available.

    I suspect that the disk space is not enough because when I edited the docker.conf file to store containers in /mnt/data/docker, the docker service failed to start and it complained that there was not enough storage to meet the minimum requirement of 2GB.
     

    Attached Files:

Share This Page