PCSX2 Problems/Inconsistencies (Debian VS Manjaro, 1.4 vs 1.5 & 1.6)

Fanboi

Member
Credits
514
Hi,
New here so I hope this is the right sub. Anyway, I've got this rather complex problem, I'll try to break down.

PCSX2 on Debian
- Versions 1.5 and up are broken on Debian. Specifically, the HW rendering doesn't work (software works). It uses OpenGL. However, if I install the dependencies and then manually install version 1.4, I get few problems other than minor performance issues.
- This makes no sense other than upstream problems...right? Except here's the thing, version 1.6 from the developers actually works as well as 1.4.

PCSX2 on Manjaro
- Using versions 1.6 I had about the same performance as on Debian with 1.4. Now I'm getting better performance with 1.7 (obviously).
- I tried grabbing the source for Arch and building it on Debian and after much annoyance with deps, I found someone else had succeeded. Problem: I think they messed up the sound.

Not the Cause:
- BIOS. I have a clean dump of my own bios PS2 (Slim) so that is cannot be the issue. A mate did the actual dumping, but he checked it against the same version online and it's correct.
- ISOs. I've ripped second-hand PS1 CDs of mine that were heavily scratched and played fine on Mednafen. My PS2 DVDs were mostly brand new, so they were in great condition when I ripped them and archived the originals a few years back (and the files are not corrupted over the years, the hashes still check out).
- Upstream, since their builds work fine.
- Hardware, since it works on Manjaro.
- i386 libs, since Debian is running multi-arch just fine.

Most likely cause: Debian-specific packages.

I sent a bug report to the Debian package maintainers regarding PCSX2 1.5 being broken and having to use the outdated 1.4, but nothing has been done in somewhere closing on 2 years. I also sought help from the PCSX2 team with about as much luck.

TL;DR*: I don't want to move from Debian, even though I can, so is there a solution whereby I can get the kinda performance I get on Manjaro with Debian? Debian should be the lighter-weight and more stable system. I'm out of ideas, myself.

*Long reasoning if interested:
So, here's my problem: I love Debian and have been using it for years (I started experimenting on 6 and changed all my systems to Debian by 7 because I love the stability and simplicity). I know that the stable branch not exactly a desktop OS (if you use testing + sid, you may as well use Ubuntu/Mint/Antix/etc.), but I like it. I like stability, security, simplicity. On the other hand, it seems things relating to gaming, especially emulators, fall short horribly. Now I don't play games a lot, and when I do I, it's mainly emulation and a few indie/free games. So my PC is definitely more a production machine for my creative endeavors and some of my remote work that I can't do on my laptop. And therein lies another problem switching, Debian is the only OS I've felt 100% secure and stable with, but more importantly, in control with (UI isn't an issue, I use XFCE desktop which is default in Manjaro, sxhkd for my keyboard shortcuts, and a dozen scripts to make myself at home almost anywhere). But since this is my work machine, I need the security, stability, simplicity, and in-control-ness factors. That is, many distros, like Manjaro/Ubuntu/etc. tend to automagically configure things. I like being in control because it makes me feel safe. I like feeling I know what everything is up to. It took me a lot of courage just to use the proprietary nVidia drivers (I was willing to pay more for an AMD card to avoid it, but between scalpers and BTC miners, they sold out while still on pre-order and I was lucky to even get this card at this price). So, there's the problem for me.

Thanks in advance.
 


f33dm3bits

Gold Member
Gold Supporter
Credits
16,529
If you mean that you want newer packages which are updated more frequently and still more stable than rolling release you could switch to Debian testing aka Bullseye.
 

Fanboi

Member
Credits
514
I am using backports for now, but only where essential. I try to stay stable.
Switching to testing wouldn't help because the Debian package itself seems to be the problem here: I've tried the backported version and I get the same problems. On Debian, the outdated 1.4 (oldstable or oldoldstable by now) works better on stable (10) than 1.5 or 1.6.
As I said, I don't want to (and won't over one application) switch from Debian or the stable branch (aside from backports when necessary), but even if I did, it wouldn't help because it's the downstream package that seems the problem and I'm having zero luck trying to figure out the cause.
All I really want is the PCSX2 Debian package to work on Debian like the PCSX2 Arch package works on Manjaro. I'm hoping there's something I missed in my messing around and that maybe someone knows the cause/bug. At least I/they/someone could patch it.

PS: I can't cope with a rolling release anyway, especially not on a PC I use for work. Things don't break often, surprisingly, but when they do it can become a nightmarish time-waster fixing them.
 

f33dm3bits

Gold Member
Gold Supporter
Credits
16,529
Yeah I missed that part, it happens after a long week of work. I tried compiling it myself in my Debian vm and ran into some missing packages, I was able to get it down to one thing missing but can't find that dependency anywhere. Wouldn't dual-booting with an Arch based distribution work for you? I've been running Arch for about two years now and this last year working full-time from home with the pandamic going on. I've had a package break something once or twice in two years and didn't take much time to fix, as well as on my remote workstation at work I run Arch and haven't had any problems with things breaking and in worst case scenario I can restore from a backup.
 

Fanboi

Member
Credits
514
I could dual-boot but it wouldn't really do in the long run, especially over one single program. I'll just have to keep looking for the bug or workaround until I find it or until the problem corrects itself.
Maybe I'll get lucky this Christmas and win a lottery or get a bonus and be able to get a secondary PC (my other devices don't have the specs, even my notebook is an old i3 mobile series with 4GB memory and intel's terrible old iGPUs).
But yeah, in the meantime I'll keep trying to figure out what the cause and solution is whenever I'm free and motivated. I've waited this long so it won't kill me to wait a little longer. Hopefully, for anyone else with this problem, I'll find a solution.

One thing of note is that I discovered a thread dedicated to Arch-specific development on the PCSX2 forums, and it seems more active than the generic Linux development, which may account for the excellent support in Manjaro/Arch.

Anyway, thanks for the input all the same.
 

KGIII

Super Moderator
Staff member
Gold Supporter
Credits
16,475
But yeah, in the meantime I'll keep trying to figure out what the cause and solution is whenever I'm free and motivated.
You are a fine example of a Linux user. I don't game and your moon language makes no sense to me (but it sure is pretty), but that's the kinda spirit I like to see.
 

f33dm3bits

Gold Member
Gold Supporter
Credits
16,529
You are a fine example of a Linux user. I don't game and your moon language makes no sense to me (but it sure is pretty), but that's the kinda spirit I like to see.
Agreed on that, you are one of a few who I have seen come across on these forums with an attitude like that, hats off to you! :)
 
Last edited:

Fanboi

Member
Credits
514
Thanks. I didn't realise it was that noteworthy. But on topic, I dug up some more interesting things. Firstly, after actually playing (not merely benching) the AppImage, there's no sound but great performance. I checked the sound output and the application isn't outputting a silent stream, but rather no stream at all. I also found that using a source build of 1.6, the PS2 post screen worked fine on a "virgin" run. However, after realising I hadn't configured my controller and quickly doing so, suddenly the post became jittery. It makes no sense, them being unrelated, but I think it's the sound. I think opening the config dialogue created a config file for each plugin, sound included. So I'm going to see if I can maybe find the problem there. I'll have to double back to Manjaro and check the default settings (presumably for Pulse) and what alsa lib versions are being used. If I can pin that down, it'd help. It'd make sense for stuttering and low performance if there was too much latency and the graphics/etc had to try and sync to the sound. Holding thumbs.
 

wizardfromoz

Super Moderator
Staff member
Gold Supporter
Credits
14,528
G'day @Fanboi and welcome to linux.org :) from DownUnder.

New here so I hope this is the right sub.
Not being a Gamer for most of the last 20 years, I had to read a bit to pick up that this was to do with a PlayStation simulator.

I am wondering whether our Linux Gaming subforum might be a better spot. Some of the people who frequent there may have some ideas.

I can move this Thread there, as can my friend and colleague @KGIII .

Cheers

Chris Turner
wizardfromoz
 

KGIII

Super Moderator
Staff member
Gold Supporter
Credits
16,475
I can move this Thread there, as can my friend and colleague @KGIII .
Being Not-A-Gamer®, their beautiful moon language makes no sense to me! The folks in this thread appear to know a whole lot more about gaming than I do. I don't even play Mine Sweeper. I do play Cribbage on my phone, usually while waiting for the missus or while in the loo.¹

But, yes, if someone wants the thread moved I'll be happy to do so.

1. I bet fewer people read shampoo bottles now that we can take our phones into the bathroom.
 

wizardfromoz

Super Moderator
Staff member
Gold Supporter
Credits
14,528
OK, well I'm passing through anyway, so hang on to your hats, fasten seatbelts and we'll take Wizard's Magic Carpet Ride to Linux Gaming

No smoking in flight, refreshments available.

Wiz

BTW good luck with the simulator, @Fanboi :)
 

Fanboi

Member
Credits
514
G'day @Fanboi and welcome to linux.org :) from DownUnder.

Not being a Gamer for most of the last 20 years, I had to read a bit to pick up that this was to do with a PlayStation simulator.

I am wondering whether our Linux Gaming subforum might be a better spot. Some of the people who frequent there may have some ideas.
Thanks for the welcome and suggestion. To be honest, I didn't know how well this fitted Linux Gaming, since it's hardware emulation that's at the core. When in doubt, I go by the motto: "Post it in something like 'General' and let the mods decide where to move it." ;)

But getting back on topic... So, I've found that the sound problem with the AppImage is entirely stupidity... on both sides! The default plugin is SPU NULL (no sound) for these versions (different from the native installs which defaulted to the current version of the official SPU plugin, thus causing me not to notice as I clicked yes->yes->-yes>... in my testing the AppImage). So, yeah, just select the SPU plugin (not NULL) and you're ready! Problem is basically fixed.
For Debian users, it's best to grab the AppImage rather than install from your repo (and make sure you bother reading the plugin configs page on your first run). Anyway, the performance difference is substantial. Games are now playable!

TL;DR INSTRUCTIONS:
- Grab the (trusted) AppImage from either:
https://github.com/ferion11/PCSX2_Appimage/releases (stable -- 1.6 as of writing)
https://github.com/ferion11/PCSX2_Appimage/releases/tag/continuous (dev -- 1.7 as of writing -- has constant patches and updates)
and make it executable.
- Run it. Yay!
You can soft link to it in /usr/local/bin/ (though I suggest renaming it to something like "pcsx2.appimage" so that updating it is less of a hassle) if you like, just to make life easier.

CAVEATS
- The vanilla version of PCSX2 is better than the nVidia-specific version in my experience. I use an nVidia card and I use the vanilla (not nVidia) version because the nVidia version crashes and I cannot be bothered sifting through logs as to why. If I guessed, it's probably designed for Nouveau and I'm sadly forced into the proprietary nVidia drivers until Nouveau actually catches up.
- If you're using a separate /tmp/ partition, make sure you have enough space since that's where the VFS will mount within and it'll probably write it's data there until closed and then update things in your home directory -- I'm no expert on AppImages.
- If you previously installed PCSX2 or used another AppImage, backup ~/.config/PCSX2/ then delete it (or rename it) and create a new ~/.config/PCSX2 with just your old memcards and bios directories copied across. ~/.config/PCSX2 must be free of other configs or it'll break things!

SPECS:
You'll need better than mine to run in Hardware Rendering, especially at =>1080p. Mine at the time of writing:

- Graphics: nVidia 1650. Obviously this is a cannon to kill a mosquito. Only advice here is prefer AMD cards on Linux, though. For peace of mind, I've tested an old RX 460 with only 2GB VRAM and it works no different than my current card. I've seen YT videos of running on an iGPU (-g series Ryzen CPU at decent settings and speed -- although on Windows, meh). Graphics card doesn't matter at all in "Software Drawing" mode.

- CPU: Ryzen 3600X with an aftermarket cooler (though the cooler shouldn't affect this use case much). The CPU matters a lot for Software Drawing, most strongly the thread count. I get comparable gameplay in Software Drawing mode on 9 drawing threads. I suggest you reserve 3 to 4 threads and use the rest for drawing. Obviously there's a wall where upping the thread count will become meaningless. For now, just go by "use all but 3 to 4 threads" the rule, it's easier. The CPU is the most important thing in emulation and TBH, intel actually wins that round for the most part.

- RAM: 8GB is plenty.

- STORAGE: Standard SATA SSD. The ISO files are stored on an HDD. Storing the ISOs on an SSD gains nothing because of caching.
That's it. SOLVED...

...ish. Now, this ends many people's stories here. Not mine. The performance of the AppImage is still subpar in comparison to "installing" it running a LiveCD Manjaro ISO. I wouldn't quibble, but I want 1080p, full FPS, and no glitches (not high expectations at all /s). I can get crummy gameplay at 1080p on my current Debian install. At native, I get almost pefect gameplay, but I notice the glitches. Also, once we go 2x or 3x (1080p), we get MAJOR sound latency. It's a far cry from the performance I get on Manjaro -- that's Manjaro running on a LiveCD at that, not even installed!

So, bottom line: I'm still determined to get native and get an x86_64 version (ported from Arch) and hopefully maybe get the current PCSX2 package maintainers to take over from there!
But for now we can consider this "Solved" because there's a solution, albeit not perfect. I'll use my necromancy on this thread in the future and resurrect it if/when I have anything to share. Things like a clean Debian 11 install, distro change, hardware upgrade, etc. may get everything working fine for me, which will demotivate me since I think I'm in a minority within a minority of users here. If I drop this (i.e. this thread's a year old with nothing new posted by me) and you're in that unlucky minority within a minority, feel free to harass me via PM and maybe I'll consider picking this quest up again.
 

wizardfromoz

Super Moderator
Staff member
Gold Supporter
Credits
14,528
When in doubt, I go by the motto: "Post it in something like 'General' and let the mods decide where to move it." ;)
Which is fine in principle, but there are only 2 of us, looking after 43,380 Members... and we're volunteers. So spare a thought for us, and look around the forums, won't you?

Wiz
 

Fanboi

Member
Credits
514
Oops, I think I may have worded that wrong. I meant strictly when confused. I didn't go looking for the gaming sub because we're dealing with hardware emulation, playing games being the by-product. So I was confused by technicality. I just meant as a last resort, it's better to find a "general" sub and let the mods decide rather than post off-topic in the wrong sub. Sorry guys. Also, I can't believe there are only two mods. That's quite a workload. If it's any consolation, I do moderate myself as far as language, etiquette, etc. are concerned.
 
$100 Digital Ocean Credit
Get a free VM to test out Linux!


Latest posts

Top