• Rob's side project: I recently started Gun-Forums.com and we currently have a $100 raffle - if you're into guns, join up and enter the raffle to win $100.00. Gun Forums

PCIe error on boot after install

bradystroud

New Member
I am trying to dual boot Widows 10 and Ubuntu 19.x. It boots fine off the live USB, but when I try reboot after installation, It gets stuck and outputs this error:

PCIe Bus Error: severity=Corrected, type=Physical Layer, (Receiver ID)
device [8086:a33d] error status/mask=00000001/00002000
[ 0] RxErr


I have tried reinstalling, reformatting the SSD and messing with GRUB settings.
This is my first time installing and Ubuntu. I have no idea what I'm doing.

Device Specs:

Intel i7 Coffee lake 8th gen
16 GB DDR4
NVIDIA GeForce 3GB 1060
Samsung evo pro 512 SSD - UBUNTU
Kingston HD 200ishGB - Windows 10

I have tried multiple distro's and the same issue occurs.
 


JulienCC

Active Member

bradystroud

New Member
Hello,

I see you also posted here : https://www.linuxquestions.org/questions/linux-newbie-8/pcie-error-on-boot-4175663999/

This message says its related to the PCIe bus. Are you sure everything is plugged correctly ?

This is not possible, it's either EVO or PRO. Is it an NVME SSD ?

Did you assemble the computer yourself ? Did you change any component recently ?
Please provide more detailed information about your hardware.
I posted in lots of places to try and get help. I can’t seem to find any solution to this.
Yeah it’s an EVO SSD sorry.

windows has been working fine on it for years. No hardware has been changed. No, I did not assemble the computer.
 

JulienCC

Active Member
OK I did some search engine magic and found that : https://askubuntu.com/questions/771899/pcie-bus-error-severity-corrected

  1. Start your system and wait for the GRUB menu to show (if you don't see a GRUB menu, press and hold the left Shift key right after starting the system).
  2. Now highlight the kernel you want to use, and press the "e" key. You should be able to see and edit the commands associated with the highlighted kernel.
  3. Go down to the line starting with linux and add the parameter "pci=nomsi" to its end.
  4. Now press Ctrl + x to boot.
If it works we'll see how to make the modification permanent.
 

bradystroud

New Member

wizardfromoz

Super Moderator
Staff member
Gold Supporter
G'day Brady and welcome to linux.org :)

Stay online for a few minutes unless you have to help with tea or have homework to finish.

I was the one who approved your last Post because our software here had a small bellyache with the internet URLs, it's touchy sometimes.

Julien is from France and maybe working but if he comes back soon, follow through with his advice.

I am from South-east Queensland, Australia, in The Granite Belt near Stanthorpe (curly part of the Queensland border), so I'll be back in a few minutes with how to make that stick.

Chris Turner
wizardfromoz
 

bradystroud

New Member
G'day Brady and welcome to linux.org :)

Stay online for a few minutes unless you have to help with tea or have homework to finish.

I was the one who approved your last Post because our software here had a small bellyache with the internet URLs, it's touchy sometimes.

Julien is from France and maybe working but if he comes back soon, follow through with his advice.

I am from South-east Queensland, Australia, in The Granite Belt near Stanthorpe (curly part of the Queensland border), so I'll be back in a few minutes with how to make that stick.

Chris Turner
wizardfromoz
Thanks I’m from near Brisbane!
 

wizardfromoz

Super Moderator
Staff member
Gold Supporter
You'll be at tea probably, so I'll leave this for you.

Go into Terminal (or Ctrl-Alt-t) and type the following and enter your password

Code:
sudo nano -m /etc/default/grub
This will open the Nano text editor in a sub-shell.

Using the -m option means you can navigate faster, by clicking your mouse at a point, the cursor block/i-beam insertion point moves to there. Other than that it is arrow keys up and down, left and right.

There'll be a line a bit like this but yours maybe a little different to mine

Code:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
Change it to include as follows


Code:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash pci=nomsi"
... that's the command Julien gave you.

At the bottom the

^

symbols mean Control.

So ^x to exit agree to the changes and the file name, pressing

Y

for Yes where appropriate, and it will take you back to Terminal.

The file is saved, but we need to do another thing in Terminal to get it to survive a reboot

Code:
sudo update-grub
When that is completed, close Terminal with

Code:
exit
and reboot and see how you go.

If Julien has anything else, or different, follow what he says.

He is a wizard of great repute, perhaps graduated from Hogwarts.

Cheers

Wizard
 

Nik-Ken-Bah

Well-Known Member


Members online


Latest posts

Top