Purchase Linux CDs / DVDs / Flash Drives at OSDisc.com

Welcome to Our Community

While Linux.org has been around for a while, we recently changed management and had to purge most of the content (including users). If you signed up before April 23rd please sign up again. Thanks!

panel launch Icons, 'flash'when clicked

Discussion in 'General Linux' started by Condobloke, May 23, 2017.

  1. Condobloke

    Condobloke Member

    Joined:
    Apr 30, 2017
    Messages:
    39
    Likes Received:
    8
    Linux Mint 18.1 mate desktop.....

    I have the usual array of icons attached to the panel beside the menu button, which I use to launch things like Firefox, Thunderbird, Tiny Pic, Screenshots, Terminal, etc etc

    When any of them are cli9cked....they momentarily 'flash' .....If i could attach a screenshot I would but I find it impossible to capture.



    This will not mean the end of computing as we know it If i fail to stop the flash....it just annoys the beejesus out of me.

    Any ideas where there may be a setting to 'stop the flash'....or maybe another way to approach this 'problem' ?
     
  2. wizardfromoz

    wizardfromoz Member

    Joined:
    Apr 30, 2017
    Messages:
    77
    Likes Received:
    75
    Hi Brian, Hi all

    The difficult we do immediately, the impossible takes a little longer, lol.

    If you are NOT in a hurry, I suggest using a screencast app to show us what is happening.

    If you do not already have a screencasting solution in place, then I can recommend both Kazam and Vokoscreen as solutions, and both of these are in in your Repos, installed via

    • Synaptic Package Manager
    • Terminal, with
      Code:
      sudo apt-get install -y <screencast-solution-name>
    • or Software Manager
    Once that is done, you can use any of the following media solutions for this site:

    Dailymotion, Facebook, LiveLeak, Metacafe, Vimeo, or Youtube

    ... to insert a video taken showing the phenomenon you are experiencing.

    I use Youtube, but the choice is yours.

    Irrespective of whether you choose to take the extra yards, I need to know from you your current State of the Nation, eg:

    Is that MATE on a baseline of 18.1 Cinnamon (Multi-DE'ing), or MATE as a full install?

    Cheers Mate

    Wizard

    Edited typo
     
  3. Condobloke

    Condobloke Member

    Joined:
    Apr 30, 2017
    Messages:
    39
    Likes Received:
    8
    Mate is on a baseline of Cinnamon.....the mate was added via package manager.....

    Your post on THIS PAGE
    ...shows the method used to install "mint meta mate" etc etc

    I will have a peek at the screencast scenario and see what I can achieve
     
  4. Condobloke

    Condobloke Member

    Joined:
    Apr 30, 2017
    Messages:
    39
    Likes Received:
    8
  5. JasKinasis

    JasKinasis Member

    Joined:
    Apr 25, 2017
    Messages:
    51
    Likes Received:
    56
    That doesn't look like a bug to me. That looks like some kind of animation/effect that has been added to the DE/WM.

    I recommend opening up the settings and seeing if there is a section for desktop effects, or it might even be something in the settings for the toolbar itself.

    With any luck, you should be able to find a setting somewhere that will turn that behaviour off. Otherwise, put in a feature request to the developers asking for a way to disable the effect.

    I'm not a Mate or Cinnamon user, so I can't be of any more help. But I'm sure someone else here will be able to find the relevant options - if they exist!! :/
     
    atanere likes this.
  6. wizardfromoz

    wizardfromoz Member

    Joined:
    Apr 30, 2017
    Messages:
    77
    Likes Received:
    75
    I am behind JasKinasis, on the effect itself, however I am not convinced that tweaking a setting will not be part of a saga that will be ongoing.

    The fault may likely be mine, re "fools rush in where angels fear to tread". Mint-meta-mate may not have been the best solution and I have another in mind.

    Question for you Condobloke for after I have slept on it is:

    I know you are a user of Timeshift and Aptik - did you perform a Timeshift snapshot before adding the MATE DE addition? It will be simpler if you did, but if not, there will be a workaround.

    2nd question, if you log in to the Cinnamon side of things, is all behaving normally?

    Tomorrow, folks

    Wizard

    Edited - added 2nd question
     
    Condobloke likes this.
  7. Condobloke

    Condobloke Member

    Joined:
    Apr 30, 2017
    Messages:
    39
    Likes Received:
    8
    I have a snapshot on the 4th May...4 days before adding the mate addition.

    Edited to add...: ....and cinnamon appears to be behaving ok.
    Wiz...I have a memory of cat saying something about the icons on mate jumping out at him....I will have a dig around and see what I can find
     
    #7 Condobloke, May 23, 2017
    Last edited: May 23, 2017
  8. wizardfromoz

    wizardfromoz Member

    Joined:
    Apr 30, 2017
    Messages:
    77
    Likes Received:
    75
    While Brian is checking his references, I have no good news to add.

    The phenomenon appears to be endemic to the MATE DE - I have checked it both with Mint MATEs standard, and "augmented" with another DE, also with Ubuntu 16.10 "Yakkety Yak" MATE.

    Each one produces the same results Brian has described and filmed.

    I have conducted a brief search on Launchpad, for MATE panel launchers icons flashing, but no results.

    So #5 from JasKinasis is as good as, or better than, any solution I have for the moment.

    For all the time I have used MATE, I had not noticed it before. Thanks Brian. :confused:

    Wizard
     
  9. JasKinasis

    JasKinasis Member

    Joined:
    Apr 25, 2017
    Messages:
    51
    Likes Received:
    56
    I just did a search for disabling animations in Mate and found this thread:
    https://ubuntu-mate.community/t/how-to-disable-synapse-animations/6865

    Much of what is discussed in the thread isn't 100% relevant to what we are doing, but there is an interesting screenshot a little way down the page:
    [​IMG]

    It says it's accessible via:
    Control Centre -> Look and Feel -> Mate Tweak

    So if you have mate tweak installed, you should be able to disable the animations, which should hopefully disable the icon animation, thus solving your problem....
    The above screenshot shows the options for the "Windows" section, but it might be worth seeing if there are any animation related options in "Desktop" and "Interface" too.
     
  10. Condobloke

    Condobloke Member

    Joined:
    Apr 30, 2017
    Messages:
    39
    Likes Received:
    8
    @JasKinasis.....thank you for your efforts

    I installed mate tweak...perused the various possibilities there in the windows section and also the desktop and interface areas....and tried all sorts of combinations.....
    I discovered that ticking/unticking the 'enable animations' box was not the answer...however, selecting a different compositor did the trick....metacity from memory ( i am back in cinnamon now and cant remember clearly)...however changing compositor also bought about other changes which led to other hassles....and so on and so on...SO... back to cinnamon desktop.

    (Yes....I did use timeshift ,Wiz, ....reverted the loss of the right side monitor and the left side panel and most of the launch icons on the rhs.....what an ungodly mess !.....and then set about retrying as many possibilities with mate tweak as I could, but the depth of the murkiness just got greater and greater...too many red herrings and side issues to keep track of)

    During the course of the morning i also allowed updates to take place..(in mate)....and that resulted in losing one of my two monitors....the monitor was 'alive'...the cursor arrow showed...but nothing else !!....blackness ! (I have attached a pic of the updates ,,,thisis just for interests sake, I am not considering finding the update responsible......there are just too many things going south with Mate atm....so I will cut my losses and simply go back to Cinnamon) :)

    [​IMG]

    Thanks to both Wizard from Oz and jasKinasis......I appreciate your efforts greatly.

    My apologies for probably typing the above happenings in the wrong order. I need a cuppa....maybe a few cuppas !
     
  11. wizardfromoz

    wizardfromoz Member

    Joined:
    Apr 30, 2017
    Messages:
    77
    Likes Received:
    75
    I've got it, if you are interested.

    Dconf-editor was the answer, uncovered thanks to the link JasKinasis provided :)

    I use dconf-editor sometimes to tweak the size of my mouse cursor (to 48) where other options are not available, but I had not discovered the animations section until now.

    First up, and for The Viewers, Brian was referring earlier to my Post at https://www.linux.org/threads/dual-monitor-drama-lm18-1.4312/ ... where I referred to installing mint-meta-mate from the Package Manager.

    Better than that, I have since learned, is to install mate-desktop-environment , also in the Repos. This bundle includes mint-meta-mate but more.

    Prior to trying this, I would recommend that you either
    • Generate a system snapshot using Timeshift (a Linux product similar to Windows Restore) or
    • otherwise backup your date and settings as your recovery plan dictates
    In that way, you can roll things back should all go awry.

    [​IMG]

    I performed mine from Terminal

    Code:
    sudo apt-get -y install mate-desktop-environment
    so that I could more closely monitor what was going on.

    Once complete, I rebooted, and at the Login screen, where you can see "Ci" for Cinnamon, I clicked and chose "M" for MATE and logged in.

    At the MATE desktop, I started to populate my Panel with my favourite apps, and as Brian describes, there is a moment of the icon expanding in size, in a flash. This is what he wants to get rid of.

    I then installed dconf-editor, which is in the Repos and can be installed from Synaptic Package Manager, or else

    Code:
    sudo apt-get -y install dconf-editor
    On completion, you can click your Menu icon and either search "dconf" or its under Applications-System Tools.

    In dconf-editor, go to :

    org-mate-panel-general

    Screenshot illustrates

    [​IMG]

    There, the box "enable-animations" is checked by default. Uncheck it and exit, the changes should be immediate. The panel icons/launchers will now depress like a button being pressed, but no expansion or flashing.

    There are other options for animations, including but perhaps not limited to:

    • org-mate-desktop-interface-enable animations and
    • another one commencing org-gnome (MATE is a fork from GNOME)
    ... which you may like to experiment with, I haven't yet, but may.

    Cheers

    Wizard
     
    atanere likes this.
  12. atanere

    atanere Moderator
    Gold Supporter

    Joined:
    Apr 6, 2017
    Messages:
    165
    Likes Received:
    123
    Glad @wizardfromoz found the solution! The dconf-editor is quite a handy tool. I had never noticed the flashing icons on MATE before either, but I am also quite averse to flashy-blinky things... which, sadly, usually keeps me away from KDE, even though the animations are disabled easily enough. Of course many others choose KDE because they love the effects! Choices and options are great to have.

    Cheers
     
    wizardfromoz likes this.
  13. wizardfromoz

    wizardfromoz Member

    Joined:
    Apr 30, 2017
    Messages:
    77
    Likes Received:
    75
    @atanere - my comments between yours:

    Wizard
     
    atanere likes this.
  14. Condobloke

    Condobloke Member

    Joined:
    Apr 30, 2017
    Messages:
    39
    Likes Received:
    8
    frozen brain...posted in wrong topic...oh well......its called old timers disease....

    I meant to post HERE
    with a summary of what I ended up doing re dual monitors

    Thanks Wiz for pointing that out....you are quite correct re the weather....minus numbers here this morning....tad chilly around 4.30AM

    ps....my coffee has a 'touch' of something extra in it today....to ward off the cold...you know?....
     
    #14 Condobloke, Jun 1, 2017
    Last edited: Jun 1, 2017
    wizardfromoz likes this.

Share This Page