Purchase Linux CDs / DVDs / Flash Drives at OSDisc.com

Welcome to Our Community

While Linux.org has been around for a while, we recently changed management and had to purge most of the content (including users). If you signed up before April 23rd, 2017 please sign up again. Thanks!

  1. Follow us on twitter - we shoot all of our new original content out as well as random messages. https://twitter.com/linuxdotorg
    Dismiss Notice

Package corrupted during installation

Discussion in 'Arch and derivatives' started by CptCharis, Jan 12, 2019.

  1. CptCharis

    CptCharis Well-Known Member

    Joined:
    Feb 27, 2018
    Messages:
    311
    Likes Received:
    299
    Hello everybody!

    I'm trying a fresh installation of Arch in my virtual box but after
    Code:
    packstrap -i /mnt base
    I have a return of some corrupted or damage packages.

    VirtualBox_Arch_12_01_2019_10_44_06.png

    Do you have any idea what is going wrong?


    (Log in to hide this advertisement)

     
  2. wizardfromoz

    wizardfromoz Super Moderator
    Staff Member Gold Supporter

    Joined:
    Apr 30, 2017
    Messages:
    2,545
    Likes Received:
    2,125
    Good evening Sir :)

    Yes, I think I do, but I just have to track down, where I saw Levente Polyak's reference, I think it may have been when I ventured into my very basic Arch VM install under SwagArch last couple of days.

    It was a "trust" issue and I had to add something to the keyring config. Got it sorted with mine.

    I have to leave for my evening meal I have to cook - spaghetti bolognese, sorry no Greek tonight :D

    I'll be back on deck tomorrow

    Cheers

    Chris
     
    CptCharis likes this.
  3. wizardfromoz

    wizardfromoz Super Moderator
    Staff Member Gold Supporter

    Joined:
    Apr 30, 2017
    Messages:
    2,545
    Likes Received:
    2,125
    Try this, Mate

    Code:
    sudo pacman -Sy archlinux-keyring && pacman -Syyu
    Let us know result.

    Wiz
     
    CptCharis likes this.
  4. poorguy

    poorguy Well-Known Member

    Joined:
    Jul 29, 2018
    Messages:
    230
    Likes Received:
    300
    CptCharis likes this.
  5. CptCharis

    CptCharis Well-Known Member

    Joined:
    Feb 27, 2018
    Messages:
    311
    Likes Received:
    299

    You did your magic again @wizardfromoz ;). Thanks a lot!!!
    It's working normaly. Can you sent me the link, bcz is very interesting, a few weeks ago I did the same installation without this kind of issues.
     
    wizardfromoz likes this.
  6. CptCharis

    CptCharis Well-Known Member

    Joined:
    Feb 27, 2018
    Messages:
    311
    Likes Received:
    299
  7. wizardfromoz

    wizardfromoz Super Moderator
    Staff Member Gold Supporter

    Joined:
    Apr 30, 2017
    Messages:
    2,545
    Likes Received:
    2,125
    Haven't found the exact sequence I used when I encountered this problem - I have about 10 Arch-based, plus the Arch VM, over 2 computers and I was working on all of them when I encountered the "Levente Polyak" issue.

    Here's what I referenced to help you, if I track down anything better I'll post.

    https://bbs.archlinux.org/viewtopic.php?id=231446

    and

    https://bbs.archlinux.org/viewtopic.php?id=221435

    Those were from a Google under

    linux Levente Polyak

    Cheers

    Chris

    BTW also found this https://forum.antergos.com/topic/5800/problem-with-update-jasper-lib-curl/7
     
    Hansel Johnson Jr likes this.
  8. CptCharis

    CptCharis Well-Known Member

    Joined:
    Feb 27, 2018
    Messages:
    311
    Likes Received:
    299
    Thanks mate ;)
     
    wizardfromoz likes this.

Share This Page