Out of the frying pan into the Fire with LAN cards.

Nik-Ken-Bah

Active Member
To help rule out a settings problem with Mint, can you boot on a Linux Mint USB? I think you said you keep one handy. After booting on the USB, don't adjust any network settings... just run Firefox and see if you can browse the internet. If this fails, I'm going to guess that your modem/router is NOT using DHCP, but let's see what happens.
Already have done that using not only mint but other distros as well with the same result.

Yes, but we're learning in the process. When it's solved, we may know better how to reach the solution quicker next time
That I am very well aware of, :) but it's just appears to be my lot in life where when I obtain an article that others seem to have no problems with the article and it works a treat. An identical article gives me a problem to solve so that it operates as it should. That is why I am patient even though at times it annoys me no end. :)
 


atanere

Well-Known Member
Already have done that using not only mint but other distros as well with the same result.
Okay then. I am restoring Win 7 to a desktop I have to compare settings there. I'll also put Mint Cinnamon on it as a dual boot with Windows, and we can compare that too. I have Win 7 Home Premium.... is that the same as you? Or do you have a different edition?

Also, tell us what "the box" is from your ISP... brand and model number if you can spot them.
 

dos2unix

Active Member
Did you post the output of...

sudo cat /etc/network/interfaces

yet?

I suspect @atanere is right, and you are already set up for DHCP, but it can't hurt to check.

Assuming this is the case, do you know how to go to your network interface properties
control panel in windows? Do you know how to take a screenshot on windows?
This is what I'm looking for...

4567


Windows 7 might look slightly different, obviously it won't say Intel I219-LM at the top.

4569


I suspect if DHCP is not enabled, you have a static IP address.
We can we can try putting the same network setting on your Linux.
 

Nik-Ken-Bah

Active Member
Assuming this is the case, do you know how to go to your network interface properties
control panel in windows?
This is what I come up with
4575
 

Nik-Ken-Bah

Active Member
This also for broadband


4577
 

Nik-Ken-Bah

Active Member
this also and as you see it connects to a WAN miniport (PPPOE)


4578
 

Nik-Ken-Bah

Active Member
Assuming this is the case, do you know how to go to your network interface properties
control panel in windows?
The above is all I seem to be able to locate in Win 7. I am not sure what version of Win you took those shots from?
this is the result of search


4579
 

dos2unix

Active Member
In post #65 above,
Can you double click on "Internet Protocol Version 4 (TCP/IPv4)"
and show that out put.
 

Nik-Ken-Bah

Active Member

Nik-Ken-Bah

Active Member
For the LAN connection

4581
 

Nik-Ken-Bah

Active Member

Nik-Ken-Bah

Active Member
I know that I can enter the both the IPv 4 & 6 data in the network connections if needed.
 

dos2unix

Active Member
..ah ha... now we are getting somewhere. :)

Since you don't have a default gateway on your LAN connection, we know
this isn't going out to the internet directly. It looks like you are using NAT
through your VPN.

Your broadband miniPort is using a hard-coded IP address with CHAP authentication.

It appears Mint doesn't have the drivers for your Broadband miniPort loaded.
Once that is done, we still have two other problems.

We will have to set up a static IP/netmask and gateway (that part is easy)

Then we will have to set-up CHAP authentication. That part is more difficult,
and I'm not sure how to explain it without exposing passwords yet.
 

Nik-Ken-Bah

Active Member

atanere

Well-Known Member
..ah ha... now we are getting somewhere.
I wish I could have "liked" that with TWO BEERS! Or even THREE or FOUR BEERS! :D:D:D

Since I really know nothing at all about VPN and NAT, it's time for me to really butt out this time and just enjoy the show. It looks like @dos2unix is headed toward success. :cool::D

I might ask @Nik-Ken-Bah though, "Is all this worth it?" With your next new computer, you will be down this road again by not using standard networking with DHCP. I realize that maybe your ISP is forcing this situation on you, and if so then there is no choice for you. And maybe the VPN is that important to you for privacy to be worth all this hassle. But if "the box" that your ISP provided is a standard modem/router, and if they support DHCP, you could be networking as easily as the rest of us, and your UEFI motherboard would be able to download your updates properly. Just something to think about, if you have the option and desire to change this.

Cheers
 

dos2unix

Active Member
I believe NAP is Network Access Protection. I think it might be a Microsoft thing.
NAT is network address translation.

Most ISP's give you a 10.x.x.x or a 192.168.x.x IP address in your house (or business)
These are reserved networks that can't be routed out to the internet.
So your ISP "translates" your internal IP address to something external.
You can see what this is by going to http://whatismyipaddresss.com

Microsoft does similar to DHCP called automatic private IP addressing.
They always use the 169.254.x.x network that you have listed in your config.

But it seems your external IP is a 188.239.x.x address.
 

dos2unix

Active Member
Any idea what kind of router you have? (The box) the cable goes to.
Maybe Cisco, Netgear, Linksys, D-Link, etc... ? Is there a model number?

I think someone above mentioned it might be on a tag on the bottom of your router.
Be careful posting pictures, sometimes the tag has passwords and sensitive data on them.
 

Nik-Ken-Bah

Active Member
With your next new computer,
I do not foresee a new computer for at least ten years or more unless one of two conditions become apparent 1/ I cannot get an AMD processor with a FM2 pin layout
2/ The MB decides to shit itself completely.
As I am getting to long in the tooth so this will do.
 

Nik-Ken-Bah

Active Member
The box) the cable goes to.
Is very much like the telephone cable boxes except it has a lot of LAN cable jacks instead of posts for connecting telephone twin pair wires to. And from memory I did not notice any writing on the box when they installed my cable. I watched them do it. Also another place they put in cable in a 9 story building and there were was a box on each floor and no writing on them.
 
Last edited:

Nik-Ken-Bah

Active Member
But it seems your external IP is a 188.239.x.x address.
That it be as I just got info about my IP and it says it is likely a static IP. And I think that maybe the case as the info states my possible locale and it confirms my knowledge of it! .
 
Last edited:

Members online


Top