Out of the frying pan into the Fire with LAN cards.

Nik-Ken-Bah

Active Member
I've had problems with sound cards on Linux and Windows.
I've had graphic card problems on Linux and Windows.
I have been lucky I suppose in that all the plastic brains that I have used up to date I have never had problems with audio or video cards.
When I first installed Linux my sound card was mute and read a few comments to the effect that my Xonar card wouldn't work, so I thought to myself that is OK no probs work it out later. After turning on the computer and launching Mint over a couple of days then one day I heard a squark from my speakers and turned the volume up a bit and opened the music console and grab a song and started playing it and there was silence no more. Though I do miss the control panel for my sound card as I can readily move from the front panel jack to the rear panel jack and also the graphic equaliser and stereo control.
So far no problems with the video card {crossing fingers}
The first driver I loaded was the r8168-8.032.00 to replace the r8169. The driver I loaded from the NIC was r8168-8.046.00 and that didn't load at all. The driver I downloaded to-day directly from Realtek's own website was r8168-8.047.04 and it was released in August of this year it also loaded correctly and is installed now.
But it still does not drive the adaptor.
So now I am thinking "why is this so?" and dredging up from the memory what I have learnt about electronic hardware over the years.
 


Nik-Ken-Bah

Active Member
The Saga continues this is what I dredged up using dmesg

Screenshot from 2019-10-28 21-23-15.png

This tells me that the adaptor is up and running, right? Or is it?
 

dos2unix

Active Member
This means your drivers are loaded. Not necessarily that you are on the network.
It seems you have a connection at least. But do you have an IP address?

You can try these commands....

sudo ip addr

sudo ifconfig enp4s0

sudo nmcli conn show

sudo netstat -nr

sudo ethtool enp4s0
 

Nik-Ken-Bah

Active Member
This means your drivers are loaded. Not necessarily that you are on the network.
It seems you have a connection at least. But do you have an IP address?

You can try these commands....

sudo ip addr

sudo ifconfig enp4s0

sudo nmcli conn show

sudo netstat -nr

sudo ethtool enp4s0
Thanks @dos2unix Will do and will take screen shots and post them.
One drop at a time wears away the mighty stone. :)
 

Nik-Ken-Bah

Active Member
As stated above @dos2unix here is the screen shots
4563
IFconfig  2019-10-30 20-53-55.JPEG
4564
4565
4566
IFconfig  2019-10-30 20-53-55.JPEGIp address  2019-10-30 20-52-11.JPEGNetStat --NR  2019-10-30 20-57-13.JPEGNMCLI conn show 2019-10-30 20-55-17.JPEG

In the netstat screen shot does MSS Windows mean Microsoft?
 

atanere

Well-Known Member
In the netstat screen shot does MSS Windows mean Microsoft?
If you look again, you'll see it is "Window"... not "Windows." Also, MSS and Window are two separate things, although they look like one item with only a single space between them. When I run the command, I get a value of 0 for both of them. This article (down around the middle of the page) explains these as:
  • The “MSS” column lists the value of the Maximum Segment Size for this line. The MSS is a TCP parameter and is used to split packets when the destination has indicated that it somehow can’t handle larger ones. Nowadays, most computers have no problems with the most commonly used maximum packet sizes, so this column usually has the value of 0, meaning “no changes”.
  • The “Window” column is like the MSS column in that it gives the option of altering a TCP parameter. In this case that parameter is the default window size, which indicates how many TCP packets can be sent before at least one of them has to be ACKnowledged. If you don’t know what this means, don’t worry. Like the MSS, this field is usually 0, meaning “no changes”.
@dos2unix is obviously expert on this topic, so I'll leave it to him to guide you further. Just one quick question though... have you tried using a different (and known good) Ethernet cable between the Goldie computer and your router?

Cheers
 

dos2unix

Active Member
It appears you do NOT have an IP address or gateway.

Let me ask the obvious questions first.

Do you have a cable/modem router?

Is there are an Ethernet cable plugged in between the router and the computer?

If both of these look good, we will need to check if your interface is set to DHCP.
 

Nik-Ken-Bah

Active Member
Thanks @atanere for the info appreciated.:)
@dos2unix At the moment directly connect my ISP's cable directly in to the computer. The only other piece of network kit I have is a switch which is not connected to the computer.
 

dos2unix

Active Member
So the ethernet cable, is going from your cable modem, to your PC?

I haven't used Mint in quite a while. Perhaps someone else could walk you through how
to configure the network in the GUI. Basically we just need to make sure that your
network interface is set to use DHCP.

I would think 99% of the people using Mint on this site probably have theirs set up this way.
I would expect it to be the default configuration, but I'm not sure on Mint.
 

Nik-Ken-Bah

Active Member
So the ethernet cable, is going from your cable modem, to your PC?
What modem?
The ISP's cables run to a box situated about 40 metres away from me then a cable runs from that box straight to my computer's NIC I/P (Lan Plug )

Where you set up your login name and password to access your ISP server is in the MD5 tab. Right?

I understand from looking at my login name that my ISP provider gave me when they set-up my computer that I am on a VPN connection as it starts out as VPN then the address where we lived at the time.

My UEFI is set for DHCP.

Is there any command I can use to verify that Mint is set to DHCP?
 

Nik-Ken-Bah

Active Member

atanere

Well-Known Member
What modem?
The ISP's cables run to a box situated about 40 metres away from me then a cable runs from that box straight to my computer's NIC I/P (Lan Plug )
That box should be the cable modem. It may be a combination modem/router. If it has any brand name and model number shown anywhere on it, please list it here. Maybe we can Google more info about it. Sometimes they have admin information on a sticker, including possibly a password... don't show us that.

40 meters is a fairly long run but should be fine (limit is usually stated to be 100m)... but let me ask again, have you ever tried a different cable instead of that one? Or, to ask differently, have you used that same cable from the cable modem to a different computer, and that it works? A bad cable is just one thing that can cause your problem (not getting an IP address). And it is quite a simple thing... but they can break easily if pinched, and you won't necessarily see the damage.

[EDIT: If your cable has never worked, one possibility is that it may be the wrong kind. Most Ethernet connections use a "straight through" cable, but there is another kind called a "crossover" cable that is wired differently but still uses the same plugs. You can't tell them apart except with a tester or by carefully looking at the wire colors inside the plugs, if they are clear plastic.]
 
Last edited:

wizardfromoz

Super Moderator
Staff member
Gold Supporter
Sleep well, Ken - it's another Linux day tomorrow :D
 

atanere

Well-Known Member
Where you set up your login name and password to access your ISP server is in the MD5 tab. Right?

I understand from looking at my login name that my ISP provider gave me when they set-up my computer that I am on a VPN connection as it starts out as VPN then the address where we lived at the time.

My UEFI is set for DHCP.

Is there any command I can use to verify that Mint is set to DHCP?
If needed, we may have to take each of these separately to be sure we're all talking about the same things... because I'm confused about "MD5 tab" and the "VPN" connection. Maybe we won't need to though.

The UEFI needs DHCP so that it can get BIOS/UEFI firmware updates for you. I do get that part. But it's never worked, because it is not getting an IP address either. The process of DHCP is that your computer (or UEFI) gets the IP address from your modem/router, and you are not getting this address.

I've used Mint a lot over the years, and I can turn to it now easily. But I can say with confidence that no settings need adjustment to get on the internet with an Ethernet connection. It is very plug and play. At most, you might need to reboot with the cable connected, but I even doubt that. I do not think this is a Mint problem at all, unless by chance some settings have been changed, perhaps by the ISP? We can compare and verify Network settings, if that will help.
 

Nik-Ken-Bah

Active Member
@atanere
The MD5 tab is also part of security will post a couple of screen shots so we are on the same wavelength with it.

The process of DHCP is that your computer (or UEFI) gets the IP address from your modem/router, and you are not getting this address.
I am not quite understanding this as Win 7 uses the same cable and still connects! So what is missing from this equation? :confused:

40 meters is a fairly long run but should be fine (limit is usually stated to be 100m)... but let me ask again, have you ever tried a different cable instead of that one?
It is a bit hard to try another cable as it is the cable that runs from the ISP's box and was installed by the ISP.
And it is a bit hard for me to talk to my ISP provider LINK.Net.UA due to language difficulties and my missus doesn't understand very much about computers. But I do remember when we changed addresses I had difficulty in connecting then and that was about five odd years ago. Then my computer was a laptop and pure Win 7 and when I fired Goldie up for the first time also there were no problems connecting through Win 7.
And I have been thinking along these lines that it may be something to do with Link. :(
What I am also thinking that the installation that I have installed may have some corruption due to having to do it all purely through windows and I was using Balena Etcher to create the USB stick.
But once I installed Mint I formatted the stick and reloaded Mint onto it using Mint to do it as I keep my ISO files on my external HD.
 

atanere

Well-Known Member
I am not quite understanding this as Win 7 uses the same cable and still connects! So what is missing from this equation?
Okay, great! Then that confirms the 40m long Ethernet cable is okay. I just wanted to rule that out for sure because I've seen many failures because of cables. But I am still confused why back in Post #31 you said that you had 1Gbps working with both Win 7 and Mint. Now Win 7 works, and Mint does not... on the same cable. And Win 7 and Mint are dual-booting on the same computer too... correct?

I see MD5 in a security tab on Mint Cinnamon that I just installed, but we can go over individual screen settings a bit later. I installed Mint last night with no network (wired or wireless).... I plugged in an Ethernet cable and I was online instantly. That's how it's supposed to work.

Let's wait and hear from @dos2unix and get his suggestions next.
 
Last edited:

Nik-Ken-Bah

Active Member
. Now Win 7 works, and Mint does not... on the same cable. And Win 7 and Mint are dual-booting on the same computer too... correct?
I have win 7 sitting on a Toshiba HD that is slowly dying. Mint sits on a new HGST HD. So yes they both share the same processor but not at once.
When I switch on power and do nothing the UEFI just boots straight in to Mint. I have to hit F11 when the ASRock window opens up to access the boot menu and click on the Toshiba HD and window loads

When I hit the connect switch on the network panel it shows connecting at 1 Gbps and the network panel of Win task Manager says connected at 1 Gbps for the broadband connection and the local area connection.
I just looked at the network panel of Win resources monitor and it showed this svchost.exe(network)..ns2.link-kremen.net and that is my ISP's server

I plugged in an Ethernet cable and I was online instantly. That's how it's supposed to work.
Yes! I am aware of that but it just my portion in life to get one that is cantankerous and wants to do its own thing. o_O
 

atanere

Well-Known Member
I have win 7 sitting on a Toshiba HD that is slowly dying. Mint sits on a new HGST HD. So yes they both share the same processor but not at once.
Same computer... great! Common cable works and common network card works (with Win 7). The difference between hard drives doesn't matter, but it can sure be settings between Windows and Mint. Yet, it is still very unusual for any Linux to have any trouble with Ethernet.

To help rule out a settings problem with Mint, can you boot on a Linux Mint USB? I think you said you keep one handy. After booting on the USB, don't adjust any network settings... just run Firefox and see if you can browse the internet. If this fails, I'm going to guess that your modem/router is NOT using DHCP, but let's see what happens.


Yes! I am aware of that but it just my portion in life to get one that is cantankerous and wants to do its own thing.
Yes, but we're learning in the process. When it's solved, we may know better how to reach the solution quicker next time. :D
 

Members online


Latest posts

Top