Nvidia driver

NickolayKo

New Member
Joined
Dec 10, 2020
Messages
8
Reaction score
1
Credits
62
Good day everyone.
Been using Linux without any problems, once I launched my laptop to external screen using HDMI, Laptop turned off due to low battery, while being connected to external screen, after unplugging from HDMI black screen appeared, I was looking for tutorials on net (while being a total noob) tried reinstalling the driver through terminal, in the end OS started working with delays and high CPU load. Tried installing it by driver manager but an error occured:

pk-client-error-quark: Error while installing package: trying to overwrite shared '/usr/share/doc/libnvidia-gl-390/changelog/Debian.gz' which is different from other instances of package libnvidia-gl-390 (313)

Can i fix this issue somehow and run Mint using this driver again without reinstalling the whole OS?



p.s. sorry for my explanations and me being stupid - my Linux skills are very basic :)
 

Attachments

  • 3.png
    3.png
    13.9 KB · Views: 446


Lord Boltar

Well-Known Member
Joined
Nov 24, 2020
Messages
1,687
Reaction score
1,131
Credits
12,591
Need to switch back to the Nouveau driver first should be under Software & Updates click on Additional Drivers and change it there.
Then remove the Nvidia Drivers -
Code:
sudo apt-get purge nvidia-*
Then open your driver manager and install nvidia again
 
OP
N

NickolayKo

New Member
Joined
Dec 10, 2020
Messages
8
Reaction score
1
Credits
62
Need to switch back to the Nouveau driver first should be under Software & Updates click on Additional Drivers and change it there.
Then remove the Nvidia Drivers -
Code:
sudo apt-get purge nvidia-*
Then open your driver manager and install nvidia again
Thank you for a reply buddy.
Turns out I was following the same commands even before your suggestion, so started over with super user(root) and followed your instructions. My drivers manag is showing the same error as in the pinned screenshot above
 

Lord Boltar

Well-Known Member
Joined
Nov 24, 2020
Messages
1,687
Reaction score
1,131
Credits
12,591
Thank you for a reply buddy.
Turns out I was following the same commands even before your suggestion, so started over with super user(root) and followed your instructions. My drivers manag is showing the same error as in the pinned screenshot above
When you bring up the driver manager is it only showing the 390 drivers or any later ones?
Also might want to try
Code:
sudo apt autoremove

To add the Proprietary GPU Drivers PPA in Ubuntu or Linux Mint and update the software sources, use the following commands:

Code:
sudo add-apt-repository ppa:graphics-drivers/ppa

Code:
sudo apt update

Close terminal then open All - then Driver Manager and install latest nVidia drivers

The other option is to go here /usr/share/doc/libnvidia-gl-390/changelog/Debian.gz - and delete that file probably have to be in root to do it since it is trying to overwrite it
 
Last edited:
OP
N

NickolayKo

New Member
Joined
Dec 10, 2020
Messages
8
Reaction score
1
Credits
62
When you bring up the driver manager is it only showing the 390 drivers or any later ones?
Also might want to try
Code:
sudo apt autoremove

To add the Proprietary GPU Drivers PPA in Ubuntu or Linux Mint and update the software sources, use the following commands:

Code:
sudo add-apt-repository ppa:graphics-drivers/ppa

Code:
sudo apt update

Close terminal then open All - then Driver Manager and install latest nVidia drivers

The other option is to go here /usr/share/doc/libnvidia-gl-390/changelog/Debian.gz - and delete that file probably have to be in root to do it since it is trying to overwrite it
Installed by your instructions, after reboot I need to change them anyway. I have no idea what this thing wants. Maybe I should try installing it from external source?
 

Attachments

  • Screenshot from 2020-12-11 14-03-35.png
    Screenshot from 2020-12-11 14-03-35.png
    22.3 KB · Views: 454
  • Screenshot from 2020-12-11 14-01-51.png
    Screenshot from 2020-12-11 14-01-51.png
    69.2 KB · Views: 392

Lord Boltar

Well-Known Member
Joined
Nov 24, 2020
Messages
1,687
Reaction score
1,131
Credits
12,591
That tells me that Nvidia has stopped updating drivers for your card

Then, run the following commands to check the list of driver devices available for the Nvidia card from the default Ubuntu repository.

Code:
sudo ubuntu-drivers devices

That should list all available drivers for your 810M Card

Now you can run the following commands to install the specific driver you want.

Code:
sudo ubuntu-drivers autoinstall

If there is later numbers then 390 then use that number instead of 390

Code:
sudo apt install nvidia-driver-390
 
OP
N

NickolayKo

New Member
Joined
Dec 10, 2020
Messages
8
Reaction score
1
Credits
62
That tells me that Nvidia has stopped updating drivers for your card

Then, run the following commands to check the list of driver devices available for the Nvidia card from the default Ubuntu repository.

Code:
sudo ubuntu-drivers devices

That should list all available drivers for your 810M Card

Now you can run the following commands to install the specific driver you want.

Code:
sudo ubuntu-drivers autoinstall

If there is later numbers then 390 then use that number instead of 390

Code:
sudo apt install nvidia-driver-390
Installed 418 version, deleted the previous one, the same message is showing up, now when i go to drivers manag it's saying the system needs no additional drivers. It's still getting delays.
 

Attachments

  • man.png
    man.png
    5.9 KB · Views: 367
  • term.png
    term.png
    17.1 KB · Views: 378

Lord Boltar

Well-Known Member
Joined
Nov 24, 2020
Messages
1,687
Reaction score
1,131
Credits
12,591
Installed 418 version, deleted the previous one, the same message is showing up, now when i go to drivers manag it's saying the system needs no additional drivers. It's still getting delays.
Then if you are not getting anymore errors and you have the latest version that came out for your card, you should be good. Video cards only update for so long then no more updates.
 
OP
N

NickolayKo

New Member
Joined
Dec 10, 2020
Messages
8
Reaction score
1
Credits
62
Then if you are not getting anymore errors and you have the latest version that came out for your card, you should be good. Video cards only update for so long then no more updates.
Do you mean there is no solution? Why OS is telling me I need to install new driver, at the same time, drivers manager says I don't need one. Maybe a new driver is not activated, can I make this thing work, as it worked before?
 
OP
N

NickolayKo

New Member
Joined
Dec 10, 2020
Messages
8
Reaction score
1
Credits
62
I do not see where the OS is telling you to install new driver
Code:
 inxi- Fx
and post back what it says
also post back what this says
Code:
sudo ubuntu-drivers devices
sorry, I didn't make it clear, my fault :c
 

Attachments

  • 1.png
    1.png
    32.1 KB · Views: 397
  • 2.png
    2.png
    20.6 KB · Views: 393
OP
N

NickolayKo

New Member
Joined
Dec 10, 2020
Messages
8
Reaction score
1
Credits
62
I see from your photo you used inxi -fx should be inxi -Fx

also you should be using the 390 driver (recommend) the 418 drivers are for server
now installed 390 driver, again the same problem
 

Attachments

  • 5.png
    5.png
    22.2 KB · Views: 391
  • 3.png
    3.png
    100.7 KB · Views: 358
OP
N

NickolayKo

New Member
Joined
Dec 10, 2020
Messages
8
Reaction score
1
Credits
62
Looks like the CPU is not seeing the driver on your Graphics it says driver: N/A

what does
Code:
nvidia-settings
give you
Everything is working fine after deleting nomodeset line on the OS selecting menu, thought maybe this line is making an issue. Don't know what the heck I was doing, that's why I typed it there after watching some youtube tutorials.
Thank you so much for your help. Can I support your work somehow?
 

Lord Boltar

Well-Known Member
Joined
Nov 24, 2020
Messages
1,687
Reaction score
1,131
Credits
12,591
Everything is working fine after deleting nomodeset line on the OS selecting menu, thought maybe this line is making an issue. Don't know what the heck I was doing, that's why I typed it there after watching some youtube tutorials.
Thank you so much for your help. Can I support your work somehow?
Glad it is fixed - you can mark this as (Solved)
 
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Members online

No members online now.

Top