No swap Partition?



Condobloke

Well-Known Member
Credits
7,730
How much RAM (memory) do you have ?
 

Condobloke

Well-Known Member
Credits
7,730
Are you sure you only have 2gb RAM ?.......are you equally sure you are running Linux Mint 20.1 ??

click on menu, type in system info.

It will be shown as memory (not ram)
 

Condobloke

Well-Known Member
Credits
7,730
To identify postively if you already have a swap partition, open Terminal (ctrl alt T)

and copy and paste this command in

Code:
sudo swapon --show
Enter your root password. If you see no output, it means that the SWAP doesn’t exist.

Follow the instructions HERE
 

Nelson Muntz

Well-Known Member
Credits
3,480
Are you sure you only have 2gb RAM ?

Open terminal and copy and paste this command.
Code:
sudo dmidecode -t memory | grep -i size
Press enter and then enter your password and press enter.

Output should look like this.
Code:
[email protected]:~$ sudo dmidecode -t memory | grep -i size
[sudo] password for nelson:
    Maximum Memory Module Size: 4096 MB
    Maximum Total Memory Size: 16384 MB
    Installed Size: 1024 MB (Double-bank Connection)
    Enabled Size: 1024 MB (Double-bank Connection)
    Installed Size: 1024 MB (Double-bank Connection)
    Enabled Size: 1024 MB (Double-bank Connection)
    Installed Size: 2048 MB (Double-bank Connection)
    Enabled Size: 2048 MB (Double-bank Connection)
    Installed Size: 2048 MB (Double-bank Connection)
    Enabled Size: 2048 MB (Double-bank Connection)
    Size: 1024 MB
    Size: 1024 MB
    Size: 2048 MB
    Size: 2048 MB
[email protected]:~$
 

KGIII

Well-Known Member
Credits
7,691
By pure happenstance, today's L-T article is about adding a swapfile - which I'm pretty sure will work in Mint.


Considering that I wrote the article a couple of days ago (and scheduled it for publication today), it's a remarkable coincidence.
 

RedAreApples

New Member
Credits
113
Are you sure you only have 2gb RAM ?.......are you equally sure you are running Linux Mint 20.1 ??

click on menu, type in system info.

It will be shown as memory (not ram)
I got it. Thanks for the immense help. Turns out I have to select /usr first and then from the options select tge "use as swap" option. I was just dumb.
 

RedAreApples

New Member
Credits
113
Open terminal and copy and paste this command.
Code:
sudo dmidecode -t memory | grep -i size
Press enter and then enter your password and press enter.
I saw that and realised I had some adjustments to make before selecting the memory as a swap file. I was following tutorials of linuxmint 20 and they had some difference in appearance. So I could not find the option to swap file directly.Thanks a lot!
 

Members online


Top