no sound

Status
Not open for further replies.

meritax69

New Member
Credits
81
hi
i've no sound
my pc is a laptop asus x555Q
I used to have sound years ago on same pc on my xubuntu 18.04 after doing some tricks i forgot.
now years later i try debian, ubuntu, linux mint: they are all broken.

I've settled with linux mint last LTS version, i've no sound, headphone don't work, speakers don't work. Not trying hdmi output cause i dont have any hdmi equipment.

Here are some system info:

Code:
$ dmesg | grep snd
[   23.928342] snd_hda_intel 0000:00:01.1: enabling device (0000 -> 0002)
[   23.928544] snd_hda_intel 0000:00:01.1: Force to non-snoop mode
[   23.928845] snd_hda_intel 0000:00:09.2: enabling device (0004 -> 0006)
[   24.003568] snd_hda_intel 0000:00:01.1: bound 0000:00:01.0 (ops amdgpu_dm_audio_component_bind_ops [amdgpu])
[   24.944245] snd_hda_intel 0000:00:09.2: azx_get_response timeout, switching to polling mode: last cmd=0x000f0000
[   25.952245] snd_hda_intel 0000:00:09.2: Codec #0 probe error; disabling it...
[   26.964259] snd_hda_intel 0000:00:09.2: azx_get_response timeout, switching to single_cmd mode: last cmd=0x000f0000
[   26.964885] snd_hda_intel 0000:00:09.2: no codecs initialized
Code:
$ lspci | grep Audio
00:01.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Kabini HDMI/DP Audio
00:09.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Carrizo Audio Dummy Host Bridge
00:09.2 Audio device: Advanced Micro Devices, Inc. [AMD] Family 15h (Models 60h-6fh) Audio Controller
Code:
$ pacmd list-cards
1 card(s) available.
    index: 0
    name: <alsa_card.pci-0000_00_01.1>
    driver: <module-alsa-card.c>
    owner module: 7
    properties:
        alsa.card = "0"
        alsa.card_name = "HDA ATI HDMI"
        alsa.long_card_name = "HDA ATI HDMI at 0xfeb64000 irq 43"
        alsa.driver_name = "snd_hda_intel"
        device.bus_path = "pci-0000:00:01.1"
        sysfs.path = "/devices/pci0000:00/0000:00:01.1/sound/card0"
        device.bus = "pci"
        device.vendor.id = "1002"
        device.vendor.name = "Advanced Micro Devices, Inc. [AMD/ATI]"
        device.product.id = "9840"
        device.product.name = "Kabini HDMI/DP Audio"
        device.form_factor = "internal"
        device.string = "0"
        device.description = "Audio Interno"
        module-udev-detect.discovered = "1"
        device.icon_name = "audio-card-pci"
    profiles:
        output:hdmi-stereo: Salida Digital Stereo (HDMI) (priority 5900, available: no)
        output:hdmi-surround: Salida Digital Surround 5.1 (HDMI) (priority 800, available: no)
        output:hdmi-surround71: Salida Digital Surround 7.1 (HDMI) (priority 800, available: no)
        off: Apagado (priority 0, available: unknown)
    active profile: <output:hdmi-stereo>
    sinks:
        alsa_output.pci-0000_00_01.1.hdmi-stereo/#3: Audio Interno Digital Stereo (HDMI)
    sources:
        alsa_output.pci-0000_00_01.1.hdmi-stereo.monitor/#3: Monitor of Audio Interno Digital Stereo (HDMI)
    ports:
        hdmi-output-0: HDMI / DisplayPort (priority 5900, latency offset 0 usec, available: no)
            properties:
                device.icon_name = "video-display"
As you can see it shows only HDMI sound outputs, not the integrated speakers, I don't know why.
or are my integrated speakers hdmi???

What I've tried to fix it, is all those lines in modprob.d conf file, one by noe, reboot every time:

Code:
# Try fix nosound
#options snd-hda-intel model=auto
#options snd-hda-intel dmic_detect=0
#options snd_hda_intel probe_mask=0x1ff
options snd-hda-intel probe_mask=1
nothing worked
I tried upgrade from kernel 5.4 to genered hwe 5.11, still not working.

help

thanks you guy hope you fix my linux

things like pulseaudio -k or reload alsa of course dont work
of course timidity isnt installed
 
Last edited:


SpongebobFan1994

Active Member
Credits
3,908
I recently had an issue with the sound on my laptop. After I was encouraged to reinstall Mint, everything works perfectly now. Try doing that with whatever distro you're having trouble with.
 

Condobloke

Well-Known Member
Credits
14,945
G'day meritax69, Welcome to Linux.org

Click on menu, and type in Driver Manager type in your password to proceed

Your pc will be scanned for hardware drivers etc

Your pc is from approx 2015, so you should not need proprietary drivers....Linux Mint should have the necessary driver already.

Let us know the result.

Edit: Apparently the asus x55q has known problems with sound.

How extensively have you googled this?
 

brickwizard

Well-Known Member
Credits
4,997
may i suggest you read through this thread, although a diffrent box the problem is the same
 

KGIII

Super Moderator
Staff member
Gold Supporter
Credits
25,899
Hmm... And you checked in other distros, like Ubuntu, to see if the sound worked there? (Your first post isn't quite clear.)

And, is there a sound mute button - often an Fn + F4, F5, F6, or something like that button on your keyboard?

By all rights, the sound driver should be built into the kernel for your device. It's AMD's sound. It shouldn't need additional drivers.
 

meritax69

New Member
Credits
81
Hmm... And you checked in other distros, like Ubuntu, to see if the sound worked there? (Your first post isn't quite clear.)
yes I tried debian and ubuntu too, sound doesn't work on them.

And, is there a sound mute button - often an Fn + F4, F5, F6, or something like that button on your keyboard?
sound isn't mute and is on max volume

By all rights, the sound driver should be built into the kernel for your device. It's AMD's sound. It shouldn't need additional drivers.
have you read the system infos I've posted ?
what does the codec error in the dmesg means? I feel like this is the main issue to solve.

Why isn't there any "analog-output" in the pacmd list-cards profile? are my integrated speakers somehow related to hdmi??
Notice how it says all profiles are "unavailable".

Why do I have 3 audio devices? Which one should be used? It seems I can only select the first one which is related to HDMI. It gives me the impression that it only can do audio if I use an HDMI screen with integrated speakers, but i'm not using that.
 

KGIII

Super Moderator
Staff member
Gold Supporter
Credits
25,899
have you read the system infos I've posted ?
Indeed I have and the only thing that led me to was updating the kernel - which you've already done. One person did resolve it by moving to the Liquorix kernel (which is pretty easy, but you're already on an updated kernel).

You know, install and open pavucontrol and go through that. Look at the 'output devices' most heavily.
 

f33dm3bits

Gold Member
Gold Supporter
Credits
24,139
Try adding doing this:
1. Open /etc/default/grub with your favorite editor using sudo privileges.
2. Change this line from: GRUB_CMDLINE_LINUX="" to the following.
Code:
GRUB_CMDLINE_LINUX="snd_hda_intel.probe_mask=0x01"
3. Open a terminal and run: sudo update-grub
4. Reboot your system
5. Check if your sound works now.
 

meritax69

New Member
Credits
81
Try adding doing this:
1. Open /etc/default/grub with your favorite editor using sudo privileges.
2. Change this line from: GRUB_CMDLINE_LINUX="" to the following.
Code:
GRUB_CMDLINE_LINUX="snd_hda_intel.probe_mask=0x01"
3. Open a terminal and run: sudo update-grub
4. Reboot your system
5. Check if your sound works now.
I tried with:

options snd_hda_intel probe_mask=0x1ff
and
options snd-hda-intel probe_mask=1

in /etc/modprob.d alsabase.conf

it didn't help.
 

f33dm3bits

Gold Member
Gold Supporter
Credits
24,139
I had that with one of my systems and putting it in /etc/modprob.d didn't help, adding it to my grub configuration solved it on that system. So add this to grub solved it for me.
Code:
GRUB_CMDLINE_LINUX="snd_hda_intel.probe_mask=0x01"
 
Last edited:

meritax69

New Member
Credits
81
I had that with one of my systems and putting it in /etc/modprob.d didn't help, adding it to my grub configuration solved it on that system. So add this to grub solved it for me.
Code:
GRUB_CMDLINE_LINUX="snd_hda_intel.probe_mask=0x01"
Code:
$ dmesg | grep -i snd
[    0.000000] Command line: BOOT_IMAGE=/vmlinuz-5.11.0-25-generic root=/dev/mapper/vgmint-root ro snd_hda_intel.probe_mask=0x01 quiet splash
[    0.053395] Kernel command line: BOOT_IMAGE=/vmlinuz-5.11.0-25-generic root=/dev/mapper/vgmint-root ro snd_hda_intel.probe_mask=0x01 quiet splash
[   23.239949] snd_hda_intel 0000:00:01.1: enabling device (0000 -> 0002)
[   23.240196] snd_hda_intel 0000:00:01.1: Force to non-snoop mode
[   23.240530] snd_hda_intel 0000:00:09.2: enabling device (0004 -> 0006)
[   23.300684] snd_hda_intel 0000:00:01.1: bound 0000:00:01.0 (ops amdgpu_dm_audio_component_bind_ops [amdgpu])
[   24.247594] snd_hda_intel 0000:00:09.2: azx_get_response timeout, switching to polling mode: last cmd=0x000f0000
[   25.255600] snd_hda_intel 0000:00:09.2: Codec #0 probe error; disabling it...
[   26.271619] snd_hda_intel 0000:00:09.2: azx_get_response timeout, switching to single_cmd mode: last cmd=0x000f0000
[   26.275120] snd_hda_intel 0000:00:09.2: no codecs initialized
still no sound.

hey do you guys just make me do random things, or do you try to address the issues that show in my system info?
I already tried all the random commands i've found on google.
 

meritax69

New Member
Credits
81
anyone notice I've 3 audio devices???????????????
one is 0000:00:01.1 the other one is 0000:00:09.2
the first one SEEMS to be only for HDMI ??????????????????????? AND IT IS SHOWN AS "UNAVAILABLE" MAYBE THATS A CLUE???????????????????????????????
the second one codecs can't be initialized.
maybe stop ignoring that?

i already googled and copy pasted all the commands and grub things, nothing work.
i doubt yourself even understand the commands you make me use.

and plz the "is it mute?" and pavucontrol, don't insult me.
make some sense guys ;)
 
Last edited:

f33dm3bits

Gold Member
Gold Supporter
Credits
24,139
I had the same problem as you with my sound device not working and I found that as the solution in the history of a bug report someone made and several people were participating in. So that is not a random solution since your system is using the same audio driver as my system which was also having this problem. I thought it might work for you, apparently not but it was worth a try.

Don't come here demanding for better help since everyone is just trying to chip in to trying to help you get to a solution and everyone here is a volunteer.
As for the solution I asked you to try, it comes from the available module options of the module that is being used by your sound device.
Code:
parm:           probe_mask:Bitmask to probe codecs (default = -1). (array of int)
Setting that at a certain value has effect on the codecs according to that, since people who write the kernel and the drivers know what would be a good value when it is not one of the standard options that is used a lot. That is why when I had the problem I went looking through bug reports to see how other people had solved it. So that's all the advice I can give you, when I run into a problem I search for the the module/driver name and errors I come across either in dmesg or syslog and then look for how others solved it in bug reports. I can do that for your device/driver but seems you are not satisfied with trying "random things and solutions"
 
Last edited:

Condobloke

Well-Known Member
Credits
14,945
Why dont you just leave?

Go somewhere, where you can pay for the help you receive.
 
Status
Not open for further replies.
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Members online


Top