No sound from built in speakers on ASUS EXPERTCENTER AIO E5402W

ivan3666

New Member
Joined
Jan 7, 2023
Messages
13
Reaction score
0
Credits
93
Hello everyone,


First of all I wish you all the best in new year. After over 20 years in Windows and Mac environment, it is time to return to roots.


I have installed fresh copy of Ubuntu 22.04.1 LTS on my ASUS EXPERTCENTER AIO E5402W I have no sound coming from the speakers. Bluetooth headset is working fine. I have tried all the solutions I have found on various forums (don't ask to remember them all), but no luck. AlsaMixer seems to show all the right values. PulseAudio Volume Control is showing as the sound is playing-that blue line is moving. Screenshots attached.


Any help or step by step guide is appreciated. I will sure know to respect your time and effort and will send some beer or lunch money. Thank you.

Ivan
 

Attachments

  • Screenshot from 2023-01-07 12-13-18.png
    Screenshot from 2023-01-07 12-13-18.png
    28.7 KB · Views: 264
  • Screenshot from 2023-01-07 12-14-55.png
    Screenshot from 2023-01-07 12-14-55.png
    54.9 KB · Views: 194


Welcome to the forums
first right click on the sound icon in task bar and check its not on mute
if OK go to sound settings check on board speakers are selected
 
For pavolumecontrol can you go the "Configuration" tab and take a screenshot of what you see there.
 
Check also the Playback tab.

OP is likely on the right path. It's often just a setting in pavucontrol that's obvious in hindsight.
 
Welcome to the forums
first right click on the sound icon in task bar and check its not on mute
if OK go to sound settings check on board speakers are selected
Thank you. I've tried that, all is correct.
For pavolumecontrol can you go the "Configuration" tab and take a screenshot of what you see there.
Screenshot attached. Analog Stereo Duplex is set at the moment. I believe I tried most if not all the options listed there.

Check also the Playback tab.

OP is likely on the right path. It's often just a setting in pavucontrol that's obvious in hindsight.
Maybe I am missing something in pavucontrol. It does leave an impression like something somewhere is muted.
Try in the terminal

Code:
sudo touch /usr/share/pipewire/media-session.d/with-pulseaudio
systemctl --user restart pipewire-session-manager

My best guess is for some reason pipewire-media-session was no longer picking up /etc/pipewire/media-session.d/with-pulseaudio - so the above command will make the file needed

changelog is here - https://changelogs.ubuntu.com/chang...pewire-media-session_0.4.1-2ubuntu1/changelog
Tried this as well. No luck.

Thank you for your efforts guys.
 

Attachments

  • Screenshot from 2023-01-07 17-13-08.png
    Screenshot from 2023-01-07 17-13-08.png
    151.2 KB · Views: 186
You have a whole lot of selections. I suspect it's one of those - but not one of the HDMI ones.
 
You have a whole lot of selections. I suspect it's one of those - but not one of the HDMI ones.
I have now officially tried all the options under "Configuration" tab. And I've tried both Output Devices that are offered with all the combinations. Nothing makes the sound play.
 
Screenshot attached. Analog Stereo Duplex is set at the moment. I believe I tried most if not all the options listed there.
Maybe I am missing something in pavucontrol. It does leave an impression like something somewhere is muted.
How are your speakers connected to your computer, by Jackplug 3.5mm or using another connection?
 
In case the following helps to solve the issue:

Audio device: Intel Corporation Tiger Lake-H HD Audio Controller (rev 11) (prog-if 80)
DeviceName: Onboard - Sound
Subsystem: ASUSTeK Computer Inc. Tiger Lake-H HD Audio Controller
Flags: bus master, fast devsel, latency 32, IRQ 195, IOMMU group 18
Memory at 601f298000 (64-bit, non-prefetchable) [size=16K]
Memory at 601f000000 (64-bit, non-prefetchable) [size=1M]
Capabilities: [50] Power Management version 3
Capabilities: [80] Vendor Specific Information: Len=14 <?>
Capabilities: [60] MSI: Enable+ Count=1/1 Maskable- 64bit+
Kernel driver in use: snd_hda_intel
Kernel modules: snd_hda_intel, snd_sof_pci_intel_tgl
 
maybe your pulse directory under .config is corrupted

Go to your home directory and then go to the hidden config directory. Rename the directory named pulse here:

home/.config/pulse - right click and rename it old_pulse

Now reboot your system. The pulse directory should be created afresh and with any luck, you have sound. If your sound does work you can then delete the old_pulse folder
 
maybe your pulse directory under .config is corrupted

Go to your home directory and then go to the hidden config directory. Rename the directory named pulse here:

home/.config/pulse - right click and rename it old_pulse

Now reboot your system. The pulse directory should be created afresh and with any luck, you have sound. If your sound does work you can then delete the old_pulse folder
No luck. Any other ideas?
 
inxi-a produces the following:

Audio:
Device-1: Intel Tiger Lake-H HD Audio driver: snd_hda_intel
Sound Server-1: ALSA v: k5.15.0-57-generic running: yes
Sound Server-2: PulseAudio v: 15.99.1 running: yes
Sound Server-3: PipeWire v: 0.3.48 running: yes
 
same here
I deleted my answer - after some thought - I don't think it applied, but then again I was thinking that there was too many default sound servers running and they would have to select one (PulseAudio or PipeWire) of them and disable the other from booting - maybe mask PipeWire under systemctl - just a thought - but PipeWire should not conflict with PulseAudio - here is my output from inxi -A

Code:
@expirion:~$ inxi -A
Audio:
  Device-1: Intel 7 Series/C216 Family High Definition Audio
  driver: snd_hda_intel
  Device-2: NVIDIA GF108 High Definition Audio
  driver: snd_hda_intel
  Sound Server: ALSA v: k5.15.84-xanmod1

What is the output of
Code:
pactl info
 
Last edited by a moderator:
Doesn't his tiger lake need some extra stuff installed for it to work?
 
I deleted my answer - after some thought - I don't think it applied, but then again I was thinking that there was too many default sound servers running and they would have to select one (PulseAudio or PipeWire) of them and disable the other from booting - maybe mask PipeWire under systemctl - just a thought - but PipeWire should not conflict with PulseAudio - here is my output from inxi -A

Code:
@expirion:~$ inxi -A
Audio:
  Device-1: Intel 7 Series/C216 Family High Definition Audio
  driver: snd_hda_intel
  Device-2: NVIDIA GF108 High Definition Audio
  driver: snd_hda_intel
  Sound Server: ALSA v: k5.15.84-xanmod1

What is the output of
Code:
pactl info
Output of pactl info:


Code:
Server String: /run/user/1000/pulse/native
Library Protocol Version: 35
Server Protocol Version: 35
Is Local: yes
Client Index: 16
Tile Size: 65472
User Name: ivan
Host Name: IvanDevice
Server Name: pulseaudio
Server Version: 15.99.1
Default Sample Specification: s16le 2ch 44100Hz
Default Channel Map: front-left,front-right
Default Sink: alsa_output.pci-0000_00_1f.3.analog-stereo
Default Source: alsa_input.pci-0000_00_1f.3.analog-stereo
Cookie: 3fc9:e91b

Any other ideas?

Hope I won't have to change distro to some else. Elementary was highly unstable and froze all the time. Haven't tried Fedora and OpenSuse for a long time.
 
AS your machine is fairly new, This may be time to try something different, download MX-21.2.1_x64 “ahs” burn it to a bootable pen-drive and try it in test mode, see if it will work with all your kit, I am making this suggestion as MX-AHS has the most up-to-date range of drivers available that I know,
 
Server Name: pulseaudio
So pulseaudio is primary let try stopping the pipewire service and see if your audio comes back
Code:
systemctl --user stop pipewire.socket && systemctl --user stop pipewire.service
do not reboot this will get restarted if you do - if it works we will mask pipewire
 


Latest posts

Top