No sound after upgrading to mint 18.1

wizardfromoz

Administrator
Staff member
Gold Supporter
Joined
Apr 30, 2017
Messages
7,314
Reaction score
6,203
Credits
24,997
So, I realize I am a little late in the game here.

Not at all, @ZEUS-PA and welcome to linux.org :)

We don't close threads around here except for a good reason, and with the way things change and update with Linux, there are often new solutions, new variations, new workarounds that can assist, if not the OP, then others with similar problems. So "Goodonyer" for sharing :D.

I, for one, am bookmarking those sources you referred, and their links, if applicable, both for my own edification and to help others.

I was unaware of the restriction on Firefox 52, and wonder if that also applies to the ESR version I use with Debian 9 'Stretch'.

So keep the input coming, and it's Saturday morning in Oz, so all and sundry whom know me will expect

Avagudweegend :p

Chris Turner
wizardfromoz
 


JasKinasis

Well-Known Member
Joined
Apr 25, 2017
Messages
1,493
Reaction score
2,116
Credits
10,643
I was unaware of the restriction on Firefox 52, and wonder if that also applies to the ESR version I use with Debian 9 'Stretch'.

I'm running Debian testing, which is currently tracking "buster" the development version of Debian 10. I've just ran the following command to check that libasound2 (Which allows firefox to use Alsa) is still a dependency of the firefox-esr package:
Code:
apt-cache showpkg firefox-esr | grep -i asound
And the output from that command clearly shows that libasound2 is still one of the packages that firefox-esr depends on. So the firefox-esr in Debian "testing" is currently safe. The one in "stable" will probably be exactly the same version, or at worst it will be a single point-release behind! Either way, the version of FF-ESR in "stable" should be OK too!

This problem will only affect people whose systems ONLY use Alsa and it should only affect the next major version of the ESR version of FF. Luckily - thanks to all of the different media software I have installed, I already have Pulseaudio AND Alsa - so if Debian testing does switch to a newer version of Firefox, I'll be OK. heh heh!
 

wizardfromoz

Administrator
Staff member
Gold Supporter
Joined
Apr 30, 2017
Messages
7,314
Reaction score
6,203
Credits
24,997
Ta Jas ... knowing you are a "Debian Man" I suspected you might be along with input, and I was not disappointed :p

I'll grep that when next I am in Debian.

Cheers

Wiz
 

Jeremy J

New Member
Joined
Feb 19, 2018
Messages
14
Reaction score
13
Credits
0
So, I realize I am a little late in the game here. I was having a similar issue and found a resolution to my problem there (and a pretty simple one at that!)
https://www.linuxquestions.org/ques...und-hardware-in-linux-mint-18-1-a-4175605741/
The link for the whole discussion is above, but the solution is here:
###########
Here is what I did:

Added the following line to the file etc/modprobe.d/alsa-base.conf:

"options snd-hda-intel model=ref"
###########

You'll have to open the containing folder, "modprobe.d" as root, which always makes me nervous, but after restarting my system, all sound works.


Sorry, I can't follow the instructions, but would love to try this. I love you Linux people, but I don't speak Linux.

The potential solution Zeus posted looks very enticing, but when it comes to computers, I can do exactly what I'm told with copy and paste.

Looks like I have to open a folder, "modprobe.d" as root. Add the line: "options snd-hda-intel model=ref" to the file "etc/modprobe.d/alsa-base.conf"

I'm still lost.
 

atanere

Well-Known Member
Joined
Apr 6, 2017
Messages
2,628
Reaction score
2,771
Credits
41
Sorry, I can't follow the instructions, but would love to try this. I love you Linux people, but I don't speak Linux.

The potential solution Zeus posted looks very enticing, but when it comes to computers, I can do exactly what I'm told with copy and paste.

Looks like I have to open a folder, "modprobe.d" as root. Add the line: "options snd-hda-intel model=ref" to the file "etc/modprobe.d/alsa-base.conf"

I'm still lost.

Hi Jeremy... you're not lost... you're right there! And welcome to the forum! :D

We all know it takes awhile to get in tune with Linux "geek-speak," so don't feel bad about that. And we will be glad to help you along as best as we can. Also take a look around on this site (Tutorials, and just reading through the threads) and anywhere & everywhere on the web to help you get used to the terminology. Make Google your best friend! :D:D

So, let's help you try to make this change above to see if it fixes your sound issue quickly, but if not, then please open up a new thread so we can work on your case explicitly (as there may be many differences from the Original Poster and his trouble).

You know what "root" is, right? It's simply the administrator of your computer... that's YOU. But usually we don't run Linux as the administrator all the time (like those silly Windows folks). Instead, you will usually use sudo to execute other commands with the power of the root/administrator. Root is also called the "super user"... and sudo can be thought of as this: super user do (this command).

The example you quoted above is a little misleading in that it says to open a folder as root and then modify a file... but what you really need to do is to open the file as root, add the new line of text that was given, and then save the file. You would not be able to save the file if you did not open it with root privileges. Making this change to this text file will not harm your system, but if it fails to work you should go back into the file again and remove it (thus restoring it back to its original form). Or you could make a copy of the file before you make the changes, and if they fail to help you, you could restore the backup back to the original file name.

Okay, let's do this... ready? We'll use the built in text editor called nano. Open a terminal... CTRL-ALT-T is a nice shortcut to do this... and then enter the following:

Code:
sudo nano etc/modprobe.d/alsa-base.conf
TIP: type sudo nano /etc/modp (then hit the TAB key).... then type als (then hit the TAB key again). Cool, huh?

You should now have the file open in a very basic text editor. Use the down arrow key to get to the bottom of the file so your cursor is on a blank line at the bottom. Come back to this page in your web browser, click and drag your mouse across this text, but without the parenthesis (options snd-hda-intel model=ref), then CTRL-C to copy the text. Now go back to the nano editor, click back in at the bottom of the file so the cursor is blinking on the blank line at the bottom again, then CTRL-SHIFT-V to paste the text in. Or you could use the Edit menu to Paste too... these are similar to Windows, except using CTRL-SHIFT-V is slightly different than CTRL-V that you may be used to.

Double check that the text you pasted exactly matches the text you copied (no parentheses or quote marks), and if all is good... look at the commands available at the bottom of the nano editor. The ^ symbol means the CTRL key, so you now need to hit CTRL-O (Write Out = save) the file. When you hit CTRL-O, you see a line highlighted that says what the file name will be... in this case the same as what you started with... so hit Enter to save the file. Then hit CTRL-X to exit from nano, and reboot. With luck, your sound will be working.

But if the sound is still broken, then as I said, I would recommend that you re-do the process above to remove the line you just added, and then open up a new thread so that we can dig deeper into the problem. Sound can be a real pain sometimes, and there are many variables between computers which we have not considered in your case. Still, it was a good opportunity to show you how to edit a configuration text file in Linux! :confused::eek::D

Maybe next time we will get you to install a nicer editor, like gedit.

Cheers
 

wizardfromoz

Administrator
Staff member
Gold Supporter
Joined
Apr 30, 2017
Messages
7,314
Reaction score
6,203
Credits
24,997
Nice piece of work, Stan (@atanere ) ;)

I love you Linux people, but I don't speak Linux.

That's really sweet, Jeremy ... we love people like you, too :p.

People like you who stick with Linux become people like us ... boring ... really interesting and cluey people, the life of parties.

So see how you go with what Stan suggests, and we'll try to have your back :D

Cheers

Wizard
 
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Linux.org Hosting Donations
Consider making a donation


Top