No Boot Media Detected After Shrinking Home Partition

YBtheS

Member
Credits
234
I have a hard drive that had the root, home, and swap partitions on it. I wanted to add a fourth NTFS partition so I used GParted to shrink the home partition and make the newly unallocated space an NTFS partition. Upon restarting my computer and booting from that hard drive, I got the "Reboot and Select proper Boot device" message. How do I go about fixing this? Thanks in advance for any help.
 


Condobloke

Well-Known Member
Credits
1,542

sp331yi

Active Member
Credits
2,374
Suggest taking a screenshot of gparted for your hard drive and posting it.
 

wizardfromoz

Super Moderator
Staff member
Gold Supporter
Credits
2,015
You would have to do that from a Live USB, the OP cannot get in to his Linux.

Wizard
 

TechnoJunky

Well-Known Member
Credits
304
Does your computer have multiple hard drives? Did you go into the Bios and change which one it should boot to? In your post you said "booting from that hard drive,". This makes me think you did this and the boot info isn't on that hard drive. If you did, change the boot drive in bios back to the original.
 

YBtheS

Member
Credits
234
Suggest taking a screenshot of gparted for your hard drive and posting it.
You would have to do that from a Live USB, the OP cannot get in to his Linux.

Wizard
I have a live CD with GParted on it so that should be no problem. Will send a screenshot of it when I have the chance.

Does your computer have multiple hard drives? Did you go into the Bios and change which one it should boot to? In your post you said "booting from that hard drive,". This makes me think you did this and the boot info isn't on that hard drive. If you did, change the boot drive in bios back to the original.
Yes, I use two drives. I never changed the boot order. Windows is first priority and that works fine. I use the boot menu so that if I don't select what to boot to, it default goes to Windows. Otherwise I can manually select my Linux drive.
 
Last edited:

TechnoJunky

Well-Known Member
Credits
304
ok, so the boot menu (Grub) shows up and you can select Windows and that boots fine. But when you select Linux, that fails to boot?
 

YBtheS

Member
Credits
234
Not exactly. Grub doesn't show up. It never has even when the drive worked. I believe this is because I installed the boot loader on the drive that doesn't have Windows? I'm referring to the boot menu that appears when you press F12 (at least on a Gigabyte motherboard) before the OS loads. Found an image of what I'm referring to online:
 

wizardfromoz

Super Moderator
Staff member
Gold Supporter
Credits
2,015
Thanks for that @YBtheS :)

1. Can you show us a GParted screenie of the Windows drive, and which Windows is it?

2. Which Linux are you using, down to version and desktop eg Ubuntu 18.04 Desktop (GNOME) or Linux Mint 19.3 with the Cinnamon Desktop?

3. Is the computer a recent model and does it run under UEFI or MBR - brand, name and model would be good, or other specs?

Thanks

Wizard
 

YBtheS

Member
Credits
234
1. Windows 10
output-onlineimagetools.jpg


2. Manjaro Linux KDE Plasma 20.0.1. If I remember correctly, the Linux kernel is 5.4 if that is useful. Sorry, I am new to Linux.

3. It's custom built so it has no single brand, name, or model. It uses UEFI. Here are the specs:
CPU: AMD Ryzen 5 1600
GPU: Sapphire Radeon NITRO+ RX 590
Motherboard: Gigabyte B450M D3SH mATX
SSD (the one with Windows): SanDisk SSD Plus 1 TB
HDD (the one with Linux): WDC WD10EADS-65MB1 1TB
Memory: 2 x 8 GB Patriot Viper DDR4-2667 MHz
PSU: Corsair CX 650M

Thanks for sticking with me so far :)

EDIT: I found out that it uses UEFI by opening System Information in Windows. However I do actually recall something about the Master Boot Record when first installing the persistent version of Manjaro from the live Manjaro CD. So I'm not quite sure...
 

wizardfromoz

Super Moderator
Staff member
Gold Supporter
Credits
2,015
Thanks again.

Do you still have the Manjaro DVD? We could use it to gather some information.

I'll be back when I can.

Wizard
 

TechnoJunky

Well-Known Member
Credits
304
ok, I understand now. So when you would tell it to boot to the Linux hard drive, did it show you the Grub menu? It sounds like what you said, you installed the boot loader on the Linux drive so when you boot up the default drive, which is the Windows drive, it doesn't see the boot loader. I think what you should do is go into the bios and change the boot order so that it boots the the Linux drive instead of the Windows drive. You will still get the option to boot to Windows because it's in the Grub menu. Then you need to try using Boot Repair, https://technastic.com/edit-repair-grub-boot-menu/. If everything is rescue-able then this should fix things.

FYI, you'll need to boot to a live usb/dvd to use Boot Rescue.
 

YBtheS

Member
Credits
234
Thanks again.

Do you still have the Manjaro DVD? We could use it to gather some information.

I'll be back when I can.

Wizard
Yes, I do.

ok, I understand now. So when you would tell it to boot to the Linux hard drive, did it show you the Grub menu? It sounds like what you said, you installed the boot loader on the Linux drive so when you boot up the default drive, which is the Windows drive, it doesn't see the boot loader. I think what you should do is go into the bios and change the boot order so that it boots the the Linux drive instead of the Windows drive. You will still get the option to boot to Windows because it's in the Grub menu. Then you need to try using Boot Repair, https://technastic.com/edit-repair-grub-boot-menu/. If everything is rescue-able then this should fix things.

FYI, you'll need to boot to a live usb/dvd to use Boot Rescue.
I've never actually even seen a Grub menu before though whether booting into Windows or Linux. And I'd rather not have the computer by default go to Linux since I usually use Windows (as of now, at least).
 

TechnoJunky

Well-Known Member
Credits
304
You can make a modification to the menu to automatically choose Windows if you don't select anything else. It's a lot more convenient than hitting F12 at the right time. But regardless, it's your computer, set it up the way you want it. Try using teh Boot Repair that I linked above on your Linux drive.
 

wizardfromoz

Super Moderator
Staff member
Gold Supporter
Credits
2,015
I'd rather not have the computer by default go to Linux since I usually use Windows (as of now, at least).
That's fine - if we can get that grub menu up, it would have Linux at the top, followed by Windows showing as "Windows Boot Manager".

We can then edit a file to set the Windows entry as default to boot into after a countdown, usually 10 seconds, and then you choose consciously when to boot into Manjaro. Sound OK?

I have to go for some physiotherapy shortly but when back, I'll outline some ideas for that Live DVD.

Cheers

Wizard
 

YBtheS

Member
Credits
234
You can make a modification to the menu to automatically choose Windows if you don't select anything else. It's a lot more convenient than hitting F12 at the right time. But regardless, it's your computer, set it up the way you want it. Try using teh Boot Repair that I linked above on your Linux drive.
Okay, I'll give it a try :)

That's fine - if we can get that grub menu up, it would have Linux at the top, followed by Windows showing as "Windows Boot Manager".

We can then edit a file to set the Windows entry as default to boot into after a countdown, usually 10 seconds, and then you choose consciously when to boot into Manjaro. Sound OK?

I have to go for some physiotherapy shortly but when back, I'll outline some ideas for that Live DVD.

Cheers

Wizard
Yup that's fine with me. Although if I understand correctly, this means that if I were to remove either the SSD or HDD, my computer would fail to boot, correct?
 

TechnoJunky

Well-Known Member
Credits
304
yes, but you can then go into the Bios and tell it to boot to the Windows drive and that would put it back exactly the way it was before you added the Linux drive. Or if you decided to remove the WIndows drive, it would still boot but choosing Windows would give you a failure. There's a grub update command you could run that would rescan and remove Windows from the Grub menu.
 

TechnoJunky

Well-Known Member
Credits
304
In my opinion, it's best to modify the boot record on the Linux drive, leaving the Windows drive as it came with the computer. Then change the boot order to boot the Linux. That way you can always revert back to the original settings and configurations before you loaded Linux.
 


Members online


Top