NewPenguin: Still struggling with Calamares Gecko install.

pavl

New Member
Credits
209
Having to post from Windows ... this is why ...
Following success with AHCI here ....This forum post.
At last have my new Samsung 860 EVO 500GB.
Wishing to have Win10pro existing installation kept on existing primary drive and use the boot option list to boot to Gecko o second external drive (new ssd).
Method attempting now ... to ensure that the Linux install is completely separate from Windows

Remove the primary Win10p ssd from machine and fit 500GB new ssd (empty and formatted/initialised in Windows NTFS).
Use Gecko live usb and boot machine to Gecko = success with new ssd drive recognised.
Launch Calamares to attempt install to new ssd.

( Minor issues during the next part with screen freezing but mouse cursor still movable .... at least a minute each time - but that is not the main problem ...).

Now faced with partitioning ...
Want approx 70GB of Gecko and leave remainder either as NTFS or unallocated (to be formatted later in Windows).
Stuck with manual partitioning as the auto option wants the whole capacity of new ssd and I cannot see how to reduce that and leave the rest.

Calamares information is a bit thin (assumes we already know how to do this so does not fully explain).
Screenshot attached ... shows what I thought was correct setup and the Calamares instructions.
"New partition" at top as Fat32 and has both flags for "/root" and "/boot" (but not /boot/efi).
"New partition" second down is my intended Gecko install and is also "/root".

Screen freezing frequently ....

But the "Next" button remains greyed out.
Have played with versions of these settings, all without success.

As I am now back out in Windows cannot re=check those settings now.
As you will already note I do not understand flags and settings and found the Calamares info unhelpful.
Happy to delve into guts in Windows but need to learn how to do this in Linux and getting stuck at what I thought was a simple stage.
 

Attachments



pavl

New Member
Credits
209
Thank you "KGIII".
My lack of understanding of flags might be an issue here ?
But perhaps this is Calamares specific ?
"GeckoLinux" advised me to go direct to Calamares (on the earlier topic) so might take a look there as well ...
 

pavl

New Member
Credits
209
UPDATE:
Determined not to give up ... so ...
Read a bit of general info (still no idea about flags) and played with settings and put the new ssd in an enclosure and left the primary w10p drive in place.
Short version:
Back in windows but looking at an external drive with the partition layout I had hoped for ... but cannot get it to boot.
Longer version:
Was given four options for partitions ... went for manual.
Messed with them and found that this time was given a warning after selection something wrong. This warning at least had the good grace to tell me to go back and set one partition as FAT32 but had already done that.
Also gave the vital information missing elsewhere = this FAT32 has to have the flag "esp" set and the mount point must be "/boot/efi".
From there I just guessed that I could have my main Gecko partition as "/" mount point.
Might have messed with another flag but no way to check from this 'window'.
Set the third partition as NTFS.
Calamares accepted all my messing and installed.
Shut down and tried to get new install to boot.
Could not find twhich bit to boot from within Windows Bios ... a couple of PCI options and four (I think) gpt options.
Chose top/first one (PCI) and tried ... and failed.
EDIT:
Image added of options now seen (fewer than first go!)

Back to Windows and can now see the partitions I expected to see (but dont know what is wrong with them).
512MB FAT32 Healthy Basic Data and has drive letter. Directories = EFI/boot & grub
70G (blank) Healthy Primary (assume = ext4) without drive letter.
394GB NTFS Healthy Basic Data and has drive letter.

So near ......
Cam someone point me to a better Calamares setting for manual partitions on this single external ssd ?
 

Attachments

Last edited:

pavl

New Member
Credits
209
Seem to have found solution on my own.
THUNDERBOLT.
Was using a usb C with Thunderbolt and did this machine defaults to not allowing Thunderbolt boot.
Used a standard usb A3 cable and am now typing from Gecko booted from my external drive.
Hopefully that little bit of info might help someone else.
No doubt will be back with another problem ... this will be for a LAMP install, Python, Flask, Ninja, MySQL or SQLite ... so plenty of trip hazards ahead !
Over and out
 

pavl

New Member
Credits
209
OK ... spoke too soon.
Can use Gecko and it accepts my user password as set up on install.
Firefox connects to network and can download Opera browser .... but wont install.

Also Yast and Yast Software refuses same password (multiple attempts).
Single user, single account name, carefully typed from written notes etc ....

So this install is stuck

Separate Windows File access issue ... wont mount the "Basic Data Partition" that has w10p on it (full shut down with shift to ensure no fast-start or similar rubbish going on).
 

pavl

New Member
Credits
209
Another go ...
Typing from another install to same new ssd.
And for those of us on rural copper ... the seemingly innocuous little icon we are presented with on first home screen titled "Language Installer" is the the worst part.
It is not just to add teh British English instead of Americanisms ... oh no .. it is a full update of everything and its dog.
A few minutes short of two hours at 100% bandwidth, a few hundred packages and MBs.
No warning, no options, just put-up-with-it ... in finest Microsoft fashion.

Calamares again no help ... not allowed to "Replace" or "Alongside" ... had to use "Manual" again ... and just replaced in my own guessed fashion (something Calamares seems unable to do).
Now have a Grub boot option on Windows boot list (not been able to investigate this yet as the update has consumed all spare time).

Now have Gecko on external ssd ... but it was a fight.
Over and out again.
 

pavl

New Member
Credits
209
For what it is worth ..... now fails to boot.
Got a new browser via Yast.
Installed latest Python, PIP, virtualenv and flask.
"env" activated and deactivated.
Seemed to be fine and working.
Shutdown.
Moved some files to the ntfs partition on the ssd in windows.
Failed to boot Gecko full install. Tried twice to check Windows shutdown fully.
Used USB Gecko live which booted as expected.
Everything visible in Windows folders and the full Gecko install folders.
But just locks on "Loading initial ramdisk", no inputs function, have to hold power to kill it.

As far as I can go in time and frustration.
WAMP here I come.
 

pavl

New Member
Credits
209
Solved with help from other forums.
TenForums to sort out the mess made by Calamares.
GeckoLinux on GitHub for linux specific.
LinuxQuestions general support.
Now know where to go ......
 

wizardfromoz

Super Moderator
Staff member
Gold Supporter
Credits
15,906
G'day @pavl glad to hear you got it sorted.

Can you share with us what the solution was?

Or perhaps @GeckoLinux can enlighten us.

Cheers

Wizard
 

pavl

New Member
Credits
209
From fading memory ..
Dell laptops are RAID by default - had to change to ACHI in safeboot in w10p as the other standard method failed.
Dell laptops usbC Thunderbolt ports are not enabled for boot unless changed in Bios and they make a huge fuss over that so went for standard usb3A from there onwards.
That lot alone took a while and a few failed installation attempts.
Live usb creation with Rufus is a problem .. had to use BalenaEtcher in Admin Run Mode.
Again ... a few failed installs.
Finally got a Static Gecko/Leap152 on live usb.
Calamares full install was horrible. Had to do manual partitioning as no other choice offered ... and as a complete beginner to Linux partitioning had to do a lot of reading and failing.
Eventually got something Calamares would accept.
Booted once, updated hundreds of packages over hours (rural copper). Shut down. Back to w10p. Shutdown. Gecko refused to boot.
I am using bios boot list from F12 and so tried every variation of parttion to boot from. Too long a story with various failed attempts.

FINAL SOLUTION:
Went for a network install newest rolling instead of static.
Ran that and did all updates (many hours).
Remove nvme primary drive with w10p.
Evo860ssd in external enclosure on usb3A.
Live usb with Rolling Gecko Leap152.
Full install ... but this time had old install still on ssd ....so was offered Repair. Just selected the main partition to change (I have an ntfs partition on bulk of ssd which has stayed unmolested).
Had to remove "hardware clock UTC" eventually as time went 2 hours out.

RESULT:
Windows replaced boots as default as normal.
Linux can be plugged in and booted from bios boot list.
Linux should now be portable and goes with a decent spare storage volume on same ssd in external enclosure.

Full install functions as expected and is quick (although the boot to w10p is quicker).
The creator of Gecko did say that the live version would be slower ... that is an understatement .. it is effectively un-usable. I have a list of times to do very simple operations such as clicking close 'x' and opening a very small text file ... all in many seconds between ten and thirty. Boot was nearly five minutes to wireless network alive.

Now able to learn how to use it.
Over and out.
Paul
 
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Staff online

Members online


Latest posts

Top