Nemo Won't Recognize USB

SpongebobFan1994

Well-Known Member
Joined
Jan 10, 2021
Messages
703
Reaction score
404
Credits
6,787
I'm using the 5.0.5 version in Mint 20.2 on a Lenovo X200 Thinkpad laptop/tablet. Before, I thought it might've been a hardware issue, but then I realized it wasn't after I searched for some answers online and tried a few things to troubleshoot it. I'm wondering if I need to upgrade Nemo?
 


Condobloke

Well-Known Member
Joined
Apr 30, 2017
Messages
4,789
Reaction score
4,106
Credits
27,542
In what way are you trying to access the usb stick with nemo ?

Walk us through what you are doing.
 

Condobloke

Well-Known Member
Joined
Apr 30, 2017
Messages
4,789
Reaction score
4,106
Credits
27,542
So, the usb is inserted. Is it recognised? If you double click on Home...(on the desktop) do you see the usb listed on the left hand side ?
 
OP
SpongebobFan1994

SpongebobFan1994

Well-Known Member
Joined
Jan 10, 2021
Messages
703
Reaction score
404
Credits
6,787
So, the usb is inserted. Is it recognised? If you double click on Home...(on the desktop) do you see the usb listed on the left hand side ?

Its inserted, but not appearing on the left side. Yet it will appear if I bring up the "disks" program or use the "lsusb" command.
 

Condobloke

Well-Known Member
Joined
Apr 30, 2017
Messages
4,789
Reaction score
4,106
Credits
27,542
If you right click on the file, and select "move to" ....or "copy to" ....do you get the choice of sending to that usb ?
 

Condobloke

Well-Known Member
Joined
Apr 30, 2017
Messages
4,789
Reaction score
4,106
Credits
27,542
Code:
lsusb

copy and paste that into Terminal.

Tell me if the usb stick is seen there
 

Condobloke

Well-Known Member
Joined
Apr 30, 2017
Messages
4,789
Reaction score
4,106
Credits
27,542
just saw your post .... Yet it will appear if I bring up the "disks" program or use the "lsusb" command.

So, open the disks app and mount it there

open disks
click on the usb stick
then click on the two gears situated just under the space that represents the usb stick
select 'Edit Mount Options'
tick the box for 'Mount at System Startup'
click ok down the bottom
reboot
 
OP
SpongebobFan1994

SpongebobFan1994

Well-Known Member
Joined
Jan 10, 2021
Messages
703
Reaction score
404
Credits
6,787
open disks
click on the usb stick
then click on the two gears situated just under the space that represents the usb stick
select 'Edit Mount Options'
tick the box for 'Mount at System Startup'
click ok down the bottom
reboot

I clicked on the gears icon, but "edit mount options" isn't highlighted for whatever reason

Screenshot from 2022-06-14 23-10-21.png
 

JasKinasis

Well-Known Member
Joined
Apr 25, 2017
Messages
1,515
Reaction score
2,154
Credits
10,904
Is the drive formatted? If not, you’ll need to format it.
If so, What file-system is in use on the USB drive?
The volume information is hidden in your screenshot, the right click context menu is in the way. But from looking at the greyed out options in the context menu, it looks probable that it is either unformatted, or it’s using a file-system that is currently unrecognised, or is unsupported.

Do you have the appropriate drivers/software installed for that particular file-system? You may need to install some additional fuse drivers in order to use the file-system.
 

wizardfromoz

Administrator
Staff member
Gold Supporter
Joined
Apr 30, 2017
Messages
7,503
Reaction score
6,350
Credits
26,518
David does GParted reveal the USB stick and if so please post us a screenshot?

Wiz

BTW just noticed Jas' post ... him first
 
OP
SpongebobFan1994

SpongebobFan1994

Well-Known Member
Joined
Jan 10, 2021
Messages
703
Reaction score
404
Credits
6,787
Is the drive formatted? If not, you’ll need to format it.
If so, What file-system is in use on the USB drive?
The volume information is hidden in your screenshot, the right click context menu is in the way. But from looking at the greyed out options in the context menu, it looks probable that it is either unformatted, or it’s using a file-system that is currently unrecognised, or is unsupported.

Do you have the appropriate drivers/software installed for that particular file-system? You may need to install some additional fuse drivers in order to use the file-system.

I just formatted it. I don't know what file system it's using because I don't know how to look it up.
 

Condobloke

Well-Known Member
Joined
Apr 30, 2017
Messages
4,789
Reaction score
4,106
Credits
27,542
This from an empty usb stick. i inserted it in a usb slot and it immediately appeared on my desktop.
I have right clicked it and selected properties

1655322529440.png
 

bob466

Well-Known Member
Joined
Oct 22, 2020
Messages
510
Reaction score
358
Credits
3,754
It might be a good idea to try another one.
happy0021.gif
 

bob466

Well-Known Member
Joined
Oct 22, 2020
Messages
510
Reaction score
358
Credits
3,754
Did you solve the problem with your Flash Drive ?

If you open the Disk Utility in Linux Mint...you'll see the Flash Drive and partition type eg...NTFS.
happy0035.gif


You can Re-Format there or right click Flash Drive on Desktop and choose Format...as we know Linux Mint has a USB Stick Formatter too.
happy0033.gif


When you Re-Format...your Flash Drive wont show up on the Desktop...go to Computer and you'll see your newly Formatted Flash Drive...double click to open...now close...you'll now see the Flash Drive on your Desktop...that is if the Flash Drive works.
happy0034.gif


When I do a clean install...I always put...Computer on the Desktop exactly for this reason...I also put Home and Trash there as well. ;)
 
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Linux.org Hosting Donations
Consider making a donation

Members online


Top