Need help with Debian 12


New Member
May 27, 2024
Reaction score
Installed graphical debian 12 on my Lenovo thinkcentre m715q.
While installation, the monitor worked, but after installation, grub loads, then monitor loses signal.

P.S. Ryzen 3 2200GE, with APU Vega 8 + DP to VGA adapter (on windows 10 it worked only with 75HZ refresh rate).

G'day @an0n1mus and welcome to :)

I may not be able to help you myself, but I'll ask a couple of questions the answers to which may help others to help you.
  1. Are you just running Debian on this machine, or is it a dualboot with Windows?
  2. If yes to the latter, do you have a Grub Menu at startup?
Chris Turner
@an0n1mus wrote:
monitor loses signal

It's not quite clear to me what this means. Is it one of these cases:
1. The monitor is completely blank as if the machine or monitor has been turned off? Or,
2. Is it black or dark, but with a small cursor in the top left hand corner that the user can't do anything with?

In case 1, it's likely a hardware issue.
In case 2, more likely a software issue.

In relation to software, the AMD card needs to have the firmware package:
This package contains the firmware and microcode for AMD graphics. If it's not installed, install it and reboot.

You can install it from the command line without a GUI. A way to do that is to press: cntl+alt+F2, (any of F2, F3, F4 should be good) to take you to a virtual console where you can log in and install the package, as root user, with the apt command.
apt install firmware-amd-graphics

If by chance it's already installed, and the problem persists, I wonder about the "DP to VGA" adapter. They can be the source of trouble. I've had low quality ones that did not work in linux.

As for the 75Hz refresh rate, that can be set with the xrandr command.
I tend to think that it is software related as he says it works with windows.
So try what @osprey has said first.
Thanks to every one, I tried to install debian 11, and it works normally. Idk why deb 12 causing this problem.
Do you have an old computer? If so, maybe the kernel that comes with Debian 12 is too new for it.

Ryzen 3 2200GE

Never mind . . . the Ryzen 3 2200GE was released in 2018, so that shouldn't be too old.

Staff online

Members online