Need Help: Nvidia video drivers not working

Jake Harris

New Member
Credits
27
I am extremely new to Linux and I am having trouble with video drivers. I am using Linux Mint. When I first started up Linux I went through the welcome page that opens and got the drivers provided through the driver manager. They worked for things outside of playing games such as rendering videos on youtube but, when I tried going into a game, there was clearly something wrong with the performance. I looked around online and found out how to get the latest drivers using PPA.
I put into the terminal: "sudo add-apt-repository ppa:graphics-drivers/ppa"
then: "sudo apt-get update"
then: "sudo apt-get install nvidia-" (I pressed tab for this in order to bring up a list of new Nvidia drivers.)
Finally: "sudo apt-get install nvidia-###" (Instead of "###" it was the number for the most recent drivers, I can't remember the what the numbers were.)

Everything seemed to work from the terminal. There were no errors, and everything seemed to be working as it should. I rebooted the PC for changes to take effect but that made it so that my computer went back to having no video driver, or at least seeming like there is no driver. Before, my monitor was running at full resolution, but after rebooting it now runs at the signature low resolution that indicates something is wrong with the video drivers. Whenever I reboot the PC I get a message in the top right corner once Linux loads saying that I have no video drivers installed. When I open driver manager it is blank saying "no proprietary drivers are in use" on the bottom left and the "revert" and "apply changes" buttons are grayed out and unusable. I have also noticed that when I reboot my PC I get a message saying:
"nvidia-gpu 0000:06:00.3: i2c timeout error e0000000"
"ucsi_ccg 0-0008: i2c_transfer failed -110"
"usci_ccg 0-0008: usci_ccg_init failed - -110"
My GPU is a GTX 1660 ti and my CPU is a ryzen 2600
This is the article I followed to try and download the most recent drivers using PPA: https://www.howtogeek.com/242045/ho...idia-amd-or-intel-graphics-drivers-on-ubuntu/
 


f33dm3bits

Gold Member
Gold Supporter
Credits
5,924
Which nvidia driver version do you currently have installed that isn't working? Can you open a terminal and show the output of: dpkg --list | grep nvidia
 

Jared.

Member
Credits
337
The article you have linked was three years old. The nvidia drivers can be grouped into three main categories. The first being the latest linux grahics drivers which I believe are at version 450. The second being version 390 which are legacy drivers for newer cards. Then version 340 or 304 for legacy drivers for older nvidia graphics cards. Since you have a GTX 1660Ti, you cannot use any the graphic drivers with versions 390, 340 or 304. Just to be 100% certain, did you install the graphics driver version 450? Do as what the previous commenter suggested to check )n the version you have installed onto your system.

If I may go off topic for a moment but if we are unable to solve your problem, you could always go to PopOS as it has nvidia's proprietary drivers preinstalled in one of their isos.
 



Latest posts

Top