Need help getting Conky to correctly display my Vcore [SOLVED]



Solved by omitting the -u switch on the sendors command, then just used grep and cut to get the value I needed like that. Worked like a charm!


${execi 2 sensors -u | grep -w 'in1_input' | cut -c 14-32} vDC
${execi 2 sensors | grep -w 'Vcore' | cut -c 28-32} vDC
Hello all!

Been a while since I've posted but I am having an issue with Conky. I am putting together a widget for my system which has an Asus TUF Gaming B560M-Plus Wifi for a motherboard. The hwinfo chip on it that I am trying to get info from is a Nuvoton nct6798D-isa-290..

In Conky, I am retrieving the voltage readings I want by using commands like this...

${execi 2 sensors -u | grep -w 'in1_input' | cut -c 14-32} vDC
... which results in the reading I am looking for (in this case, the 3.3v rail)...

However, if I try this with in0_input, which as far as I can tell is the Vcore input reference voltage, it gives me two values.. looks something like this:
Core Voltage: 1.152
0.950 vDC
Also, when I try to edit the 'cut' statement, to lets say, 3 characters (via cut -c 14-16), it cuts both values simultaneously like this:
Core Voltage: 1.1
0.9 vDC
So it's like both values are associated with in0_input. For the heck of it, I did this command from a terminal prompt and I get this...
~$ sensors -u | grep -w 'in0_input'|cut -c 14-32
ERROR: Can't get value of subfeature temp1_input: Can't read
I've never seen this happen with any other chips on the other motherboards I have used in systems..

SO....Can anyone tell me A) know what's going on with this, and B) point me in the right direction to make conky only show the first value which (I *think*) is the core voltage?

Many many thanks in advance!
Last edited:
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Staff online

Members online