N/A Mediatek MTK7921K WiFi card driver - Ubuntu 21.10

samdporter

New Member
Joined
Jan 28, 2022
Messages
14
Reaction score
1
Credits
93
Hi,

Running Ubuntu 21.10 with kernel 5.15

The system can't find the driver for my Mediatek M7921K graphics card

1643383372975.png


Based on the advice from other threads, I have:

Disabled secure boot

Checked that I have all the firmware in /lib/firmware/mediatek/
BT_RAM_CODE_MT7961_1_2_hdr.bin
WIFI_MT7961_patch_mcu_1_2_hdr.bin
WIFI_RAM_CODE_MT7961_1.bin

Does anyone have any ideas? I'm a bit stuck

Thanks for any help
 


kc1di

Well-Known Member
Joined
May 14, 2021
Messages
1,044
Reaction score
884
Credits
7,436
Please go to a terminal and copy and paste this command and let up see the results.
Code:
lspci -nnk | grep -iA3 net; mokutil --sb-state
Also let us see the output of

Code:
inxi -Fxxz
 

Brickwizard

Well-Known Member
Joined
Apr 28, 2021
Messages
2,674
Reaction score
1,769
Credits
20,010
As far as I am aware the drivers were added to the 15.4 kernel and higher, try menu, all applications, and find the driver manager/additional drivers, open and let it run to see if it can find them itself[ best done with a hard-wired connection to the router]

MediaTek normally use realtek chipsets
 
OP
S

samdporter

New Member
Joined
Jan 28, 2022
Messages
14
Reaction score
1
Credits
93
Please go to a terminal and copy and paste this command and let up see the results.
Code:
lspci -nnk | grep -iA3 net; mokutil --sb-state
Also let us see the output of

Code:
inxi -Fxxz
Code:
[email protected]:~$ lspci -nnk | grep -iA3 net; mokutil --sb-state
05:00.0 Network controller [0280]: MEDIATEK Corp. Device [14c3:0608]
    Subsystem: MEDIATEK Corp. Device [14c3:0608]
06:00.0 Ethernet controller [0200]: Intel Corporation Ethernet Controller I225-V [8086:15f3] (rev 01)
    Subsystem: Gigabyte Technology Co., Ltd Ethernet Controller I225-V [1458:e000]
    Kernel driver in use: igc
    Kernel modules: igc
07:00.0 Non-Essential Instrumentation [1300]: Advanced Micro Devices, Inc. [AMD] Starship/Matisse Reserved SPP [1022:1485]
SecureBoot disabled
Platform is in Setup Mode


Code:
[email protected]:~$ inxi -Fxxz
System:
  Kernel: 5.15.0-051500-generic x86_64 bits: 64 compiler: gcc v: 11.2.0
  Desktop: GNOME 40.5 tk: GTK 3.24.30 wm: gnome-shell dm: GDM3
  Distro: Ubuntu 21.10 (Impish Indri)
Machine:
  Type: Desktop System: Gigabyte product: X570S AORUS PRO AX v: -CF
  serial: <filter>
  Mobo: Gigabyte model: X570S AORUS PRO AX serial: <filter>
  UEFI: American Megatrends LLC. v: F3d PI date: 10/15/2021
CPU:
  Info: 8-Core model: AMD Ryzen 7 5700G with Radeon Graphics bits: 64
  type: MT MCP arch: Zen 3 rev: 0 cache: L2: 4 MiB
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  bogomips: 121377
  Speed: 2994 MHz min/max: 1400/3800 MHz boost: enabled Core speeds (MHz):
  1: 2994 2: 2406 3: 2395 4: 2395 5: 2994 6: 2394 7: 2395 8: 2396 9: 2394
  10: 2395 11: 1987 12: 1397 13: 2255 14: 1397 15: 1397 16: 1396
Network:
  Device-1: MEDIATEK driver: N/A port: f000 bus-ID: 05:00.0
  chip-ID: 14c3:0608
  Device-2: Intel Ethernet I225-V vendor: Gigabyte driver: igc v: kernel
  port: f000 bus-ID: 06:00.0 chip-ID: 8086:15f3
  IF: enp6s0 state: down mac: <filter>
  IF-ID-1: docker0 state: down mac: <filter>
  IF-ID-2: usb0 state: unknown speed: -1 duplex: half mac: <filter>
 
Last edited:
OP
S

samdporter

New Member
Joined
Jan 28, 2022
Messages
14
Reaction score
1
Credits
93
As far as I am aware the drivers were added to the 15.4 kernel and higher, try menu, all applications, and find the driver manager/additional drivers, open and let it run to see if it can find them itself[ best done with a hard-wired connection to the router]

MediaTek normally use realtek chipsets
"No additional drivers available"
 

Lord Boltar

Well-Known Member
Joined
Nov 24, 2020
Messages
1,772
Reaction score
1,184
Credits
13,201
you could try my Expirion Linux LXQt-CE version it is running Ubuntu mainline kernel 5.16.3 - it is based on Ubuntu 22.04 Developmental available here - https://sourceforge.net/projects/expirion-linux/files/ and click on Expirion-LXQt-CE-20220128.iso to download

See if it detects it from the Live USB
 
OP
S

samdporter

New Member
Joined
Jan 28, 2022
Messages
14
Reaction score
1
Credits
93
you could try my Expirion Linux LXQt-CE version it is running Ubuntu mainline kernel 5.16.3 - it is based on Ubuntu 22.04 Developmental available here - https://sourceforge.net/projects/expirion-linux/files/ and click on Expirion-LXQt-CE-20220128.iso to download

See if it detects it from the Live USB
I tried this as a live user, but there's still no available driver according to
Code:
~$ inxi -Fxxz
. There are no additional drivers available in Software and Updates
 

kc1di

Well-Known Member
Joined
May 14, 2021
Messages
1,044
Reaction score
884
Credits
7,436
Ok Make sure secure boot is turned off and you are connected via Ethernet cable to the internet. The Do the following in the terminal:

Code:
sudo apt install build-essential flex bison
wget https://gitlab.com/jeremy53561/backports-11-26/-/raw/main/backports-5.15-rc6-1.tar.gz
tar -xvf backports-5.15-rc6-1.tar.gz
cd backports-5.15-rc6-1
make clean
make defconfig-wifi
make
sudo make install
cd /lib/firmware/mediatek
sudo wget https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git/plain/mediatek/WIFI_MT7961_patch_mcu_1_2_hdr.bin
sudo wget https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git/plain/mediatek/WIFI_RAM_CODE_MT7961_1.bin
Copy and paste one line at a time then hit enter. If all finishes correctly reboot Wifi should be working.
If that does not work would say you need to find a different wifi card. Good luck.
 
OP
S

samdporter

New Member
Joined
Jan 28, 2022
Messages
14
Reaction score
1
Credits
93
Ok Make sure secure boot is turned off and you are connected via Ethernet cable to the internet. The Do the following in the terminal:

Code:
sudo apt install build-essential flex bison
wget https://gitlab.com/jeremy53561/backports-11-26/-/raw/main/backports-5.15-rc6-1.tar.gz
tar -xvf backports-5.15-rc6-1.tar.gz
cd backports-5.15-rc6-1
make clean
make defconfig-wifi
make
sudo make install
cd /lib/firmware/mediatek
sudo wget https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git/plain/mediatek/WIFI_MT7961_patch_mcu_1_2_hdr.bin
sudo wget https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git/plain/mediatek/WIFI_RAM_CODE_MT7961_1.bin
Copy and paste one line at a time then hit enter. If all finishes correctly reboot Wifi should be working.
If that does not work would say you need to find a different wifi card. Good luck.
WiFi still not working, unfortunately.

FYI when this line is reached
Code:
cd backports-5.15-rc6-1
there's no directory with this name.
 

kc1di

Well-Known Member
Joined
May 14, 2021
Messages
1,044
Reaction score
884
Credits
7,436
WiFi still not working, unfortunately.

FYI when this line is reached
Code:
cd backports-5.15-rc6-1
there's no directory with this name.
Try dropping the -rc6-1 see if it works.
 

Lord Boltar

Well-Known Member
Joined
Nov 24, 2020
Messages
1,772
Reaction score
1,184
Credits
13,201
Code:
[email protected]:~$ iwconfig
lo        no wireless extensions.

enp6s0    no wireless extensions.

docker0   no wireless extensions.

usb0      no wireless extensions.
Try
Code:
sudo ifconfig enp6s0 up
Code:
sudo iwconfig enp6s0 power off
Code:
sudo iwconfig enp6s0 txpower 18
 
OP
S

samdporter

New Member
Joined
Jan 28, 2022
Messages
14
Reaction score
1
Credits
93
UPDATE:
I left my PC to run some things overnight.
There had been a generator test that I wasn't aware of and so when I came in my PC was off. I booted it up and the WiFi was working.
I'm not sure what worked, but something did!

Thanks so much for your help!
 

kc1di

Well-Known Member
Joined
May 14, 2021
Messages
1,044
Reaction score
884
Credits
7,436
Glad you got it going , enjoy! :)
 
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Linux.org Hosting Donations
Consider making a donation

Members online


Top