• Rob's side project: I recently started Gun-Forums.com and we currently have a $100 raffle - if you're into guns, join up and enter the raffle to win $100.00. Gun Forums

My Mint 18.3 installation is now a GRUB Prompt!

Johann

New Member
My wife donated her old Mint 18.3 system to me, so I could use it as a MUD server. Since it had multiple user accounts on it I didn't need, I set out to re-install Mint 18.3, so the computer could start the second half of its life with a fresh installation of Mint.

The installation appeared to go normally. I got to the "Remove the installation media and press Enter" and did so ... and got a GRUB prompt.

I want there to be only one OS on this computer, the new copy of Mint 18.3. During installation, when it said "There is already an OS on this computer", I specifically chose "Write over it" and NOT "Install Mint alongside exiting OS"

I have played with Boot Order, made sure the HD is the first in the boot order and not the USB stick I did the installation from. Same result - GRUB prompt at restart.

I have tried it with Secure Boot turned off, then did an entire re-installation with Secure Boot turned off. Same result - GRUB prompt at reboot.

I've installed Mint 17, 18, and 19 multiple times on three or four systems, and never had any problem. I certainly botched this one!

Can anyone point me at a good resource for combating GRUB errors? I Googled some, but mostly found "How to install GRUB"
 


Johann

New Member
grub> startx

the computer's reply is, "error: can't find command 'startx'

FWIW, The system starts up very quickly - it doesn't step through loading Linux at all, it just immediately comes on with "GNU Grub version <ver no> ", then "Minimal BASH-like line editing is supported ...", then grub>
 

Johann

New Member
Rut Roh! I must confess that the cause of this was the dreaded .... user error!

I forgot the computer had two drives. I was installing to the secondary drive.

Once I installed to the primary drive, it worked fine.

Thank you for your help, arochester!
 


Members online


Top