My computer went slow suddenly, I suspect it is my hard disk

astrale

New Member
Credits
0
Hey, i run the last version of linux mint, and suddenly my performance dropped
my shells take some time to boot, firefox takes muchh more ram than before, pdf takes time to show up, the experience is not very smooth

i suspect its my hard disk that is slower than usual, but i have no idea if its because it is old or if i can do something about it

I have an SSD with everything except /home and my harddisk with /home on it, I suspect this is the latter that has become slow


Any idea or advise are warmly welcome, i put some system information below, let me now if you need more:
for a GNU dawn!




- i vaguely remember simplescreenrecorder disabled an option of my Nvidia card but i dont think thats the problem

#-----------------------------------#
~$ sudo hdparm -Tt /dev/sda
[sudo] Mot de passe de astrale :

/dev/sda:
Timing cached reads: 6840 MB in 1.99 seconds = 3436.09 MB/sec
Timing buffered disk reads: 346 MB in 3.01 seconds = 114.80 MB/sec

#-----------------------------------#

$ dd if=/dev/zero of=/tmp/output bs=8k count=10k; rm -f /tmp/output
10240+0 enregistrements lus
10240+0 enregistrements écrits
83886080 bytes (84 MB, 80 MiB) copied, 0,11678 s, 718 MB/s

#-----------------------------------#

EDIT 0 in response of[B] sp331yi :[/B]
#-----------------------------------#
$ inxi
CPU: Dual Core Intel Core i3-2330M (-MT MCP-)
speed/min/max: 798/800/2200 MHz Kernel: 5.3.0-46-generic x86_64 Up: 9h 54m
Mem: 1446.9/3844.7 MiB (37.6%) Storage: 1.02 TiB (50.9% used) Procs: 228
Shell: bash 4.4.20 inxi: 3.0.32
#-----------------------------------#
$ inxi -D
Drives:
Local Storage: total: 1.02 TiB used: 531.25 GiB (50.9%)
ID-1: /dev/sda vendor: Seagate model: ST31000524AS size: 931.51 GiB
ID-2: /dev/sdb model: SATA SSD size: 111.79 GiB
#-----------------------------------#
EDIT 2 : trying fsck
Okay, i logined as root, and didnt know where to put the output of fsck -nc /dev/sda1 and fsck.ext4 /dev/sda1 (in fact i put it in /tmp but it got removed when i exited rootsession or entered my session
but it was a very short output saying the filesystem looked okay, im gonna try again :
ok i tried again but same thing, it did say that the filesystem seems correct and i cant get it to print to a file
#------------------------------------------------------#
EDIT 3 : smartmontools

$ sudo smartctl --health /dev/sda
smartctl 6.6 2016-05-31 r4324 [x86_64-linux-5.3.0-46-generic] (local build)
Copyright (C) 2002-16, Bruce Allen, Christian Franke, www.smartmontools.org

=== START OF READ SMART DATA SECTION ===
SMART overall-health self-assessment test result: PASSED
#------------------------------------------------------#
$ sudo smartctl --health /dev/sda1
smartctl 6.6 2016-05-31 r4324 [x86_64-linux-5.3.0-46-generic] (local build)
Copyright (C) 2002-16, Bruce Allen, Christian Franke, www.smartmontools.org

=== START OF READ SMART DATA SECTION ===
SMART overall-health self-assessment test result: PASSED
#------------------------------------------------------#
$ sudo smartctl --all /dev/sda1
smartctl 6.6 2016-05-31 r4324 [x86_64-linux-5.3.0-46-generic] (local build)
Copyright (C) 2002-16, Bruce Allen, Christian Franke, www.smartmontools.org

=== START OF INFORMATION SECTION ===
Model Family: Seagate Barracuda 7200.12
Device Model: ST31000524AS
Serial Number: 9VPF0LF8
LU WWN Device Id: 5 000c50 03fab141d
Firmware Version: JC45
User Capacity: 1 000 204 886 016 bytes [1,00 TB]
Sector Size: 512 bytes logical/physical
Rotation Rate: 7200 rpm
Device is: In smartctl database [for details use: -P show]
ATA Version is: ATA8-ACS T13/1699-D revision 4
SATA Version is: SATA 3.0, 6.0 Gb/s (current: 3.0 Gb/s)
Local Time is: Sat Apr 18 21:25:56 2020 CEST
SMART support is: Available - device has SMART capability.
SMART support is: Enabled

=== START OF READ SMART DATA SECTION ===
SMART overall-health self-assessment test result: PASSED

General SMART Values:
Offline data collection status: (0x82) Offline data collection activity
was completed without error.
Auto Offline Data Collection: Enabled.
Self-test execution status: ( 0) The previous self-test routine completed
without error or no self-test has ever
been run.
Total time to complete Offline
data collection: ( 609) seconds.
Offline data collection
capabilities: (0x7b) SMART execute Offline immediate.
Auto Offline data collection on/off support.
Suspend Offline collection upon new
command.
Offline surface scan supported.
Self-test supported.
Conveyance Self-test supported.
Selective Self-test supported.
SMART capabilities: (0x0003) Saves SMART data before entering
power-saving mode.
Supports SMART auto save timer.
Error logging capability: (0x01) Error logging supported.
General Purpose Logging supported.
Short self-test routine
recommended polling time: ( 1) minutes.
Extended self-test routine
recommended polling time: ( 177) minutes.
Conveyance self-test routine
recommended polling time: ( 2) minutes.
SCT capabilities: (0x103f) SCT Status supported.
SCT Error Recovery Control supported.
SCT Feature Control supported.
SCT Data Table supported.

SMART Attributes Data Structure revision number: 10
Vendor Specific SMART Attributes with Thresholds:
ID# ATTRIBUTE_NAME FLAG VALUE WORST THRESH TYPE UPDATED WHEN_FAILED RAW_VALUE
1 Raw_Read_Error_Rate 0x000f 119 099 006 Pre-fail Always - 227952960
3 Spin_Up_Time 0x0003 100 100 000 Pre-fail Always - 0
4 Start_Stop_Count 0x0032 093 093 020 Old_age Always - 7477
5 Reallocated_Sector_Ct 0x0033 100 100 036 Pre-fail Always - 0
7 Seek_Error_Rate 0x000f 084 060 030 Pre-fail Always - 275967955
9 Power_On_Hours 0x0032 088 088 000 Old_age Always - 10738
10 Spin_Retry_Count 0x0013 100 100 097 Pre-fail Always - 0
12 Power_Cycle_Count 0x0032 093 093 020 Old_age Always - 7245
183 Runtime_Bad_Block 0x0032 100 100 000 Old_age Always - 0
184 End-to-End_Error 0x0032 100 100 099 Old_age Always - 0
187 Reported_Uncorrect 0x0032 100 100 000 Old_age Always - 0
188 Command_Timeout 0x0032 100 100 000 Old_age Always - 1
189 High_Fly_Writes 0x003a 100 100 000 Old_age Always - 0
190 Airflow_Temperature_Cel 0x0022 062 052 045 Old_age Always - 38 (Min/Max 21/38)
194 Temperature_Celsius 0x0022 038 048 000 Old_age Always - 38 (0 11 0 0 0)
195 Hardware_ECC_Recovered 0x001a 035 024 000 Old_age Always - 227952960
197 Current_Pending_Sector 0x0012 100 100 000 Old_age Always - 0
198 Offline_Uncorrectable 0x0010 100 100 000 Old_age Offline - 0
199 UDMA_CRC_Error_Count 0x003e 200 200 000 Old_age Always - 0
240 Head_Flying_Hours 0x0000 100 253 000 Old_age Offline - 28634 (192 181 0)
241 Total_LBAs_Written 0x0000 100 253 000 Old_age Offline - 2152323875
242 Total_LBAs_Read 0x0000 100 253 000 Old_age Offline - 1794466797

SMART Error Log Version: 1
No Errors Logged

SMART Self-test log structure revision number 1
No self-tests have been logged. [To run self-tests, use: smartctl -t]

SMART Selective self-test log data structure revision number 1
SPAN MIN_LBA MAX_LBA CURRENT_TEST_STATUS
1 0 0 Not_testing
2 0 0 Not_testing
3 0 0 Not_testing
4 0 0 Not_testing
5 0 0 Not_testing
Selective self-test flags (0x0):
After scanning selected spans, do NOT read-scan remainder of disk.
If Selective self-test is pending on power-up, resume after 0 minute delay.
#----------------------------------------------------------#

well, no clue and still pretty slow.. Any clues?
 
Last edited:


sp331yi

Active Member
Credits
1,057
Hello astrale,
Suggest unmounting the hard drive in question (following example, where X is the drive designation)

umount /dev/sdX

Then doing an fsck on it --

fsck /dev/sdX

Also, it's a good idea to clarify one's hardware when asking advice on a forum; one method of making clear one's hardware is to use a program called inxi
Take a look at it.

Try the fsck then get back to this forum, adding some more hardware information to clarify, please.
 

sp331yi

Active Member
Credits
1,057
Another hardware tweak to get CPU up to speed, courtesy of JeZ-l-Lee post in Mint

sudo apt-get install cpufrequtils
(already installed on LM18.2)​
sudo nano /etc/default/cpufrequtils
(ADD: GOVERNOR="performance")​
sudo update-rc.d ondemand disable
Your CPU is, in my estimation, marginal for accessing a 1TB 7200RPM spinner HDD. Hence the suggestion.

BTW nano is a text editor to edit the file cpufrequtils. I use mcedit (mdnight commander) and there are many others, beginning with vi -- in case of confusion.

Also, Mint is a bloated distro IMHO. So, it's gonna be slower than a distro with a simple Windows Manager versus a full-blown Desktop Environment.

If this does not help, come back. I may not be here, but someone will continue to help if necessary.
 
Last edited:

astrale

New Member
Credits
0
Okay, thanks a lot for the suggestion

the output suggest it didnt work cause of risk of instability, should i force it? ps I rather have a slow pc thatn no pc ;)

#--------------------------------------------------------------------#
$ sudo update-rc.d ondemand disable
usage: update-rc.d [-f] <basename> remove
update-rc.d [-f] <basename> defaults
update-rc.d [-f] <basename> defaults-disabled
update-rc.d <basename> disable|enable [S|2|3|4|5]
-f: force

The disable|enable API is not stable and might change in the future.
#--------------------------------------------------------------------#
 

Alexzee

Well-Known Member
Credits
1,066


Members online


Latest posts

Top