Move non-Raid disk to a server with hardware RAID (HP)

hgoles

New Member
Credits
0
I have a disk with data on it used on a Supermicro server which has no RAID controller, I've put it into an HP server, and I can see the disk and it's containing data but while I'm trying to mount it this errors happen:

Code:
mount: wrong fs type, bad option, bad superblock on /dev/sda1,
       missing codepage or helper program, or other error

       In some cases useful info is found in syslog - try
       dmesg | tail or so.
And using fsck /dev/sda1 leads to an other error indicating the physical disk size is 8KB short:

Code:
e2fsck 1.42.13 (17-May-2015)
The filesystem size (according to the superblock) is 244190390 blocks
The physical size of the device is 244182198 blocks
Either the superblock or the partition table is likely to be corrupt!


It's the output of `hpacucli ctrl all show config detail`

Code:
Smart Array P420i in Slot 0 (Embedded)
   Bus Interface: PCI
   Slot: 0
   Serial Number: 0014380350DA6C0
   Cache Serial Number: PBKUA0BRH8M91T
   RAID 6 (ADG) Status: Enabled
   Controller Status: OK
   Hardware Revision: B
   Firmware Version: 8.00
   Rebuild Priority: Medium
   Expand Priority: Medium
   Surface Scan Delay: 15 secs
   Surface Scan Mode: Idle
   Queue Depth: Automatic
   Monitor and Performance Delay: 60  min
   Elevator Sort: Enabled
   Degraded Performance Optimization: Disabled
   Inconsistency Repair Policy: Disabled
   Wait for Cache Room: Disabled
   Surface Analysis Inconsistency Notification: Disabled
   Post Prompt Timeout: 0 secs
   Cache Board Present: True
   Cache Status: OK
   Cache Ratio: 25% Read / 75% Write
   Drive Write Cache: Disabled
   Total Cache Size: 512 MB
   Total Cache Memory Available: 304 MB
   No-Battery Write Cache: Disabled
   Cache Backup Power Source: Capacitors
   Battery/Capacitor Count: 1
   Battery/Capacitor Status: OK
   SATA NCQ Supported: True
   Spare Activation Mode: Activate on drive failure
   Controller Temperature (C): 80
   Cache Module Temperature (C): 41
   Capacitor Temperature  (C): 33

   Array: A
      Interface Type: SATA
      Unused Space: 0  MB
      Status: OK
      Array Type: Data



      Logical Drive: 1
         Size: 931.5 GB
         Fault Tolerance: 0
         Heads: 255
         Sectors Per Track: 32
         Cylinders: 65535
         Strip Size: 256 KB
         Full Stripe Size: 256 KB
         Status: OK
         Caching:  Enabled
         Unique Identifier: 600508B1001CEA10DE41CCBBC5381E77
         Disk Name: /dev/sda
         Mount Points: None
         Logical Drive Label: AE60E98C0014380350DA6C0CF0F
         Drive Type: Data

      physicaldrive 1I:1:12
         Port: 1I
         Box: 1
         Bay: 12
         Status: OK
         Drive Type: Data Drive
         Interface Type: SATA
         Size: 1 TB
         Rotational Speed: 7200
         Firmware Revision: CC43
         Serial Number:             Z9A2441W
         Model: ATA     ST1000DM003-1SB1
         SATA NCQ Capable: True
         SATA NCQ Enabled: True
         Current Temperature (C): 38
         Maximum Temperature (C): 38
         PHY Count: 1
         PHY Transfer Rate: 6.0Gbps
         Drive Authentication Status: OK
         Carrier Application Version: 11
         Carrier Bootloader Version: 6



   Enclosure SEP (Vendor ID HP, Model Gen8 ServBP 12+2) 378
      Device Number: 378
      Firmware Version: 3.30
      WWID: 50014380355F89B9
      Port: 1I
      Box: 1
      Vendor ID: HP
      Model: Gen8 ServBP 12+2

   Expander 380
      Device Number: 380
      Firmware Version: 3.30
      WWID: 50014380355F89A0
      Port: 1I
      Box: 1
      Vendor ID: HP

   SEP (Vendor ID PMCSIERA, Model SRCv8x6G) 379
      Device Number: 379
      Firmware Version: RevB
      WWID: 50014380350DA6CF
      Vendor ID: PMCSIERA
      Model: SRCv8x6G


Any idea on how to fix this issue? maybe changing a parameter on raid array?
 
Last edited:


Members online


Top