Mouse(Touchpad) does not work in X (Solved)

Amirk

New Member
Credits
150
dmesg|grep input output:
[ 0.361101] input: Power Button as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/device:03/PNP0C09:01/PNP0C0C:00/input/input0
[ 0.361280] input: Lid Switch as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/device:03/PNP0C09:01/PNP0C0D:01/input/input1
[ 0.361454] input: Sleep Button as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0E:00/input/input2
[ 0.361618] input: Power Button as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0C:01/input/input3
[ 0.406123] input: Video Bus as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/LNXVIDEO:00/input/input4
[ 0.435785] input: AT Translated Set 2 keyboard as /devices/platform/i8042/serio0/input/input5
[ 0.970109] input: ELAN1201:00 04F3:3054 Mouse as /devices/pci0000:00/0000:00:17.0/i2c_designware.0/i2c-5/i2c-ELAN1201:00/0018:04F3:3054.0001/input/input6
[ 0.970465] input: ELAN1201:00 04F3:3054 Touchpad as /devices/pci0000:00/0000:00:17.0/i2c_designware.0/i2c-5/i2c-ELAN1201:00/0018:04F3:3054.0001/input/input7
[ 0.970812] hid-generic 0018:04F3:3054.0001: input,hidraw0: I2C HID v1.00 Mouse [ELAN1201:00 04F3:3054] on i2c-ELAN1201:00
/var/log/Xorg.0.log:
[ 56.157]
X.Org X Server 1.20.11
X Protocol Version 11, Revision 0
[ 56.173] Build Operating System: Linux 5.8.0-59-generic x86_64
[ 56.179] Current Operating System: Linux PC 5.10.27-gentoo #3 SMP Tue May 4 22:37:17 MSK 2021 x86_64
[ 56.179] Kernel command line: BOOT_IMAGE=/vmlinuz-5.10.27-gentoo root=/dev/mmcblk0p2 ro
[ 56.190] Build Date: 08 July 2021 11:59:39AM
[ 56.195]
[ 56.201] Current version of pixman: 0.40.0
[ 56.211] Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
[ 56.212] Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[ 56.235] (==) Log file: "/var/log/Xorg.0.log", Time: Thu Jul 8 09:47:04 2021
[ 56.266] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[ 56.268] (==) No Layout section. Using the first Screen section.
[ 56.268] (==) No screen section available. Using defaults.
[ 56.268] (**) |-->Screen "Default Screen Section" (0)
[ 56.268] (**) | |-->Monitor "<default monitor>"
[ 56.269] (==) No monitor specified for screen "Default Screen Section".
Using a default monitor configuration.
[ 56.269] (==) Not automatically adding devices
[ 56.269] (==) Not automatically enabling devices
[ 56.269] (==) Not automatically adding GPU devices
[ 56.269] (==) Max clients allowed: 256, resource mask: 0x1fffff
[ 56.271] (WW) The directory "/usr/share/fonts/X11//TTF/" does not exist.
[ 56.271] Entry deleted from font path.
[ 56.271] (WW) The directory "/usr/share/fonts/X11//OTF/" does not exist.
[ 56.271] Entry deleted from font path.
[ 56.271] (WW) The directory "/usr/share/fonts/X11//Type1/" does not exist.
[ 56.271] Entry deleted from font path.
[ 56.272] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/X11//100dpi/".
[ 56.272] Entry deleted from font path.
[ 56.272] (Run 'mkfontdir' on "/usr/share/fonts/X11//100dpi/").
[ 56.272] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/X11//75dpi/".
[ 56.272] Entry deleted from font path.
[ 56.272] (Run 'mkfontdir' on "/usr/share/fonts/X11//75dpi/").
[ 56.272] (==) FontPath set to:
/usr/share/fonts/X11//misc/
[ 56.272] (==) ModulePath set to "/usr/lib/xorg/modules"
[ 56.272] (==) |-->Input Device "<default pointer>"
[ 56.272] (==) |-->Input Device "<default keyboard>"
[ 56.272] (==) No Layout section. Using the default mouse configuration.
[ 56.272] (==) No Layout section. Using the default keyboard configuration.
[ 56.272] (II) Loader magic: 0x600a20
[ 56.272] (II) Module ABI versions:
[ 56.272] X.Org ANSI C Emulation: 0.4
[ 56.272] X.Org Video Driver: 24.1
[ 56.272] X.Org XInput driver : 24.1
[ 56.272] X.Org Server Extension : 10.0
[ 56.277] (--) PCI:*([email protected]:2:0) 8086:3185:1043:11f1 rev 3, Mem @ 0xa0000000/16777216, 0x90000000/268435456, I/O @ 0x0000f000/64, BIOS @ 0x????????/131072
[ 56.277] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
[ 56.277] (==) Matched intel as autoconfigured driver 0
[ 56.277] (==) Matched modesetting as autoconfigured driver 1
[ 56.277] (==) Matched fbdev as autoconfigured driver 2
[ 56.277] (==) Matched vesa as autoconfigured driver 3
[ 56.277] (==) Assigned the driver to the xf86ConfigLayout
[ 56.278] (II) LoadModule: "intel"
[ 56.279] (II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so
[ 56.283] (II) Module intel: vendor="X.Org Foundation"
[ 56.283] compiled for 1.20.11, module version = 2.99.917
[ 56.283] Module class: X.Org Video Driver
[ 56.283] ABI class: X.Org Video Driver, version 24.1
[ 56.283] (II) LoadModule: "modesetting"
[ 56.283] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[ 56.284] (II) Module modesetting: vendor="X.Org Foundation"
[ 56.284] compiled for 1.20.11, module version = 1.20.11
[ 56.284] Module class: X.Org Video Driver
[ 56.284] ABI class: X.Org Video Driver, version 24.1
[ 56.284] (II) LoadModule: "fbdev"
[ 56.285] (WW) Warning, couldn't open module fbdev
[ 56.285] (EE) Failed to load module "fbdev" (module does not exist, 0)
[ 56.285] (II) LoadModule: "vesa"
[ 56.285] (WW) Warning, couldn't open module vesa
[ 56.285] (EE) Failed to load module "vesa" (module does not exist, 0)
[ 56.285] (II) LoadModule: "mouse"
[ 56.286] (II) Loading /usr/lib/xorg/modules/input/mouse_drv.so
[ 56.286] (II) Module mouse: vendor="X.Org Foundation"
[ 56.286] compiled for 1.20.11, module version = 1.9.3
[ 56.287] Module class: X.Org XInput Driver
[ 56.287] ABI class: X.Org XInput driver, version 24.1
[ 56.287] (II) LoadModule: "kbd"
[ 56.287] (II) Loading /usr/lib/xorg/modules/input/kbd_drv.so
[ 56.288] (II) Module kbd: vendor="X.Org Foundation"
[ 56.288] compiled for 1.20.11, module version = 1.9.0
[ 56.288] Module class: X.Org XInput Driver
[ 56.288] ABI class: X.Org XInput driver, version 24.1
[ 56.288] (II) intel: Driver for Intel(R) Integrated Graphics Chipsets:
i810, i810-dc100, i810e, i815, i830M, 845G, 854, 852GM/855GM, 865G,
915G, E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM,
Pineview G, 965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33,
GM45, 4 Series, G45/G43, Q45/Q43, G41, B43
[ 56.289] (II) intel: Driver for Intel(R) HD Graphics
[ 56.289] (II) intel: Driver for Intel(R) Iris(TM) Graphics
[ 56.289] (II) intel: Driver for Intel(R) Iris(TM) Pro Graphics
[ 56.289] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[ 56.289] (--) using VT number 2

[ 56.318] (II) intel(0): Using Kernel Mode Setting driver: i915, version 1.6.0 20200917
[ 56.331] (WW) Falling back to old probe method for modesetting
[ 56.333] (--) intel(0): gen9 engineering sample
[ 56.333] (--) intel(0): CPU: x86-64, sse2, sse3, ssse3, sse4.1, sse4.2; using a maximum of 2 threads
[ 56.333] (II) intel(0): Creating default Display subsection in Screen section
"Default Screen Section" for depth/fbbpp 24/32
[ 56.333] (==) intel(0): Depth 24, (--) framebuffer bpp 32
[ 56.333] (==) intel(0): RGB weight 888
[ 56.333] (==) intel(0): Default visual is TrueColor
[ 56.336] (II) intel(0): Output eDP1 has no monitor section
[ 56.336] (**) intel(0): Found backlight control interface intel_backlight (type 'raw') for output eDP1
[ 56.336] (II) intel(0): Enabled output eDP1
[ 56.337] (II) intel(0): Output HDMI1 has no monitor section
[ 56.337] (II) intel(0): Enabled output HDMI1
[ 56.337] (II) intel(0): Output DP1 has no monitor section
[ 56.338] (II) intel(0): Enabled output DP1
[ 56.338] (--) intel(0): Using a maximum size of 256x256 for hardware cursors
[ 56.338] (II) intel(0): Output VIRTUAL1 has no monitor section
[ 56.338] (II) intel(0): Enabled output VIRTUAL1
[ 56.338] (--) intel(0): Output eDP1 using initial mode 1366x768 on pipe 0
[ 56.338] (==) intel(0): TearFree disabled
[ 56.338] (==) intel(0): Using gamma correction (1.0, 1.0, 1.0)
[ 56.339] (==) intel(0): DPI set to (96, 96)
[ 56.339] (II) Loading sub module "dri3"
[ 56.339] (II) LoadModule: "dri3"
[ 56.339] (II) Module "dri3" already built-in
[ 56.339] (II) Loading sub module "dri2"
[ 56.339] (II) LoadModule: "dri2"
[ 56.339] (II) Module "dri2" already built-in
[ 56.339] (II) Loading sub module "present"
[ 56.339] (II) LoadModule: "present"
[ 56.339] (II) Module "present" already built-in
[ 56.339] (II) UnloadModule: "modesetting"
[ 56.339] (II) Unloading modesetting
[ 56.343] (II) intel(0): SNA initialized with Geminilake (gen9) backend
[ 56.343] (==) intel(0): Backing store disabled
[ 56.343] (==) intel(0): Silken mouse enabled
[ 56.343] (II) intel(0): HW Cursor enabled
[ 56.345] (==) intel(0): DPMS enabled
[ 56.345] (II) intel(0): [DRI2] Setup complete
[ 56.345] (II) intel(0): [DRI2] DRI driver: i965
[ 56.345] (II) intel(0): [DRI2] VDPAU driver: va_gl
[ 56.345] (II) intel(0): direct rendering: DRI2 enabled
[ 56.345] (II) intel(0): hardware support for Present enabled
[ 56.345] (II) Initializing extension Generic Event Extension
[ 56.345] (II) Initializing extension SHAPE
[ 56.345] (II) Initializing extension MIT-SHM
[ 56.345] (II) Initializing extension XInputExtension
[ 56.346] (II) Initializing extension XTEST
[ 56.346] (II) Initializing extension BIG-REQUESTS
[ 56.346] (II) Initializing extension SYNC
[ 56.346] (II) Initializing extension XKEYBOARD
[ 56.346] (II) Initializing extension XC-MISC
[ 56.346] (II) Initializing extension XFIXES
[ 56.346] (II) Initializing extension RENDER
[ 56.346] (II) Initializing extension RANDR
[ 56.346] (II) Initializing extension DAMAGE
[ 56.346] (II) Initializing extension DOUBLE-BUFFER
[ 56.346] (II) Initializing extension RECORD
[ 56.346] (II) Initializing extension DPMS
[ 56.346] (II) Initializing extension Present
[ 56.346] (II) Initializing extension DRI3
[ 56.347] (II) Initializing extension X-Resource
[ 56.347] (II) Initializing extension XVideo
[ 56.347] (II) Initializing extension XVideo-MotionCompensation
[ 56.347] (II) Initializing extension XFree86-VidModeExtension
[ 56.347] (II) Initializing extension XFree86-DGA
[ 56.347] (II) Initializing extension DRI2
[ 56.352] (II) intel(0): switch to mode [email protected] on eDP1 using pipe 0, position (0, 0), rotation normal, reflection none
[ 56.356] (II) intel(0): Setting screen physical size to 361 x 203
[ 56.463] (II) Using input driver 'mouse' for '<default pointer>'
[ 56.463] (**) Option "CorePointer" "on"
[ 56.463] (**) <default pointer>: always reports core events
[ 56.463] (WW) <default pointer>: No Device specified, looking for one...
[ 56.463] (EE) <default pointer>: Cannot find which device to use.
[ 56.463] (==) <default pointer>: Protocol: "Auto"
[ 56.463] (**) <default pointer>: always reports core events
[ 56.463] (EE) xf86OpenSerial: No Device specified.
[ 56.463] (EE) <default pointer>: cannot open input device
[ 56.463] (EE) PreInit returned 2 for "<default pointer>"
[ 56.463] (II) UnloadModule: "mouse"
[ 56.463] (II) Using input driver 'kbd' for '<default keyboard>'
[ 56.463] (**) Option "CoreKeyboard" "on"
[ 56.463] (**) <default keyboard>: always reports core events
[ 56.463] (**) <default keyboard>: always reports core events
[ 56.463] (**) Option "Protocol" "standard"
[ 56.463] (**) Option "XkbRules" "base"
[ 56.463] (**) Option "XkbModel" "pc105"
[ 56.463] (**) Option "XkbLayout" "us"
[ 56.463] (II) XINPUT: Adding extended input device "<default keyboard>" (type: KEYBOARD, id 6)
[ 58.346] (II) intel(0): EDID vendor "AUO", prod id 8796
[ 58.346] (II) intel(0): Printing DDC gathered Modelines:
[ 58.346] (II) intel(0): Modeline "1366x768"x0.0 76.30 1366 1404 1426 1592 768 771 777 798 -hsync -vsync (47.9 kHz eP)
[ 60.683] (II) UnloadModule: "kbd"
[ 60.696] (II) Server terminated successfully (0). Closing log file.
 
Last edited:


Tolkem

Well-Known Member
Credits
8,516
1. You didn't give any details about your problem; what is it exactly you're experiencing? Distro? Desktop environment? And no, that dmesg output is not enough.
2. Next time, try and use code tags for command line/terminal output, so it's easier to read, like this:
Code:
dmesg|grep input output:
[ 0.361101] input: Power Button as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/device:03/PNP0C09:01/PNP0C0C:00/input/input0
[ 0.361280] input: Lid Switch as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/device:03/PNP0C09:01/PNP0C0D:01/input/input1
[ 0.361454] input: Sleep Button as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0E:00/input/input2
[ 0.361618] input: Power Button as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0C:01/input/input3
[ 0.406123] input: Video Bus as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/LNXVIDEO:00/input/input4
[ 0.435785] input: AT Translated Set 2 keyboard as /devices/platform/i8042/serio0/input/input5
[ 0.970109] input: ELAN1201:00 04F3:3054 Mouse as /devices/pci0000:00/0000:00:17.0/i2c_designware.0/i2c-5/i2c-ELAN1201:00/0018:04F3:3054.0001/input/input6
[ 0.970465] input: ELAN1201:00 04F3:3054 Touchpad as /devices/pci0000:00/0000:00:17.0/i2c_designware.0/i2c-5/i2c-ELAN1201:00/0018:04F3:3054.0001/input/input7
[ 0.970812] hid-generic 0018:04F3:3054.0001: input,hidraw0: I2C HID v1.00 Mouse [ELAN1201:00 04F3:3054] on i2c-ELAN1201:00
/var/log/Xorg.0.log:
[ 56.157] 
X.Org X Server 1.20.11
X Protocol Version 11, Revision 0
[ 56.173] Build Operating System: Linux 5.8.0-59-generic x86_64 
[ 56.179] Current Operating System: Linux PC 5.10.27-gentoo #3 SMP Tue May 4 22:37:17 MSK 2021 x86_64
[ 56.179] Kernel command line: BOOT_IMAGE=/vmlinuz-5.10.27-gentoo root=/dev/mmcblk0p2 ro
[ 56.190] Build Date: 08 July 2021 11:59:39AM
[ 56.195] 
[ 56.201] Current version of pixman: 0.40.0
[ 56.211] Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
[ 56.212] Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[ 56.235] (==) Log file: "/var/log/Xorg.0.log", Time: Thu Jul 8 09:47:04 2021
[ 56.266] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[ 56.268] (==) No Layout section. Using the first Screen section.
[ 56.268] (==) No screen section available. Using defaults.
[ 56.268] (**) |-->Screen "Default Screen Section" (0)
[ 56.268] (**) | |-->Monitor "<default monitor>"
[ 56.269] (==) No monitor specified for screen "Default Screen Section".
Using a default monitor configuration.
[ 56.269] (==) Not automatically adding devices
[ 56.269] (==) Not automatically enabling devices
[ 56.269] (==) Not automatically adding GPU devices
[ 56.269] (==) Max clients allowed: 256, resource mask: 0x1fffff
[ 56.271] (WW) The directory "/usr/share/fonts/X11//TTF/" does not exist.
[ 56.271] Entry deleted from font path.
[ 56.271] (WW) The directory "/usr/share/fonts/X11//OTF/" does not exist.
[ 56.271] Entry deleted from font path.
[ 56.271] (WW) The directory "/usr/share/fonts/X11//Type1/" does not exist.
[ 56.271] Entry deleted from font path.
[ 56.272] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/X11//100dpi/".
[ 56.272] Entry deleted from font path.
[ 56.272] (Run 'mkfontdir' on "/usr/share/fonts/X11//100dpi/").
[ 56.272] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/X11//75dpi/".
[ 56.272] Entry deleted from font path.
[ 56.272] (Run 'mkfontdir' on "/usr/share/fonts/X11//75dpi/").
[ 56.272] (==) FontPath set to:
/usr/share/fonts/X11//misc/
[ 56.272] (==) ModulePath set to "/usr/lib/xorg/modules"
[ 56.272] (==) |-->Input Device "<default pointer>"
[ 56.272] (==) |-->Input Device "<default keyboard>"
[ 56.272] (==) No Layout section. Using the default mouse configuration.
[ 56.272] (==) No Layout section. Using the default keyboard configuration.
[ 56.272] (II) Loader magic: 0x600a20
[ 56.272] (II) Module ABI versions:
[ 56.272] X.Org ANSI C Emulation: 0.4
[ 56.272] X.Org Video Driver: 24.1
[ 56.272] X.Org XInput driver : 24.1
[ 56.272] X.Org Server Extension : 10.0
[ 56.277] (--) PCI:*([email protected]:2:0) 8086:3185:1043:11f1 rev 3, Mem @ 0xa0000000/16777216, 0x90000000/268435456, I/O @ 0x0000f000/64, BIOS @ 0x????????/131072
[ 56.277] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
[ 56.277] (==) Matched intel as autoconfigured driver 0
[ 56.277] (==) Matched modesetting as autoconfigured driver 1
[ 56.277] (==) Matched fbdev as autoconfigured driver 2
[ 56.277] (==) Matched vesa as autoconfigured driver 3
[ 56.277] (==) Assigned the driver to the xf86ConfigLayout
[ 56.278] (II) LoadModule: "intel"
[ 56.279] (II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so
[ 56.283] (II) Module intel: vendor="X.Org Foundation"
[ 56.283] compiled for 1.20.11, module version = 2.99.917
[ 56.283] Module class: X.Org Video Driver
[ 56.283] ABI class: X.Org Video Driver, version 24.1
[ 56.283] (II) LoadModule: "modesetting"
[ 56.283] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[ 56.284] (II) Module modesetting: vendor="X.Org Foundation"
[ 56.284] compiled for 1.20.11, module version = 1.20.11
[ 56.284] Module class: X.Org Video Driver
[ 56.284] ABI class: X.Org Video Driver, version 24.1
[ 56.284] (II) LoadModule: "fbdev"
[ 56.285] (WW) Warning, couldn't open module fbdev
[ 56.285] (EE) Failed to load module "fbdev" (module does not exist, 0)
[ 56.285] (II) LoadModule: "vesa"
[ 56.285] (WW) Warning, couldn't open module vesa
[ 56.285] (EE) Failed to load module "vesa" (module does not exist, 0)
[ 56.285] (II) LoadModule: "mouse"
[ 56.286] (II) Loading /usr/lib/xorg/modules/input/mouse_drv.so
[ 56.286] (II) Module mouse: vendor="X.Org Foundation"
[ 56.286] compiled for 1.20.11, module version = 1.9.3
[ 56.287] Module class: X.Org XInput Driver
[ 56.287] ABI class: X.Org XInput driver, version 24.1
[ 56.287] (II) LoadModule: "kbd"
[ 56.287] (II) Loading /usr/lib/xorg/modules/input/kbd_drv.so
[ 56.288] (II) Module kbd: vendor="X.Org Foundation"
[ 56.288] compiled for 1.20.11, module version = 1.9.0
[ 56.288] Module class: X.Org XInput Driver
[ 56.288] ABI class: X.Org XInput driver, version 24.1
[ 56.288] (II) intel: Driver for Intel(R) Integrated Graphics Chipsets:
i810, i810-dc100, i810e, i815, i830M, 845G, 854, 852GM/855GM, 865G,
915G, E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM,
Pineview G, 965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33,
GM45, 4 Series, G45/G43, Q45/Q43, G41, B43
[ 56.289] (II) intel: Driver for Intel(R) HD Graphics
[ 56.289] (II) intel: Driver for Intel(R) Iris(TM) Graphics
[ 56.289] (II) intel: Driver for Intel(R) Iris(TM) Pro Graphics
[ 56.289] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[ 56.289] (--) using VT number 2

[ 56.318] (II) intel(0): Using Kernel Mode Setting driver: i915, version 1.6.0 20200917
[ 56.331] (WW) Falling back to old probe method for modesetting
[ 56.333] (--) intel(0): gen9 engineering sample
[ 56.333] (--) intel(0): CPU: x86-64, sse2, sse3, ssse3, sse4.1, sse4.2; using a maximum of 2 threads
[ 56.333] (II) intel(0): Creating default Display subsection in Screen section
"Default Screen Section" for depth/fbbpp 24/32
[ 56.333] (==) intel(0): Depth 24, (--) framebuffer bpp 32
[ 56.333] (==) intel(0): RGB weight 888
[ 56.333] (==) intel(0): Default visual is TrueColor
[ 56.336] (II) intel(0): Output eDP1 has no monitor section
[ 56.336] (**) intel(0): Found backlight control interface intel_backlight (type 'raw') for output eDP1
[ 56.336] (II) intel(0): Enabled output eDP1
[ 56.337] (II) intel(0): Output HDMI1 has no monitor section
[ 56.337] (II) intel(0): Enabled output HDMI1
[ 56.337] (II) intel(0): Output DP1 has no monitor section
[ 56.338] (II) intel(0): Enabled output DP1
[ 56.338] (--) intel(0): Using a maximum size of 256x256 for hardware cursors
[ 56.338] (II) intel(0): Output VIRTUAL1 has no monitor section
[ 56.338] (II) intel(0): Enabled output VIRTUAL1
[ 56.338] (--) intel(0): Output eDP1 using initial mode 1366x768 on pipe 0
[ 56.338] (==) intel(0): TearFree disabled
[ 56.338] (==) intel(0): Using gamma correction (1.0, 1.0, 1.0)
[ 56.339] (==) intel(0): DPI set to (96, 96)
[ 56.339] (II) Loading sub module "dri3"
[ 56.339] (II) LoadModule: "dri3"
[ 56.339] (II) Module "dri3" already built-in
[ 56.339] (II) Loading sub module "dri2"
[ 56.339] (II) LoadModule: "dri2"
[ 56.339] (II) Module "dri2" already built-in
[ 56.339] (II) Loading sub module "present"
[ 56.339] (II) LoadModule: "present"
[ 56.339] (II) Module "present" already built-in
[ 56.339] (II) UnloadModule: "modesetting"
[ 56.339] (II) Unloading modesetting
[ 56.343] (II) intel(0): SNA initialized with Geminilake (gen9) backend
[ 56.343] (==) intel(0): Backing store disabled
[ 56.343] (==) intel(0): Silken mouse enabled
[ 56.343] (II) intel(0): HW Cursor enabled
[ 56.345] (==) intel(0): DPMS enabled
[ 56.345] (II) intel(0): [DRI2] Setup complete
[ 56.345] (II) intel(0): [DRI2] DRI driver: i965
[ 56.345] (II) intel(0): [DRI2] VDPAU driver: va_gl
[ 56.345] (II) intel(0): direct rendering: DRI2 enabled
[ 56.345] (II) intel(0): hardware support for Present enabled
[ 56.345] (II) Initializing extension Generic Event Extension
[ 56.345] (II) Initializing extension SHAPE
[ 56.345] (II) Initializing extension MIT-SHM
[ 56.345] (II) Initializing extension XInputExtension
[ 56.346] (II) Initializing extension XTEST
[ 56.346] (II) Initializing extension BIG-REQUESTS
[ 56.346] (II) Initializing extension SYNC
[ 56.346] (II) Initializing extension XKEYBOARD
[ 56.346] (II) Initializing extension XC-MISC
[ 56.346] (II) Initializing extension XFIXES
[ 56.346] (II) Initializing extension RENDER
[ 56.346] (II) Initializing extension RANDR
[ 56.346] (II) Initializing extension DAMAGE
[ 56.346] (II) Initializing extension DOUBLE-BUFFER
[ 56.346] (II) Initializing extension RECORD
[ 56.346] (II) Initializing extension DPMS
[ 56.346] (II) Initializing extension Present
[ 56.346] (II) Initializing extension DRI3
[ 56.347] (II) Initializing extension X-Resource
[ 56.347] (II) Initializing extension XVideo
[ 56.347] (II) Initializing extension XVideo-MotionCompensation
[ 56.347] (II) Initializing extension XFree86-VidModeExtension
[ 56.347] (II) Initializing extension XFree86-DGA
[ 56.347] (II) Initializing extension DRI2
[ 56.352] (II) intel(0): switch to mode [email protected] on eDP1 using pipe 0, position (0, 0), rotation normal, reflection none
[ 56.356] (II) intel(0): Setting screen physical size to 361 x 203
[ 56.463] (II) Using input driver 'mouse' for '<default pointer>'
[ 56.463] (**) Option "CorePointer" "on"
[ 56.463] (**) <default pointer>: always reports core events
[ 56.463] (WW) <default pointer>: No Device specified, looking for one...
[ 56.463] (EE) <default pointer>: Cannot find which device to use.
[ 56.463] (==) <default pointer>: Protocol: "Auto"
[ 56.463] (**) <default pointer>: always reports core events
[ 56.463] (EE) xf86OpenSerial: No Device specified.
[ 56.463] (EE) <default pointer>: cannot open input device
[ 56.463] (EE) PreInit returned 2 for "<default pointer>"
[ 56.463] (II) UnloadModule: "mouse"
[ 56.463] (II) Using input driver 'kbd' for '<default keyboard>'
[ 56.463] (**) Option "CoreKeyboard" "on"
[ 56.463] (**) <default keyboard>: always reports core events
[ 56.463] (**) <default keyboard>: always reports core events
[ 56.463] (**) Option "Protocol" "standard"
[ 56.463] (**) Option "XkbRules" "base"
[ 56.463] (**) Option "XkbModel" "pc105"
[ 56.463] (**) Option "XkbLayout" "us"
[ 56.463] (II) XINPUT: Adding extended input device "<default keyboard>" (type: KEYBOARD, id 6)
[ 58.346] (II) intel(0): EDID vendor "AUO", prod id 8796
[ 58.346] (II) intel(0): Printing DDC gathered Modelines:
[ 58.346] (II) intel(0): Modeline "1366x768"x0.0 76.30 1366 1404 1426 1592 768 771 777 798 -hsync -vsync (47.9 kHz eP)
[ 60.683] (II) UnloadModule: "kbd"
[ 60.696] (II) Server terminated successfully (0). Closing log file.
 

Amirk

New Member
Credits
150
Distro: busybox+systemv+xorgserver
Problem: x server starts with xinit and keyboard works, but mouse doesn’t work. And if I start another distro(gentoo) with the same kernel, mouse works.
Desktop environment: openbox+xinit
 
Last edited:

Tolkem

Well-Known Member
Credits
8,516
Distro: busybox+systemv+xorgserver
Busybox isn't a distro, it is a set of programs, and some distros use it instead of glibc, i.e. Alpine.
Problem: x server starts with xinit and keyboard works, but mouse doesn’t work.
Do you have libinput(or whatever the equivalent is in your distro)installed? https://pkgs.org/search/?q=libinput
Desktop environment: openbox+xinit
Check openbox docs http://openbox.org/wiki/Main_Page and arch wiki page on openbox as well https://wiki.archlinux.org/title/Openbox maybe something there might help you solve your issue.
 

Lord Boltar

Well-Known Member
Credits
5,968
If you look at the dmesg
[ 56.179] Current Operating System: Linux PC 5.10.27-gentoo #3 SMP Tue May 4 22:37:17 MSK 2021 x86_64
It looks like Gentoo with kernel 5.10.27 -
also an Elantech touchpad
[ 0.970465] input: ELAN1201:00 04F3:3054 Touchpad
Elantech does not play well with Xorg - which is probably causing some of the warnings listed below in the dmesg
[ 56.277] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
[ 56.285] (WW) Warning, couldn't open module vesa
[ 56.331] (WW) Falling back to old probe method for modesetting
[ 56.463] (WW) <default pointer>: No Device specified, looking for one
 
Last edited:

brickwizard

Well-Known Member
Credits
6,724
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Members online


Top