Welcome to Our Community

While Linux.org has been around for a while, we recently changed management and had to purge most of the content (including users). If you signed up before April 23rd, 2017 please sign up again. Thanks!

  1. Note: we recently updated out site software, please report any unseen issues - we do this often to insure your information is secure.
    Dismiss Notice

mkfs issues

Discussion in 'Linux Hardware' started by CptCharis, Feb 27, 2018.

Tags:
  1. CptCharis

    CptCharis Active Member

    Joined:
    Feb 27, 2018
    Messages:
    147
    Likes Received:
    137
    Hello guys!!!

    I'm trying to fix a broken external disk
    I'm using fdisk tool & everything going well till the moment I'm starting mkfs command
    It returns a msg :Failed to make "FAT" file system or something similar anyway
    The same problem appears also trying to fix it in Windows
    Do you thing that is something else that logical error?

    External disk had had never an accident.

    Thanks in advance
    Top


     
  2. nuna

    nuna Member

    Joined:
    Aug 29, 2017
    Messages:
    36
    Likes Received:
    57
    Welcome @CptCharis. It could be a logical error (damaged partition structure or filesystem) or something else like a hardware error. To provide better help we need more details, like the symptoms that makes you think the external disk is broken, the type or size format of the disk...

    If it's just to format it there are graphical tools to ease the job (gparted, Disks utility or alike), but it the hard disk has some issues the programs might fail as well. We aware that by formatting it you'll lose the files/data on the disk.

    On external hard disks you may hear a clicking noise (i.e. damaged heads, head crash), or hear the motor and the platters spin and stop (not enough power)... Sometimes the controller of the external case fails while the disk inside it is ok, &c.

    On a GNU/Linux system you may retrieve some information using dmesg command after connecting the drive: it might show some warnings or errors.
    fdisk -l and parted -l can show partitions and some hard disk details.
    Another useful command is smartctl (or some of its graphical frontends, like GSmartControl) which allows you to see the S.M.A.R.T. status (i.e. the number of pending and reallocated sectors) and do some health self-tests.
    Sometimes, to correct filesystem issues, TestDisk comes in handy.
     
    atanere and wizardfromoz like this.
  3. CptCharis

    CptCharis Active Member

    Joined:
    Feb 27, 2018
    Messages:
    147
    Likes Received:
    137
    Hello @nuna. Thanks for your time.

    I don't really know the history of external disk but once came to me, it could be recognized by PC but works really slow.
    For example try to open a word or exel file and if finally open it tooks more than five minutes.
    Even copy-paste I tried, in order to save the archives inside, never completed, if you know what i mean.
    The owner of the disk is pretty sure that never happen any accident to his external disk. Also no any strange noise is coming from it.
    File system was NTFS and the model is WD MyPassport Ultra 2 Tb, and it was almost full,1.7 Tb out of 1.8 Tb total memory.
    After that I tried dd command but also it took 1 hour to copy 300 Mb ( I don't know, is this sound OK to you?)

    Finally I decide to erase everything inside and I used windows and DISKPART tool for erase everything and make new file system.
    When this failed I tried with Linux, fdisk tool, but the results were similar.
    I tried also gparted & similar Windows programs without results. Moreover bcz I'm a newbie I prefer CLI for my training ;-)
    Anyway i will try your suggestions and I will be back.

    Thanks again for your time.
     
    atanere and wizardfromoz like this.
  4. wizardfromoz

    wizardfromoz Well-Known Member

    Joined:
    Apr 30, 2017
    Messages:
    871
    Likes Received:
    972
    Hi @CptCharis and welcome to linux.org :p

    I am from DownUnder (Australia) and so will be on and offline at different times.

    I sense English is not your first language, is that so? If so, I will try to explain things in clear terms.

    You also seem to have some experience with Linux.

    May I ask what version of Windows you are using?

    I would like to get you to check through Disk Management that the WD MyPassport Ultra 2 Tb is on MBR, or if it is on GPT.

    Over and out for now, enjoy ;)

    Chris Turner
    wizardfromoz
     
    atanere likes this.
  5. CptCharis

    CptCharis Active Member

    Joined:
    Feb 27, 2018
    Messages:
    147
    Likes Received:
    137
    Hello @wizardfromoz

    Nice to hear you.

    Nope English is not my mother language, but I'm trying a lot. :)
    Actually due to the reason I'm on board the vessel and our port home is west Australia our office time will be almost common.

    About Linux , yeap I'm a newbie but I'm f**cking excited!!!
    Hope I knew it earlier but if your age is real, never is late!!!

    Windows version that I used it's 7 professional and external disc is not any more recognized
    In Linux by other hand I have upload some pictures FYR

    Can you check and tell me?
    I don't really care anymore for the HDD, what I want is to learn things. (of course is an expansive one)

    Hope guys you can see the photos!!!
    I use Linux Mint 18.3 by the way & maybe you know how to make print screen only the active window? Screenshot 2.png
    Screenshot 1.png Screenshot at 2018-02-28 11-36-57.png
     

    Attached Files:

    atanere and wizardfromoz like this.
  6. CptCharis

    CptCharis Active Member

    Joined:
    Feb 27, 2018
    Messages:
    147
    Likes Received:
    137
    Hello again @nuna.

    I tried dmesg command and Ihad this results.
    Do you have any idea what's is going on?
    If I undrstand well the first is about the built in camera which is not working and the rest are about the HDD,
    is that correct? Screenshot at 2018-02-28 12-52-15.png Screenshot at 2018-02-28 12-52-24.png

    Screenshot at 2018-02-28 12-52-01.png
     
    atanere and wizardfromoz like this.
  7. nuna

    nuna Member

    Joined:
    Aug 29, 2017
    Messages:
    36
    Likes Received:
    57
    Such slowness and I/O errors are often caused by bad blocks.
    Have into account WD MyPassport Ultra drives have hardware encryption which can be enabled/disabled from Windows or Mac OS (no linux friendly). If you were able to access the drive contents without using any password then that does not concern you. They also come with a Virtual CD.

    From the screenshots it appears the drive is mounted in read-only mode, this could be due to bad mount parameters or filesystem errors. It also warns about partition overlapping.

    I'd rather check the drive for bad sectors, or update the WD firmware. Sadly you'll need to use Windows to accomplish some of the tasks.

    Useful Information:
     
    #7 nuna, Feb 28, 2018
    Last edited: Mar 1, 2018
    atanere, wizardfromoz and CptCharis like this.
  8. wizardfromoz

    wizardfromoz Well-Known Member

    Joined:
    Apr 30, 2017
    Messages:
    871
    Likes Received:
    972
    (Wizard appears in a puff of smoke, doesn't set off sprinkler system...damn)

    Good morning Capta, and yes, you are 2 hours behind me, I am in Southeast Queensland.

    In your Linux Mint, you can find GNOME's Screenshot under Menu - Accessories or by starting to type it in. It will allow you to set a time delay, capture the active window, etc.

    On Linux Mint, you can let us know what DE (Desktop Environment) you are using, by typing in at Terminal

    Code:
    echo $DESKTOP_SESSION
    ... or by Menu - Welcome Screen.

    If you wish to read more on DEs available under Linux

    https://renewablepcs.wordpress.com/about-linux/kde-gnome-or-xfce/

    Also, and given you are using the Mint 18.3 series - this is the first of theirs to ship with Timeshift installed, which will be of use to you.

    See my Tutorial here

    https://www.linux.org/threads/timeshift-similar-solutions-safeguard-recover-your-linux.15241/

    If you have not already done so with your Linux Mint, you should enable your Uncomplicated FireWall - ufw

    Code:
    sudo ufw enable
    And as for my age, see below



    Your pictures are fine, by the way :)

    Cheers

    Chris Turner
    wizardfromoz
     
    atanere likes this.
  9. CptCharis

    CptCharis Active Member

    Joined:
    Feb 27, 2018
    Messages:
    147
    Likes Received:
    137
    Good morning @wizardofoz

    Nice to meet you :)
    Thanks for your links & your video. Unfortunately the ship's Internet speed is not allow me to see videos, I will check ti at the port.
    By the way my DE is MATE . I use MATE bcz during downloading said "if you DON'T know what to download , download MATE"

    Wizard I really want my knowledge about Linux and Computing to achieve your level, can you help me ?
    e.x with some links or tutorials ?

    Thanks a lot
     
    atanere likes this.
  10. wizardfromoz

    wizardfromoz Well-Known Member

    Joined:
    Apr 30, 2017
    Messages:
    871
    Likes Received:
    972
    Just for purposes of accuracy ... wizardofoz is already taken, I am wizardfromoz. If you start to type in a Member's user id, with an @ , you will get the autocomplete function, just click the right-hand part you have not typed yet, and it will insert, followed by a space.

    Hi, Capta, and you are welcome and I am humbled. But there are many here whom know far more than I on a range of interesting Topics.

    If you wish to get a few leads/ideas, perhaps start a new thread in General Linux or Getting Started, and people will zoom in and provide suggestions, myself included :p

    There, I can recommend at least one free study course, and someone may beat me to it.

    Cheers

    Wizard
     
    atanere likes this.
  11. CptCharis

    CptCharis Active Member

    Joined:
    Feb 27, 2018
    Messages:
    147
    Likes Received:
    137
    Hahahaha @wizardfromoz sorry about that!!!

    And thank you for your links

    C u around

    Cheers!!! ;-)
     
    wizardfromoz likes this.
  12. atanere

    atanere Moderator
    Gold Supporter

    Joined:
    Apr 6, 2017
    Messages:
    1,163
    Likes Received:
    1,153
    Hi @CptCharis, and welcome! I noticed on your screenshots that you have already installed gdisk... a nice utility with a little more power that the standard fdisk.

    I have a small 4GB flash drive that also showed the overlapping partitions, however it has been working fine. But I decided to use that for a little experimenting so that maybe it will help your problem too. This will destroy all the data on your external hard drive though. And if the drive has actual hardware problems, this will not help that.

    So, you want to unmount the drive before using gdisk, but the mounted partition is probably sdb1. Confirm with mount:
    Code:
    mount    #you will probably see /dev/sdb1 near the bottom

    Unmount as root with sudo (note that umount is correct... not unmount):
    Code:
    sudo umount /dev/sdb1

    Next, run gdisk and go into expert mode:
    Code:
    sudo gdisk /dev/sdb
    x    #this puts you in expert mode

    Then, in expert mode, give it the z command to zap the drive:
    Code:
    z

    Answer Y for the following two questions it will present to you:
    Code:
    About to wipe out GPT on /dev/sdb. Proceed? (Y/N):
    Blank out MBR? (Y/N):

    On completing this step, gdisk will automatically exit. Next run Gparted and use the dropdown box to select /dev/sdb. You will see that it is totally "unallocated" (empty and unformatted). Click on Device on the top menu, and choose Create Partition Table. For "Select new partition table type" change the selection from msdos to gpt, and then click Apply. It will still show the drive as "unallocated" at this point. Next, click on Partition on the top menu, and choose New. The only thing to change on the screen is File System.... FAT32 or NTFS are both good choices, but FAT32 is more common on smaller drives like my flash drive, and NTFS might be better for larger drives such as yours. Both FAT32 and NTFS will allow your drive to be plugged into Linux or Windows computers and be usable. After choosing the file system, click the Add button. The final step now is to click the Apply button on the top menu... the arrow icon on the far right. When its finished, you will have a single very large usable partition, and also a very small partition at the end of the drive.... leave the small partition alone as this seems to be the proper configuration for GPT formatted drives. Exit Gparted.

    Now, if you check again with gdisk, and if your luck matches mine, you will find that it reports, "Found valid GPT with protective MBR; using GPT." and it no longer reports the overlapping partitions. This worked for me with both FAT32 and NTFS choices, but if I used msdos instead of gpt, then the overlapping partition error returned.

    With a lot of luck, maybe you will be able to use the drive again with reasonable file transfer speeds, but of course these steps won't help if the drive is truly defective.

    Good luck!
     
    CptCharis and wizardfromoz like this.
  13. CptCharis

    CptCharis Active Member

    Joined:
    Feb 27, 2018
    Messages:
    147
    Likes Received:
    137
    Hi @atanere thank you very much for you advises

    I will try and i will let you know.

    Something else how can I understand all this infos coming out , like this in my screen shoots?
    of course I can understand that something is wrong bcz is red :) or print out error but I mean, what are all this infos
    Is there any specific tutorial?

    Thanks a lot.
     
    atanere likes this.
  14. CptCharis

    CptCharis Active Member

    Joined:
    Feb 27, 2018
    Messages:
    147
    Likes Received:
    137
    Hello agian @atanere
    You r fu***cking magician . HDD it works but as the size of file/archive getting bigger the speed reducing
    But it works my friend. only in Linux but it works!!!!
    Thanks a lot.
    Thnak you everybody for your time

    As @wizardfromoz says Cheers ;)
     
    wizardfromoz and atanere like this.
  15. atanere

    atanere Moderator
    Gold Supporter

    Joined:
    Apr 6, 2017
    Messages:
    1,163
    Likes Received:
    1,153
    Hey, glad it seems to work... but it should work in Windows too if you used FAT32 or NTFS (and not ext4) file system. The ext4 would be Linux only, so if you picked that you can use Gparted to format it to FAT32 or NTFS instead.

    No magic though... that's Wizard's department. I'm just a fat hobbit having my 2nd breakfast, and catching up on the forum news for the day. :D

    There is a ton of information on the internet.... you really want to make Google your best friend as you learn Linux. There are tutorials, free training courses, YouTube videos.... literally a wealth of information for you to dig into. But there isn't really a "START HERE" point. You've already started, and you seem to be doing very well. :cool::D

    Linux Mint offers a PDF "Users Guide" that is about 1.8 MB, a pretty small download. You can get it here. It is based on the Cinnamon edition, so it will be slightly different from your MATE edition, but it is close enough to help you. The dmesg output that shows color is a built-in option to the dmesg command itself, and it is usually set to show colors by default, but you can turn off the colors if you wanted to.

    When using the command line (terminal) there is a built-in set of help files called the "man pages" (man = manual). So for just about any command you would use, you can quickly look up how the command operates and what options are available with it. Below is a simple command that reports who the current user is (you)... run the command, and then run the man page and it will explain it better.
    Code:
    whoami
    man whoami

    For something more complicated (but frequently used) from the command line, check out the "list" command, ls:
    Code:
    ls
    man ls
    You'll see the output of ls shows you the files and folders from wherever you started, probably your home folder. With Linux Mint, you will see that the ls output is color-coded also. There are many options for the ls command to help you to identify the files and folders on your system. Not every distro does color-coding, or they may use different colors, so you also need to expect and be prepared for different things if you use a different Linux distro.

    Use Google to search for "Linux cheat sheets" which will give you a lot of short lists of popular Linux commands. But there are other cheat sheets too. You can also search for "vi cheat sheets" (vi is a built-in text editor included with probably every Linux distro, but a new user needs a cheat sheet to begin to learn its special way of operation). Some other special commands used for file and/or text manipulation are sed and awk, and there are many cheat sheets available to help with those too. Those things are more for your later learning though... don't worry about them now. A cheat sheet just for Linux commands could be handy for you now though.

    Cheers
     
    wizardfromoz likes this.
  16. CptCharis

    CptCharis Active Member

    Joined:
    Feb 27, 2018
    Messages:
    147
    Likes Received:
    137
    Hello @atanere

    I did it , I used ntfs , bcz is a big HDD but , I don't know why all windows PC that I used couldn't "see" it
    only in my personal laptop which run Linux can I use it, with the "restrictions" I referred above.
    Anyway , as a Greek poet said : doesn't matter the destination but the trip itself ;)
    Cheers !!!
     
  17. onliveserver

    onliveserver New Member

    Joined:
    Apr 12, 2018
    Messages:
    2
    Likes Received:
    1
    it should ne dependence mkfs to fdisk partition
     
    wizardfromoz likes this.

Share This Page